aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgienah <gienah@gentoo.org>2014-10-13 21:20:08 +1100
committergienah <gienah@gentoo.org>2014-10-13 21:20:08 +1100
commit1cfde85a3a210cfa6f5eb98096dc56dc0005e090 (patch)
tree43fcdbaf438f0f23674ef5c75fdfb770b92c1c0b /virtual/blas
parentmultilib int64 multibuild xblas. The int64 build may not work though, not tes... (diff)
downloadsci-1cfde85a3a210cfa6f5eb98096dc56dc0005e090.tar.gz
sci-1cfde85a3a210cfa6f5eb98096dc56dc0005e090.tar.bz2
sci-1cfde85a3a210cfa6f5eb98096dc56dc0005e090.zip
Bump the blas virtual to add int64 supplort for blas-reference.
Diffstat (limited to 'virtual/blas')
-rw-r--r--virtual/blas/ChangeLog5
-rw-r--r--virtual/blas/blas-2.1-r3.ebuild44
2 files changed, 49 insertions, 0 deletions
diff --git a/virtual/blas/ChangeLog b/virtual/blas/ChangeLog
index ec884e087..29295b342 100644
--- a/virtual/blas/ChangeLog
+++ b/virtual/blas/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/virtual/blas/ChangeLog,v 1.3 2010/01/11 10:55:38 ulm Exp $
+*blas-2.1-r3 (13 Oct 2014)
+
+ 13 Oct 2014; Mark Wright <gienah@gentoo.org> +blas-2.1-r3.ebuild:
+ Bump the blas virtual to add int64 supplort for blas-reference.
+
*blas-2.1-r2 (26 Apr 2014)
26 Apr 2014; Mark Wright <gienah@gentoo.org> +blas-2.1-r2.ebuild,
diff --git a/virtual/blas/blas-2.1-r3.ebuild b/virtual/blas/blas-2.1-r3.ebuild
new file mode 100644
index 000000000..f06189ebe
--- /dev/null
+++ b/virtual/blas/blas-2.1-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Virtual for FORTRAN 77 BLAS implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc int64"
+
+RDEPEND="
+ int64? (
+ || (
+ >=sci-libs/openblas-0.2.11[int64]
+ >=sci-libs/blas-reference-20131116-r1[int64]
+ )
+ )
+ || (
+ >=sci-libs/blas-reference-20131116-r1[int64?]
+ >=dev-cpp/eigen-3.1.2
+ sci-libs/atlas[fortran]
+ >=sci-libs/openblas-0.2.11[int64?]
+ >=sci-libs/acml-4.4
+ sci-libs/gotoblas2
+ >=sci-libs/mkl-10.3
+ )
+ doc? ( >=app-doc/blas-docs-3.2 )"
+DEPEND=""
+
+pkg_pretend() {
+ if [[ -e "${EROOT%/}"/usr/$(get_libdir)/lib${PN}.so ]]; then
+ ewarn "You have still the old ${PN} library symlink present"
+ ewarn "Please delete"
+ ewarn "${EROOT%/}/usr/$(get_libdir)/lib${PN}.so"
+ ewarn "to avoid problems with new ${PN} structure"
+ fi
+}