aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-28 09:15:54 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-28 09:15:54 +0100
commit3881348dbe9cacb8d1712bb0b8acd8104b5aa427 (patch)
tree24bc6bee096161ce7091242fc339c4795139173d /virtual/cblas/cblas-2.0-r4.ebuild
parentvirtual/lapacke: Version Bump, add ABI_X86 and int64 support (diff)
downloadsci-3881348dbe9cacb8d1712bb0b8acd8104b5aa427.tar.gz
sci-3881348dbe9cacb8d1712bb0b8acd8104b5aa427.tar.bz2
sci-3881348dbe9cacb8d1712bb0b8acd8104b5aa427.zip
virtual/cblas: Update deps, Drop unsupported ABIs
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'virtual/cblas/cblas-2.0-r4.ebuild')
-rw-r--r--virtual/cblas/cblas-2.0-r4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/virtual/cblas/cblas-2.0-r4.ebuild b/virtual/cblas/cblas-2.0-r4.ebuild
new file mode 100644
index 000000000..46fdf7998
--- /dev/null
+++ b/virtual/cblas/cblas-2.0-r4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for BLAS C implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="int64"
+
+RDEPEND="
+ || (
+ >=sci-libs/cblas-reference-20110218-r1[int64?,${MULTILIB_USEDEP}]
+ >=sci-libs/openblas-0.2.11[int64?,${MULTILIB_USEDEP}]
+ >=sci-libs/gsl-1.16-r2[-cblas-external,${MULTILIB_USEDEP}]
+ >=sci-libs/gotoblas2-1.13[int64?,${MULTILIB_USEDEP}]
+ sci-libs/mkl[int64?,${MULTILIB_USEDEP}]
+ abi_x86_64? ( !abi_x86_32? ( >=sci-libs/atlas-3.9.34 ) )
+ )
+ int64? (
+ || (
+ >=sci-libs/openblas-0.2.11[int64,${MULTILIB_USEDEP}]
+ >=sci-libs/cblas-reference-20110218-r1[int64,${MULTILIB_USEDEP}]
+ >=sci-libs/gotoblas2-1.13[int64,${MULTILIB_USEDEP}]
+ sci-libs/mkl[int64,${MULTILIB_USEDEP}]
+ )
+ )"
+DEPEND=""