aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorgienah <gienah@gentoo.org>2014-09-07 02:42:37 +1000
committergienah <gienah@gentoo.org>2014-09-27 21:10:07 +1000
commit915f693ca57021b9b2ba191991215ebbe94eac05 (patch)
treedcc9cf35b99c376243384d7676016e46fc41bfba /virtual/lapack
parentmasking int64 flag for 32 bits arches (diff)
downloadsci-915f693ca57021b9b2ba191991215ebbe94eac05.tar.gz
sci-915f693ca57021b9b2ba191991215ebbe94eac05.tar.bz2
sci-915f693ca57021b9b2ba191991215ebbe94eac05.zip
Add int64 use flag for separate eselect modules for int64 providers
Diffstat (limited to 'virtual/lapack')
-rw-r--r--virtual/lapack/ChangeLog6
-rw-r--r--virtual/lapack/lapack-3.5-r2.ebuild33
-rw-r--r--virtual/lapack/metadata.xml4
3 files changed, 43 insertions, 0 deletions
diff --git a/virtual/lapack/ChangeLog b/virtual/lapack/ChangeLog
index f2d88bb85..cd1f5c67b 100644
--- a/virtual/lapack/ChangeLog
+++ b/virtual/lapack/ChangeLog
@@ -2,6 +2,12 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/virtual/lapack/ChangeLog,v 1.5 2010/01/11 11:04:19 ulm Exp $
+*lapack-3.5-r2 (26 Apr 2014)
+
+ 26 Apr 2014; Mark Wright <gienah@gentoo.org> +lapack-3.5-r2.ebuild,
+ metadata.xml:
+ Add int64 use flag for separate eselect modules for int64 providers
+
11 Feb 2014; Justin Lecher <jlec@gentoo.org> -lapack-3.5.ebuild,
+lapack-3.5-r1.ebuild:
Add missing inherite from multilib.eclass, thanks dev-zero spotting this
diff --git a/virtual/lapack/lapack-3.5-r2.ebuild b/virtual/lapack/lapack-3.5-r2.ebuild
new file mode 100644
index 000000000..d89f0e0cf
--- /dev/null
+++ b/virtual/lapack/lapack-3.5-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Virtual for Linear Algebra Package FORTRAN 77 implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc int64"
+
+RDEPEND="
+ || (
+ >=sci-libs/lapack-reference-${PV}
+ >=sci-libs/atlas-3.10.1[lapack]
+ )
+ doc? ( >=app-doc/lapack-docs-3.3 )"
+DEPEND=""
+
+pkg_pretend() {
+ if [[ -e "${EROOT%/}"/usr/$(get_libdir)/lib${PN}.so ]]; then
+ ewarn "You have still the old ${PN} library symlink present"
+ ewarn "Please delete"
+ ewarn "${EROOT%/}/usr/$(get_libdir)/lib${PN}.so"
+ ewarn "to avoid problems with new ${PN} structure"
+ fi
+}
diff --git a/virtual/lapack/metadata.xml b/virtual/lapack/metadata.xml
index e16cd365b..544d38ecc 100644
--- a/virtual/lapack/metadata.xml
+++ b/virtual/lapack/metadata.xml
@@ -7,4 +7,8 @@
FORTRAN 77 implementation. The version number corresponds to the
version of the LAPACK reference implementation.
</longdescription>
+<use>
+ <flag name="int64">Add eselect module for lapack libraries built with 64 bits
+ integer ABI</flag>
+</use>
</pkgmetadata>