aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-11-10 16:33:37 -0700
committerChristoph Junghans <ottxor@gentoo.org>2014-11-10 16:33:37 -0700
commit18d61d4db02599198a3bac4e64f41d509e563cc7 (patch)
tree1c241ab31f20a2020cbf712979b2aa8981a76e43 /virtual
parentadded multilib support (bug #528622) (diff)
downloadsci-18d61d4db02599198a3bac4e64f41d509e563cc7.tar.gz
sci-18d61d4db02599198a3bac4e64f41d509e563cc7.tar.bz2
sci-18d61d4db02599198a3bac4e64f41d509e563cc7.zip
added multilib support (bug #528622)
Package-Manager: portage-2.2.8-r2
Diffstat (limited to 'virtual')
-rw-r--r--virtual/cblas/ChangeLog5
-rw-r--r--virtual/cblas/cblas-2.0-r3.ebuild35
2 files changed, 40 insertions, 0 deletions
diff --git a/virtual/cblas/ChangeLog b/virtual/cblas/ChangeLog
index fce923850..7c01c5f54 100644
--- a/virtual/cblas/ChangeLog
+++ b/virtual/cblas/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/virtual/cblas/ChangeLog,v 1.6 2010/01/11 10:56:05 ulm Exp $
+*cblas-2.0-r3 (10 Nov 2014)
+
+ 10 Nov 2014; Christoph Junghans <ottxor@gentoo.org> +cblas-2.0-r3.ebuild:
+ added multilib support (bug #528622)
+
*cblas-2.0-r2 (13 Oct 2014)
13 Oct 2014; Mark Wright <gienah@gentoo.org> +cblas-2.0-r2.ebuild:
diff --git a/virtual/cblas/cblas-2.0-r3.ebuild b/virtual/cblas/cblas-2.0-r3.ebuild
new file mode 100644
index 000000000..b7a94e8f4
--- /dev/null
+++ b/virtual/cblas/cblas-2.0-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for BLAS C implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="int64"
+
+RDEPEND="
+ int64? (
+ || (
+ >=sci-libs/openblas-0.2.11[int64,${MULTILIB_USEDEP}]
+ >=sci-libs/cblas-reference-20110218-r1[int64,${MULTILIB_USEDEP}]
+ )
+ )
+ || (
+ >=sci-libs/cblas-reference-20110218-r1[int64?,${MULTILIB_USEDEP}]
+ >=sci-libs/openblas-0.2.11[int64?,${MULTILIB_USEDEP}]
+ >=sci-libs/gsl-1.16-r2[-cblas-external,${MULTILIB_USEDEP}]
+ abi_x86_64? ( !abi_x86_32? ( || (
+ >=sci-libs/gotoblas2-1.13
+ >=sci-libs/atlas-3.9.34
+ >=sci-libs/mkl-10.3
+ ) ) )
+ )"
+DEPEND=""