aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-26 09:51:02 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-26 09:51:02 +0100
commit73544b0df0284161eda0cb93ce5cfa6fddbb1fbe (patch)
treee15b6f805a3d28b5b0da7aad2ea96270a4a7e0c1 /www-client/casperjs/casperjs-1.1_beta5.ebuild
parentMerge remote-tracking branch 'github/master' (diff)
downloadsci-73544b0df0284161eda0cb93ce5cfa6fddbb1fbe.tar.gz
sci-73544b0df0284161eda0cb93ce5cfa6fddbb1fbe.tar.bz2
sci-73544b0df0284161eda0cb93ce5cfa6fddbb1fbe.zip
www-client/casperjs: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'www-client/casperjs/casperjs-1.1_beta5.ebuild')
-rw-r--r--www-client/casperjs/casperjs-1.1_beta5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/www-client/casperjs/casperjs-1.1_beta5.ebuild b/www-client/casperjs/casperjs-1.1_beta5.ebuild
new file mode 100644
index 000000000..952f90888
--- /dev/null
+++ b/www-client/casperjs/casperjs-1.1_beta5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PV=${PV/_beta/-beta}
+
+DESCRIPTION="Navigation scripting & testing utility for PhantomJS and SlimerJS"
+HOMEPAGE="http://casperjs.org/"
+SRC_URI="https://github.com/n1k0/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="<www-client/phantomjs-2.0.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ return
+}
+
+src_install() {
+ insinto /usr/share/${P}/
+ doins -r modules tests package.json
+
+ insinto /usr/share/${P}/bin
+ doins bin/bootstrap.js bin/usage.txt
+
+ exeinto /usr/share/${P}/bin
+ doexe bin/casperjs
+ dosym ../share/${P}/bin/casperjs /usr/bin/casperjs
+
+ dodoc CHANGELOG.md CONTRIBUTORS.md README.md
+}