aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-astronomy/eazy/ChangeLog10
-rw-r--r--sci-astronomy/eazy/Manifest1
-rw-r--r--sci-astronomy/eazy/eazy-1.00.ebuild53
-rw-r--r--sci-astronomy/eazy/files/eazy-1.00-makefile.patch21
-rw-r--r--sci-astronomy/eazy/metadata.xml10
5 files changed, 95 insertions, 0 deletions
diff --git a/sci-astronomy/eazy/ChangeLog b/sci-astronomy/eazy/ChangeLog
new file mode 100644
index 000000000..6f99c500a
--- /dev/null
+++ b/sci-astronomy/eazy/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-astronomy/eazy
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*eazy-1.00 (11 May 2012)
+
+ 11 May 2012; Sébastien Fabbro <bicatali@gentoo.org> +eazy-1.00.ebuild,
+ +files/eazy-1.00-makefile.patch, +metadata.xml:
+ sci-astronomy/eazy: Initial import
+
diff --git a/sci-astronomy/eazy/Manifest b/sci-astronomy/eazy/Manifest
new file mode 100644
index 000000000..cc9e00529
--- /dev/null
+++ b/sci-astronomy/eazy/Manifest
@@ -0,0 +1 @@
+DIST eazy-1.00.tar.gz 4111352 SHA256 54870485a02c17f90fef43d0e074372d3ae305d9e4b18fe408a0bce1f0fbe80b SHA512 b841b4d5c3bd853cd1bcb575bc6be6cde4437521399fe978c92a448d037ace9edcdf88e8a9eef3157a722a524b8d0bb5f656559d865c6c66e52d2f07b300f78a WHIRLPOOL 617c47c905213aa671ca1ae38acdf31ff2f972f3e8e9d1f97f4d6fea6cbd75d25fd669c6e36cb9916b9b877ed339242524e52504bd7fd78f65b8dab7bc4144ce
diff --git a/sci-astronomy/eazy/eazy-1.00.ebuild b/sci-astronomy/eazy/eazy-1.00.ebuild
new file mode 100644
index 000000000..a04b6ac28
--- /dev/null
+++ b/sci-astronomy/eazy/eazy-1.00.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Photometric redshift estimator for galaxies"
+HOMEPAGE="http://www.astro.yale.edu/eazy/?home"
+SRC_URI="http://www.astro.yale.edu/eazy/download/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ cd src
+ emake
+ if use doc; then
+ cd ../doc
+ emake
+ fi
+}
+
+src_test() {
+ cd inputs
+ ../src/eazy
+ mv zphot.param.default zphot.param
+ ../src/eazy || die
+}
+
+src_install() {
+ dobin src/eazy
+ insinto /usr/share/eazy
+ doins -r templates
+ use doc && dodoc doc/eazy_manual.pdf
+ if use examples; then
+ cd inputs
+ rm templates
+ insinto /usr/share/doc/${PF}
+ doins -r *
+ dosym /usr/share/eazy/templates templates
+ fi
+}
diff --git a/sci-astronomy/eazy/files/eazy-1.00-makefile.patch b/sci-astronomy/eazy/files/eazy-1.00-makefile.patch
new file mode 100644
index 000000000..40ce53894
--- /dev/null
+++ b/sci-astronomy/eazy/files/eazy-1.00-makefile.patch
@@ -0,0 +1,21 @@
+--- src/makefile.orig 2012-05-11 04:15:35.000000000 +0100
++++ src/makefile 2012-05-11 04:15:53.000000000 +0100
+@@ -1,16 +1,14 @@
+ # -pg -lc_p for profiling
+-.c.o:
+- gcc -msse2 -c -O3 -Wall $<
+
+ all: eazy
+
+ eazy: main.o output_files.o zeropoints.o getpar.o makegrid.o interpol.o getphotz.o kmag_prior.o
+- gcc -o eazy main.o output_files.o zeropoints.o getpar.o makegrid.o interpol.o getphotz.o kmag_prior.o -lm
++ $(CC) $(LDFLAGS) main.o output_files.o zeropoints.o getpar.o makegrid.o interpol.o getphotz.o kmag_prior.o -lm -o eazy
+
+ main.o output_files.o zeropoints.o getpar.o makegrid.o interpol.o getphotz.o temperr.o kmag_prior.o : defs.h
+
+ temperr: temperr.o getpar.o
+- gcc -o temperr temperr.o getpar.o -lm
++ $(CC) $(LDFLAGS) temperr.o getpar.o -lm -o temperr
+
+ clean:
+ rm *.o eazy
diff --git a/sci-astronomy/eazy/metadata.xml b/sci-astronomy/eazy/metadata.xml
new file mode 100644
index 000000000..8ce25a1dc
--- /dev/null
+++ b/sci-astronomy/eazy/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ Easy and Accurate Zphot from Yale is a photometric redshift code
+ designed to produce high-quality redshifts from 0 to 4 for situations
+ where complete spectroscopic calibration samples are not available.
+</longdescription>
+</pkgmetadata>