aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/castxml/Manifest1
-rw-r--r--dev-cpp/castxml/castxml-0.2.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-cpp/castxml/Manifest b/dev-cpp/castxml/Manifest
new file mode 100644
index 000000000..0169371f2
--- /dev/null
+++ b/dev-cpp/castxml/Manifest
@@ -0,0 +1 @@
+DIST castxml-0.2.0.tar.gz 94793 BLAKE2B 3b1560b261d68ab86f3286c80166707f677835b020d15ce3e0a6533ec467afac28505a834bf974127ea48b4d873ef617b26858b16bb8242f8688aa4be759b552 SHA512 e0c7281e44dacb9c7605cb11dd9c07a4b3919fa78ac6423f2f165e19ce4336407383ad501f1f75f287a6dbb1adab021275d4c575e2cb34c61577476b0958294a
diff --git a/dev-cpp/castxml/castxml-0.2.0.ebuild b/dev-cpp/castxml/castxml-0.2.0.ebuild
new file mode 100644
index 000000000..cf81e7209
--- /dev/null
+++ b/dev-cpp/castxml/castxml-0.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils llvm
+
+MY_PN="CastXML"
+
+DESCRIPTION="CastXML is a C-family abstract syntax tree XML output tool."
+HOMEPAGE="https://github.com/CastXML/CastXML"
+SRC_URI="https://github.com/CastXML/CastXML/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="${RDEPEND}"
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ sys-devel/llvm:=
+ sys-devel/clang:=
+ "
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ ctest -j 20
+}