aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/PyVISA/Manifest1
-rw-r--r--dev-python/PyVISA/PyVISA-1.9.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/PyVISA/Manifest b/dev-python/PyVISA/Manifest
index 0325a1839..e077b791c 100644
--- a/dev-python/PyVISA/Manifest
+++ b/dev-python/PyVISA/Manifest
@@ -1 +1,2 @@
DIST PyVISA-1.8.tar.gz 429701 BLAKE2B 5e35dba270df0e39fe132cad4adcbaf136146add9c9a06419a724daa5fc7da1e31010aba1d0e1025a4559dff38d33a8d645705051987db3e64b973b8f950c55e SHA512 e3346c0966a97ef09158820df5df74480b0f253c1bde6a3d3621e8011f98f3059d2e9f04c6a361c3332abef433e8e5bb85fc161cbfe737be354d1786336d9254
+DIST PyVISA-1.9.1.tar.gz 440456 BLAKE2B f7e89f25e961e3e4cba1590a0ca871d100dfde39a85f28e00992972d86de4efa5dce75f9d5c56cb4cfc1ba796d1263d85bc7fe8a0e976b52d4956fbbafaf430e SHA512 be33753be222dbc9fbbfb4668261b603b5ab269bc9fa8cac712a1e86156f7f0626d362fab86aed83fe6180f997d1bd5be2db0502fa3520adb00dc6c4e3299945
diff --git a/dev-python/PyVISA/PyVISA-1.9.1.ebuild b/dev-python/PyVISA/PyVISA-1.9.1.ebuild
new file mode 100644
index 000000000..5520ac62b
--- /dev/null
+++ b/dev-python/PyVISA/PyVISA-1.9.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python VISA bindings for GPIB, RS232, and USB instruments"
+HOMEPAGE="https://github.com/pyvisa/pyvisa"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+ "
+DEPEND="${RDEPEND}"
+
+python_test() {
+ esetup.py test
+}