aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/vector/Manifest1
-rw-r--r--dev-python/vector/vector-1.4.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/vector/Manifest b/dev-python/vector/Manifest
index 541d150c6..df652f966 100644
--- a/dev-python/vector/Manifest
+++ b/dev-python/vector/Manifest
@@ -1,2 +1,3 @@
DIST vector-1.1.1.tar.gz 289916 BLAKE2B 35281c498f244b0307d744a20d0364c4cf664d0bd08a4f17d8d3110aa4eae6d7f66e3b51b4e9847f31d3a6ab943248115221dee4dcd3c3f2f8c47842001b553a SHA512 b1e195751de35ca2c67749b6b2b330db8a29e023f42e9b454adc8fc2408c29b5926b39e9ed6dc6a93f97006fbfb286a2217be8b14cb0eb2b96c9538f6c3943e6
DIST vector-1.3.1.tar.gz 299581 BLAKE2B 36e99e814b5e8afc7a0179acce74f399db8f76e3c3c59ebbb5a2616bfa8f34ca2cfabe9e42752226dbabbdcd77fc15a4725c4e296f5329533a85cade8fcfae0c SHA512 524752789f6ea0201e1bb3dc09e7396a8bc64a1ee78ccab383bbe968134783bbf7499948784b141353612649f8188d0cb93147b53afdf37ba26f812d8ebd84b0
+DIST vector-1.4.0.tar.gz 368490 BLAKE2B 443922bc00bfddd3601a414af1a2ba70bed0caff0dd5516573a557d736b65ebf42f191c6de776a3a28b2399d4cbe3db56f69864051758839a00e2703e6b3b53c SHA512 f8caba973fe7739537c41b5a86b435134bfa1f59b355a2246ae0cff76b6be5ea8ddae90c11326d439e4c31aacbbf21061479fa0d1d9e644292307bf2a77c416e
diff --git a/dev-python/vector/vector-1.4.0.ebuild b/dev-python/vector/vector-1.4.0.ebuild
new file mode 100644
index 000000000..a57240b49
--- /dev/null
+++ b/dev-python/vector/vector-1.4.0.ebuild
@@ -0,0 +1,34 @@
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=hatchling
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="Vector classes and utilities"
+HOMEPAGE="
+ https://github.com/scikit-hep/vector
+ https://vector.readthedocs.io/
+ https://doi.org/10.5281/zenodo.7054478
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+# tests need numba
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+pkg_postinst() {
+ optfeature "awkward array support" dev-python/awkward
+ optfeature "sympy support" dev-python/sympy
+}