aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--eclass/mpi.eclass12
-rw-r--r--sci-libs/libsufr/ChangeLog13
-rw-r--r--sci-libs/libsufr/Manifest1
-rw-r--r--sci-libs/libsufr/libsufr-0.4.1.ebuild29
4 files changed, 48 insertions, 7 deletions
diff --git a/eclass/mpi.eclass b/eclass/mpi.eclass
index 361b0e750..b411ae9ac 100644
--- a/eclass/mpi.eclass
+++ b/eclass/mpi.eclass
@@ -9,11 +9,11 @@ inherit multilib
# Justin Bronder <jsbronder@gentoo.org>
# @BLURB: Common functions for mpi-pkg.eclass and mpi-imp.eclass
-# History:
-# 2009-06-26 (jsbronder): Add ability to require common use flags.
+# History:
+# 2009-06-26 (jsbronder): Add ability to require common use flags.
# Remove dep on eselect-mpi (it's in sys-cluster/empi)
# Use virtual/$class to get imp dep in mpi_pkg_deplist.
-# 2008-11-20 (jsbronder): Initial rewrite from old mpi.eclass
+# 2008-11-20 (jsbronder): Initial rewrite from old mpi.eclass
#####################
@@ -216,7 +216,7 @@ mpi_imp_deplist() {
}
mpi_imp_add_eselect() {
- mpi_classed || return 0
+ mpi_classed || return 0
local c=$(mpi_class)
cp "${FILESDIR}"/${MPI_ESELECT_FILE} ${T}/${c}.eselect || die
sed -i \
@@ -357,7 +357,7 @@ mpi_pkg_fc() { _mpi_pkg_compiler "MPI_FC" "f90 fc"; }
# @USAGE:
# @DESCRIPTION: Adds the correct path(s) to the end of LD_LIBRARY_PATH. Does
# nothing if the build is unclassed.
-mpi_pkg_set_ld_library_path() {
+mpi_pkg_set_ld_library_path() {
if mpi_classed; then
export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}:$(_get_eselect_var LD_LIBRARY_PATH)"
fi
@@ -404,7 +404,7 @@ mpi_pkg_set_env() {
# @FUNCTION: mpi_pkg_restore_env
# @USAGE:
# @DESCRIPTION: Attempts to undo the damage done by mpi_pkg_set_env
-mpi_pkg_restore_env() {
+mpi_pkg_restore_env() {
if mpi_classed; then
export CC=$_mpi_oCC
export CXX=$_mpi_oCXX
diff --git a/sci-libs/libsufr/ChangeLog b/sci-libs/libsufr/ChangeLog
index 3f3c9dfcc..1bf764b39 100644
--- a/sci-libs/libsufr/ChangeLog
+++ b/sci-libs/libsufr/ChangeLog
@@ -1,7 +1,18 @@
# ChangeLog for sci-libs/libsufr
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*libsufr-0.4.1 (13 Jan 2013)
+
+ 13 Jan 2013; AstroFloyd <AstroFloyd@gmail.com> +libsufr-0.4.1.ebuild:
+ Updated libSUFR to 0.4.1, added VERSION to doc files, added ChangeLog
+ to git repo, keep one older version
+
+*libsufr-0.3.3 (5 May 2012)
+
+ 13 Jan 2013; Kacper Kowalik (Xarthisius) +libsufr-0.3.3.ebuild:
+ Version bump, drop old, don't install unnecessary doc files
+
*libsufr-0.3.2 (04 Mar 2012)
04 Mar 2012; AstroFloyd <AstroFloyd@gmail.com> +libsufr-0.3.2.ebuild:
diff --git a/sci-libs/libsufr/Manifest b/sci-libs/libsufr/Manifest
index 1f6c0f73c..37459ec8c 100644
--- a/sci-libs/libsufr/Manifest
+++ b/sci-libs/libsufr/Manifest
@@ -1 +1,2 @@
DIST libsufr-0.3.3.tar.gz 45360 SHA256 c2c76c9461cd913dc62e3e6dc3420aca5a03b620ccfbb7f8e58375fcbc1bfbf5 SHA512 27ceefaf345532c3579b80420038ff3c12e2dda0111fe95a4623283084ff52b6e19571e4fbd38cf1b2e495037443df54d9c280f85b4eabeafec454201b621178 WHIRLPOOL 1f6258e8c9339c6a07a9a3a4612a348f7f5a68ef230eeb1d3645f288103a8ea7e65b6f3af7d9c18d965960c8338e3822ff753ba1d55b8f37feb31c257ed3deaf
+DIST libsufr-0.4.1.tar.gz 52219 SHA256 8826f7bc2f3db8c6fea37896211bbbf933ba8cc3f06465ce42266a9193891ec1 SHA512 d51bcc26957bb8c11845d16d1ace3753eb9a8e42367ddc5c4d35dc3208f03c016e7a46700d462a8705a9ba4ef821bc240852b2fad95605f2abd3dd59d06f08cc WHIRLPOOL 8886b3983516a431cd1d14dbe884a67d1592b1f5f3c2d8255cac5ad716ba42d0b0d8cc144353ffd8b6c180c0c40fddf60f9218b7da65c1ebdedd368f1f3ee9bb
diff --git a/sci-libs/libsufr/libsufr-0.4.1.ebuild b/sci-libs/libsufr/libsufr-0.4.1.ebuild
new file mode 100644
index 000000000..88dd64902
--- /dev/null
+++ b/sci-libs/libsufr/libsufr-0.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+CMAKE_VERBOSE=1
+
+inherit cmake-utils fortran-2
+
+DESCRIPTION="LIBrary of Some Useful Fortran Routines"
+HOMEPAGE="http://libsufr.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+DEPEND="virtual/fortran"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use static-libs CREATE_STATICLIB)
+ )
+ cmake-utils_src_configure
+}
+
+DOCS="CHANGELOG README VERSION"