aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-geosciences/pydap/ChangeLog8
-rw-r--r--sci-geosciences/pydap/Manifest2
-rw-r--r--sci-geosciences/pydap/metadata.xml12
-rw-r--r--sci-geosciences/pydap/pydap-3.0.3.ebuild34
-rw-r--r--sci-geosciences/pydap/pydap-3.1.ebuild38
5 files changed, 52 insertions, 42 deletions
diff --git a/sci-geosciences/pydap/ChangeLog b/sci-geosciences/pydap/ChangeLog
index 168bfd15a..4bf82255a 100644
--- a/sci-geosciences/pydap/ChangeLog
+++ b/sci-geosciences/pydap/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sci-geosciences/pydap
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*pydap-3.1 (03 Jul 2013)
+
+ 03 Jul 2013; Justin Lecher <jlec@gentoo.org> -pydap-3.0.3.ebuild,
+ +pydap-3.1.ebuild, metadata.xml:
+ Version Bump; Bump to new python eclass
+
*pydap-3.0.3 (11 Apr 2012)
11 Apr 2012; Tim Cera <tim@cerazone.net> -pydap-3.0.1.ebuild,
diff --git a/sci-geosciences/pydap/Manifest b/sci-geosciences/pydap/Manifest
index 74c319db5..1b0893ab5 100644
--- a/sci-geosciences/pydap/Manifest
+++ b/sci-geosciences/pydap/Manifest
@@ -1 +1 @@
-DIST Pydap-3.0.3.tar.gz 3079097 SHA256 0a066ee92882b6b31fc255f73d4e5944d66a1a8c83950be02e824f068e68ff6b SHA512 97255c1d35494e66055b0301f9caf174d909794f9c01917901c567001c569078ae3971662fee9a0b626d420b830d0893548583e06c4e934004b1f76e5b19caee WHIRLPOOL 059099aedd67170a531fb2ca0e8985c15e44f333a045bb53f26d2e57fed33978e8b9df6f85f3830427c4da31153c0166af51029261799dd96ea76189a0ec32b5
+DIST Pydap-3.1.tar.gz 3098212 SHA256 0e37ebb7755134689d34c7221a140b0b7fb8a76b213e3975e85fec3fe0c2d5f1 SHA512 3cae2cd21c73813c640c6fdf9d1ba10d704a60a1b9c93124631dc0727f575a9ee334923693a44dbd16c950203ec7dd9e9124abd48ae33113d191db4256e8fcfb WHIRLPOOL ecbcad47d88b6e10c21b6e34cfaff5ebab5a84eb9835180159c7d33d34594fa548b03279ee56703c145c81fccacab1281708b215697575316032c34090fe8ba0
diff --git a/sci-geosciences/pydap/metadata.xml b/sci-geosciences/pydap/metadata.xml
index 4bfa33117..c1ce68b21 100644
--- a/sci-geosciences/pydap/metadata.xml
+++ b/sci-geosciences/pydap/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci-geosciences</herd>
-<maintainer>
-<email>tim@cerazone.net</email>
-<name>Tim Cera</name>
-</maintainer>
-<longdescription lang="en">
+ <herd>sci-geosciences</herd>
+ <maintainer>
+ <email>tim@cerazone.net</email>
+ <name>Tim Cera</name>
+ </maintainer>
+ <longdescription lang="en">
Pydap is a pure Python library implementing the Data Access Protocol.
</longdescription>
</pkgmetadata>
diff --git a/sci-geosciences/pydap/pydap-3.0.3.ebuild b/sci-geosciences/pydap/pydap-3.0.3.ebuild
deleted file mode 100644
index fffbc5a31..000000000
--- a/sci-geosciences/pydap/pydap-3.0.3.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-MY_PN=${PN/pydap/Pydap}
-MY_P=${P/pydap/Pydap}
-MY_P=${MY_P/_rc/.rc.}
-
-DESCRIPTION="Data Access Protocol client and server."
-HOMEPAGE="http://pydap.org"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="pydap"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND=">=dev-python/setuptools-0.6_rc3"
-RDEPEND=">=dev-python/numpy-1.2.1
- >=dev-python/httplib2-0.4.0
- >=dev-python/genshi-0.5.1
- >=dev-python/paste-1.7.2
- >=dev-python/pastescript-1.7.2
- >=dev-python/pastedeploy-1.3.3"
-
-S="$WORKDIR/$MY_P"
diff --git a/sci-geosciences/pydap/pydap-3.1.ebuild b/sci-geosciences/pydap/pydap-3.1.ebuild
new file mode 100644
index 000000000..262ddf090
--- /dev/null
+++ b/sci-geosciences/pydap/pydap-3.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+MY_PN=${PN/pydap/Pydap}
+MY_P=${P/pydap/Pydap}
+MY_P=${MY_P/_rc/.rc.}
+
+DESCRIPTION="Data Access Protocol client and server."
+HOMEPAGE="http://pydap.org"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="pydap"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-python/setuptools-0.6_rc3[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/wsgiintercept[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/genshi-0.5.1[${PYTHON_USEDEP}]
+ >=dev-python/paste-1.7.2[${PYTHON_USEDEP}]
+ >=dev-python/pastescript-1.7.2[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.3.3[${PYTHON_USEDEP}]"
+
+S="$WORKDIR"/${MY_P}
+
+python_test() {
+ esetup.py test
+}