aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/Macaulay2/ChangeLog5
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-1.2-r2.ebuild (renamed from sci-mathematics/Macaulay2/Macaulay2-1.2-r1.ebuild)6
-rw-r--r--sci-mathematics/Macaulay2/Macaulay2-1.2.ebuild118
-rw-r--r--sci-mathematics/Macaulay2/Manifest5
4 files changed, 12 insertions, 122 deletions
diff --git a/sci-mathematics/Macaulay2/ChangeLog b/sci-mathematics/Macaulay2/ChangeLog
index 9f8ba6fdf..a8dea06ef 100644
--- a/sci-mathematics/Macaulay2/ChangeLog
+++ b/sci-mathematics/Macaulay2/ChangeLog
@@ -2,6 +2,11 @@
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 06 May 2009; Thomas Kahle <tom111@gmx.de> -Macaulay2-1.2.ebuild
+ -Macaulay2-1.2-r1.ebuild +Macaulay2-1.2-r2.ebuild
+
+ Updated Useflag Deps. Fix for use -emacs (Fixes Bug #268064)
+
05 May 2009; Thomas Kahle <tom111@gmx.de> +Macaulay2-1.2-r1.ebuild
Fixes an issue with the documentation
diff --git a/sci-mathematics/Macaulay2/Macaulay2-1.2-r1.ebuild b/sci-mathematics/Macaulay2/Macaulay2-1.2-r2.ebuild
index 2f1e6da3d..44ccc4c4c 100644
--- a/sci-mathematics/Macaulay2/Macaulay2-1.2-r1.ebuild
+++ b/sci-mathematics/Macaulay2/Macaulay2-1.2-r2.ebuild
@@ -29,7 +29,7 @@ KEYWORDS="~x86 ~amd64"
# sys-process/time is needed to run the checks
DEPEND="sys-libs/gdbm
dev-libs/gmp
- >=dev-libs/ntl-5.4.1
+ >=dev-libs/ntl-5.4.1[gmp]
>=dev-libs/boehm-gc-7.0
>=sci-mathematics/pari-2.3.4[gmp]
virtual/blas
@@ -69,6 +69,10 @@ src_compile() {
sed "/^ *SourceCode => applicationDirectory.*$/d" -i doc13.m2
cd "${S}"
+ if ! use emacs; then
+ tags="ctags"
+ fi
+
CXXFLAGS="${CXXFLAGS} -Wno-deprecated"
append-ldflags "-L${WORKDIR}/$(get_libdir)"
emake -j1 && CPPFLAGS="-I/usr/include/gc -I${WORKDIR}/include" \
diff --git a/sci-mathematics/Macaulay2/Macaulay2-1.2.ebuild b/sci-mathematics/Macaulay2/Macaulay2-1.2.ebuild
deleted file mode 100644
index 3252affa1..000000000
--- a/sci-mathematics/Macaulay2/Macaulay2-1.2.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="2"
-
-inherit elisp-common eutils flag-o-matic toolchain-funcs autotools
-
-IUSE="emacs"
-
-DESCRIPTION="research tool for commutative algebra and algebraic geometry"
-SRC_URI=" http://www.math.uiuc.edu/Macaulay2/Downloads/SourceCode/${P}-r8438-src.tar.bz2
- ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Factory/factory-3-1-0.tar.gz \
- ftp://www.mathematik.uni-kl.de/pub/Math/Singular/Libfac/libfac-3-1-0.tar.gz \
- http://www.math.uiuc.edu/Macaulay2/Extra/frobby_vmike3.tar.gz"
-# mirror://gentoo/${P}-src.tar.bz2
-
-# We should keep frobby, factory and libfac in sync, and if possible make
-# separate ebuilds later
-
-HOMEPAGE="http://www.math.uiuc.edu/Macaulay2/"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86 ~amd64"
-
-# The ntl version is a due to factory
-# If <boehm-gc-7.0 is installed M2 download and install it internally
-# sys-process/time is needed to run the checks
-DEPEND="sys-libs/gdbm
- dev-libs/gmp
- >=dev-libs/ntl-5.4.1
- >=dev-libs/boehm-gc-7.0
- >=sci-mathematics/pari-2.3.4[gmp]
- virtual/blas
- virtual/lapack
- dev-util/ctags
- sys-libs/ncurses
- sys-process/time
- emacs? ( virtual/emacs )"
-
-SITEFILE=70Macaulay2-gentoo.el
-
-S="${WORKDIR}/${P}-r8438"
-
-src_unpack() {
- unpack ${A}
- # How can we prevent unpacking of frobby? It's not needed.
- cd "${S}"
-
- sed -e "s:\$docdirtail/${PN}:\$docdirtail/${P}:" \
- -i configure.ac \
- || die "Failed to fix doc install directory."
-}
-
-src_compile() {
- cd "${WORKDIR}/factory"
- epatch "${FILESDIR}"/patch-3.1.0b
- econf --enable-NTL --prefix="${WORKDIR}" || \
- die "failed to configure factory"
- # -j1 is still necessary
- emake -j1 || die "failed to build factory"
- make install || die "failed to install factory"
-
- cd "${WORKDIR}/libfac"
- CPPFLAGS="-I${WORKDIR}/include" econf --with-NOSTREAMIO \
- --prefix="${WORKDIR}" || die "failed to configure libfac"
- emake || die "failed to build libfac"
- make install || die "failed to install libfac"
-
- # Put sourcfile in the right location:
- mkdir "${S}/BUILD/tarfiles"
- cp "${DISTDIR}/frobby_vmike3.tar.gz" "${S}/BUILD/tarfiles/" \
- || die "copy failed"
-
- cd "${S}"
- sed -e "/^docm2RelDir/s:Macaulay2:${P}:" \
- -i include/config.Makefile.in \
- || die "failed to fix makefile"
-
- CXXFLAGS="${CXXFLAGS} -Wno-deprecated"
- append-ldflags "-L${WORKDIR}/$(get_libdir)"
- emake -j1 && CPPFLAGS="-I/usr/include/gc -I${WORKDIR}/include" \
- ./configure --prefix="${D}/usr" --disable-encap \
- || die "failed to configure Macaulay"
-
- emake -j1 || die "failed to build Macaulay"
-}
-
-src_test() {
- cd "${S}"
- make check || die "tests failed"
-}
-
-src_install () {
-
- make install || die "install failed"
-
- # nothing useful in here, get rid of it
- # NOTE: Macaulay installs into lib even on amd64 hence don't
- # replace lib with $(get_libdir) below!
- rm -fr "${D}"/usr/lib \
- || die "failed to remove empty /usr/lib"
-
- use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
-}
-
-pkg_postinst() {
- if use emacs; then
- elisp-site-regen
- elog "If you want to set a hot key for Macaulay2 in Emacs add a line similar to"
- elog "(global-set-key [ f12 ] 'M2)"
- elog "in order to set it to F12 (or choose a different one)."
- fi
-}
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/sci-mathematics/Macaulay2/Manifest b/sci-mathematics/Macaulay2/Manifest
index ff2299311..5de3cdfbd 100644
--- a/sci-mathematics/Macaulay2/Manifest
+++ b/sci-mathematics/Macaulay2/Manifest
@@ -4,7 +4,6 @@ DIST Macaulay2-1.2-r8438-src.tar.bz2 3198159 RMD160 bfd5fc5498e0ca7507277e9b2997
DIST factory-3-1-0.tar.gz 565374 RMD160 059ed1697f282d309e89d1cc2e0ce8bd94a8b4b3 SHA1 c41ab3cdc6ea51332169645e35c35c3fd6c4d94b SHA256 cb1768ccaaa71557ace880be0e88100bcfd420d3094ffac59d229cd852edc0ff
DIST frobby_vmike3.tar.gz 235794 RMD160 d9bf705895f4ccb8a1db9fd3909d4ae53fb05b08 SHA1 e478c0d0ac66f4d315ab246a1b2e0cb563991367 SHA256 98c58c0bb99f81344d1a647840f32e062923f2a45bf4cbafbf03ad1160e0a673
DIST libfac-3-1-0.tar.gz 91544 RMD160 2500d402328ad532756c677015c1d01f8594e394 SHA1 d005ddd58a180b8a91fe5728b96bde515c5d9cc5 SHA256 fc3dda08f7ec039635f8d7f1629546f4ac7620a69cf9332ca39e29dd822aee7d
-EBUILD Macaulay2-1.2-r1.ebuild 3094 RMD160 878ed67534f882e66e88662a70a1d96151c489f1 SHA1 f2a06530ccb0e7db5eee5d3e788e08eb852855eb SHA256 58c56a9315665516d62e9313580ee1b2f08af5ec74e9d0f25c3a6ac449962adf
-EBUILD Macaulay2-1.2.ebuild 3274 RMD160 54523c2361c3cbfde6848258901bdc53e5301d0c SHA1 93a740fca6e3c04d86a86a24d459b4e284dabb11 SHA256 bc3d3a8621e1c367715740e745839f4994cf58c95c249ec4fba4798fbe3f8435
-MISC ChangeLog 399 RMD160 c73ae3c42f8e97777f534b50e27607a44b68ed7f SHA1 f7a7c7e372f114fe1c5c5a004bc47912bb11dc2f SHA256 87841b76c19f6bc120c4b15023859735859df2f33418ae2292bfa6180b7cd6e5
+EBUILD Macaulay2-1.2-r2.ebuild 3140 RMD160 4228497ba8c22038b496744c494c6ab0c808d90b SHA1 33ef56c4cbfe449e119d5b7fb1a2801421c5f30a SHA256 bfb59f0a752f4dd90ed87ade901010dc26d2fa6b5c70872638f898399072bb5c
+MISC ChangeLog 582 RMD160 729915412ed83e2f1370884c27c0793d8d89b6f8 SHA1 36915300ffdb1fab2aa4ec5307712d79c144289b SHA256 a974054d4c9598d11d6b86dcc5c5c21b0cad9d4312c9474dd43bf2bdc3222c68
MISC metadata.xml 361 RMD160 273db3a009b85938f85e60ea0d34d6fc625f9477 SHA1 7f6e903d81af55b08c7dbb9feb4f7ad39852a23e SHA256 71a0f19b08b1e752e754bbc5faf15880601d00c5b9df2bc5ca5a3b8e93e83b7f