aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/bigdft/ChangeLog4
-rw-r--r--sci-libs/bigdft/bigdft-1.6.0-r1.ebuild23
-rw-r--r--sci-libs/bigdft/bigdft-1.6_pre1-r1.ebuild32
3 files changed, 27 insertions, 32 deletions
diff --git a/sci-libs/bigdft/ChangeLog b/sci-libs/bigdft/ChangeLog
index 80ea11cbc..5334648c2 100644
--- a/sci-libs/bigdft/ChangeLog
+++ b/sci-libs/bigdft/ChangeLog
@@ -2,6 +2,10 @@
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 22 May 2012; Justin Lecher <jlec@gentoo.org> bigdft-1.6_pre1-r1.ebuild,
+ bigdft-1.6.0-r1.ebuild:
+ Add missing eutils.eclass, bump to EAPI=4, remove unnecessary bits
+
*bigdft-1.6.0-r1 (15 May 2012)
*bigdft-1.6_pre1-r1 (15 May 2012)
diff --git a/sci-libs/bigdft/bigdft-1.6.0-r1.ebuild b/sci-libs/bigdft/bigdft-1.6.0-r1.ebuild
index ef9b7f103..cdb304961 100644
--- a/sci-libs/bigdft/bigdft-1.6.0-r1.ebuild
+++ b/sci-libs/bigdft/bigdft-1.6.0-r1.ebuild
@@ -2,19 +2,15 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI=4
-inherit autotools-utils flag-o-matic fortran-2 toolchain-funcs
-
-DESCRIPTION="A DFT electronic structure code using a wavelet basis set"
-HOMEPAGE="http://inac.cea.fr/L_Sim/BigDFT/"
+inherit autotools-utils eutils flag-o-matic fortran-2 toolchain-funcs
REAL_P="${P/_pre0/-tuto}"
-S="${WORKDIR}/${REAL_P}"
-SRC_URI="
- http://inac.cea.fr/L_Sim/BigDFT/${REAL_P}.tar.gz
- "
+DESCRIPTION="A DFT electronic structure code using a wavelet basis set"
+HOMEPAGE="http://inac.cea.fr/L_Sim/BigDFT/"
+SRC_URI="http://inac.cea.fr/L_Sim/BigDFT/${REAL_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -35,15 +31,14 @@ RDEPEND="
)
)
etsf_io? ( sci-libs/etsf_io )
- netcdf? (
- sci-libs/netcdf[fortran]
- )
- "
+ netcdf? ( sci-libs/netcdf[fortran] )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
>=sys-devel/autoconf-2.59
doc? ( virtual/latex-base )"
+S="${WORKDIR}/${REAL_P}"
+
DOCS=( README INSTALL ChangeLog AUTHORS NEWS )
FORTRAN_STANDARD=90
@@ -107,7 +102,7 @@ src_compile() {
#autotools-utils_src_compile() expanded
_check_build_dir
pushd "${AUTOTOOLS_BUILD_DIR}" > /dev/null
- emake -j1 || die 'emake failed'
+ emake -j1
sed -i -e's%\$(top_builddir)/[^ ]*/lib\([^ /$-]*\)\.a%-l\1%g' bigdft.pc
popd > /dev/null
diff --git a/sci-libs/bigdft/bigdft-1.6_pre1-r1.ebuild b/sci-libs/bigdft/bigdft-1.6_pre1-r1.ebuild
index 861a9dbb4..6cdd6e4e3 100644
--- a/sci-libs/bigdft/bigdft-1.6_pre1-r1.ebuild
+++ b/sci-libs/bigdft/bigdft-1.6_pre1-r1.ebuild
@@ -2,20 +2,16 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI="4"
+EAPI=4
-inherit autotools-utils flag-o-matic fortran-2 toolchain-funcs
-
-DESCRIPTION="A DFT electronic structure code using a wavelet basis set"
-HOMEPAGE="http://inac.cea.fr/L_Sim/BigDFT/"
+inherit autotools-utils eutils flag-o-matic fortran-2 toolchain-funcs
REAL_P="${P/_pre/-tuto.}"
REAL_P="${REAL_P/-tuto.0/-tuto}"
-S="${WORKDIR}/${REAL_P}"
-SRC_URI="
- http://inac.cea.fr/L_Sim/BigDFT/${REAL_P}.tar.gz
- "
+DESCRIPTION="A DFT electronic structure code using a wavelet basis set"
+HOMEPAGE="http://inac.cea.fr/L_Sim/BigDFT/"
+SRC_URI="http://inac.cea.fr/L_Sim/BigDFT/${REAL_P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -36,15 +32,14 @@ RDEPEND="
)
)
etsf_io? ( sci-libs/etsf_io )
- netcdf? (
- sci-libs/netcdf[fortran]
- )
- "
+ netcdf? ( sci-libs/netcdf[fortran] )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
>=sys-devel/autoconf-2.59
doc? ( virtual/latex-base )"
+S="${WORKDIR}/${REAL_P}"
+
DOCS=( README INSTALL ChangeLog AUTHORS NEWS )
FORTRAN_STANDARD=90
@@ -63,10 +58,11 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/"${REAL_P}"-libxc_dir_include.patch
- epatch "${FILESDIR}"/"${REAL_P}"-bigdft.pc.patch
- sed -i -e's/capitalize_module_ext/ax_fc_mod_ext/g' "${S}"/configure
- sed -i -e's/capitalize_module_ext/ax_fc_mod_ext/g' "${S}"/configure.ac
+ epatch \
+ "${FILESDIR}"/"${REAL_P}"-libxc_dir_include.patch \
+ "${FILESDIR}"/"${REAL_P}"-bigdft.pc.patch
+ sed -i -e's/capitalize_module_ext/ax_fc_mod_ext/g' "${S}"/configure || die
+ sed -i -e's/capitalize_module_ext/ax_fc_mod_ext/g' "${S}"/configure.ac || die
eautoreconf
}
@@ -112,7 +108,7 @@ src_compile() {
#autotools-utils_src_compile() expanded
_check_build_dir
pushd "${AUTOTOOLS_BUILD_DIR}" > /dev/null
- emake -j1 || die 'emake failed'
+ emake -j1
sed -i -e's%\$(top_builddir)/[^ ]*/lib\([^ /$-]*\)\.a%-l\1%g' bigdft.pc
popd > /dev/null