aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/kst/Manifest2
-rw-r--r--media-gfx/kst/files/kst-1.1.0-netcdf-fix.patch66
2 files changed, 58 insertions, 10 deletions
diff --git a/media-gfx/kst/Manifest b/media-gfx/kst/Manifest
index ea0367c21..6f522fab7 100644
--- a/media-gfx/kst/Manifest
+++ b/media-gfx/kst/Manifest
@@ -4,4 +4,4 @@ MD5 9256bacd4953825aa817b820ecf8e4e3 ChangeLog 2495
MD5 862e7941cb21c9dd10e8bd6183f21fb0 metadata.xml 173
MD5 b3c3b4529c7a84a69be4e52b98c71a53 files/digest-kst-1.1.0 63
MD5 19eccdaf16ff3e3301ad96c85fd3417b files/digest-kst-0.97 61
-MD5 de4e30c39bff503234472d2a8863275c files/kst-1.1.0-netcdf-fix.patch 932
+MD5 7d7826a4f8fadf0c3c8627577a4f55a9 files/kst-1.1.0-netcdf-fix.patch 2939
diff --git a/media-gfx/kst/files/kst-1.1.0-netcdf-fix.patch b/media-gfx/kst/files/kst-1.1.0-netcdf-fix.patch
index d5e2f5c5d..cf2d0fe35 100644
--- a/media-gfx/kst/files/kst-1.1.0-netcdf-fix.patch
+++ b/media-gfx/kst/files/kst-1.1.0-netcdf-fix.patch
@@ -1,6 +1,15 @@
---- configure.in.old 2005-10-25 10:37:27.000000000 -0300
-+++ configure.in 2005-10-25 11:09:22.000000000 -0300
-@@ -182,11 +182,20 @@
+--- configure.in 2005-10-27 00:25:05.000000000 -0300
++++ configure.in 2005-10-27 00:22:25.000000000 -0300
+@@ -156,7 +156,7 @@
+ AC_HELP_STRING([--with-cdf=DIR],[where the root of CDF is installed ]),
+ [ ac_cdf_includes="-I$withval/include"
+ ac_cdf_libraries="-L$withval/lib"
+- ])
++ ])
+
+ all_includes_save="$all_includes"
+ all_includes="$all_includes $ac_cdf_includes"
+@@ -182,32 +182,43 @@
# netCDF Test
ac_netcdf_includes=""
ac_netcdf_libraries=""
@@ -9,10 +18,27 @@
- [ ac_netcdf_includes="-I$withval/include"
- ac_netcdf_libraries="-L$withval/lib"
- ])
-+
-+AC_MSG_CHECKING(--enable-netcdf argument)
+-
+-all_includes_save="$all_includes"
+-all_includes="$all_includes $ac_netcdf_includes"
+-KDE_CHECK_HEADER(netcdfcpp.h, AC_DEFINE(HAVE_NETCDFCPP_H, 1, [If we have NetCDF CPP headers]) have_netcdfcpp_h=yes NETCDFINCLUDES="$ac_netcdf_includes", , )
+-all_includes="$all_includes_save"
++NETCDFLIBS=""
+
+-ldflags_save="$LDFLAGS"
+-LDFLAGS="$LDFLAGS $ac_netcdf_libraries"
+-KDE_CHECK_LIB(netcdf, nc_open, NETCDFLIBS="$ac_netcdf_libraries -lnetcdf_c++ -lnetcdf $NETCDFLIBS", , )
+-LDFLAGS="$ldflags_save"
+-
+-if test $ac_cv_lib_netcdf_nc_open = yes; then
+- if test $have_netcdfcpp_h = yes; then
+- AC_SUBST(NETCDFLIBS)
+- AC_SUBST(NETCDFINCLUDES)
+- AC_DEFINE(KST_HAVE_NETCDF, 1, [If we have the NetCDF libraries.])
+- fi
++AC_MSG_CHECKING([--enable-netcdf argument])
+AC_ARG_ENABLE(netcdf,
-+ [ --enable-netcdf Enable netcdf support.],
++ [ --enable-netcdf enable netcdf support.],
+ [ enable_netcdf=$enableval ],
+ [ enable_netcdf="no" ])
+
@@ -22,7 +48,29 @@
+ [ ac_netcdf_includes="-I$withval/include"
+ ac_netcdf_libraries="-L$withval/lib"
+ ])
-+fi
++
++ all_includes_save="$all_includes"
++ all_includes="$all_includes $ac_netcdf_includes"
++ KDE_CHECK_HEADER(netcdfcpp.h, AC_DEFINE(HAVE_NETCDFCPP_H, 1, [If we have NetCDF CPP headers]) have_netcdfcpp_h=yes NETCDFINCLUDES="$ac_netcdf_includes", , )
++ all_includes="$all_includes_save"
++
++ ldflags_save="$LDFLAGS"
++ LDFLAGS="$LDFLAGS $ac_netcdf_libraries"
++ KDE_CHECK_LIB(netcdf, nc_open, NETCDFLIBS="$ac_netcdf_libraries -lnetcdf_c++ -lnetcdf $NETCDFLIBS", , )
++ LDFLAGS="$ldflags_save"
++
++ if test $ac_cv_lib_netcdf_nc_open = yes; then
++ if test $have_netcdfcpp_h = yes; then
++ AC_SUBST(NETCDFLIBS)
++ AC_SUBST(NETCDFINCLUDES)
++ AC_DEFINE(KST_HAVE_NETCDF, 1, [If we have the NetCDF libraries.])
++ fi
++ fi
+ fi
- all_includes_save="$all_includes"
- all_includes="$all_includes $ac_netcdf_includes"
+ AM_CONDITIONAL(include_netcdf, test -n "$NETCDFLIBS")
+
++
+ # Readline and ncurses check
+ KDE_CHECK_HEADER(readline/readline.h, AC_DEFINE(HAVE_READLINE_H, 1, [If we have libreadline headers]) have_readline_h=yes, , )
+ KDE_CHECK_LIB(readline, rl_cleanup_after_signal, LIBREADLINE="-lreadline -lncurses", , -lncurses)