aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/numpy/ChangeLog4
-rw-r--r--dev-python/numpy/Manifest4
-rw-r--r--dev-python/numpy/files/digest-numpy-0.9.61
-rw-r--r--dev-python/numpy/numpy-0.9.6.ebuild48
4 files changed, 54 insertions, 3 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index ede63f7ba..abcdf4b75 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -2,9 +2,9 @@
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
-*numpy-0.9.5 (05 Mar 2006)
+*numpy-0.9.6 (15 Mar 2006)
- 05 Mar 2006; Sebastien Fabbro <seb@ist.utl.pt> +numpy-0.9.5.ebuild:
+ 15 Mar 2006; Sebastien Fabbro <seb@ist.utl.pt> +numpy-0.9.6.ebuild:
Added lapack use flag, a src_test function, and marked ~amd64.
*numpy-0.9.4 (07 Feb 2006)
diff --git a/dev-python/numpy/Manifest b/dev-python/numpy/Manifest
index a68bf0300..2f1e750aa 100644
--- a/dev-python/numpy/Manifest
+++ b/dev-python/numpy/Manifest
@@ -1,3 +1,5 @@
-MD5 478f0f621c59819395b4e740ee008b24 ChangeLog 430
+MD5 3abf235b64d60ff95dec5b02d7840e28 ChangeLog 430
MD5 5238e63b838e1c26ed682d2c3050cea8 files/digest-numpy-0.9.5 63
+MD5 3d1644c7fef9abd10cb81c674838b436 files/digest-numpy-0.9.6 63
MD5 04c542ab54b370936205c9a08cab2af7 numpy-0.9.5.ebuild 1096
+MD5 04c542ab54b370936205c9a08cab2af7 numpy-0.9.6.ebuild 1096
diff --git a/dev-python/numpy/files/digest-numpy-0.9.6 b/dev-python/numpy/files/digest-numpy-0.9.6
new file mode 100644
index 000000000..c1ad4cdc2
--- /dev/null
+++ b/dev-python/numpy/files/digest-numpy-0.9.6
@@ -0,0 +1 @@
+MD5 eac9ae05bd7511cecf1ffd12da0e1993 numpy-0.9.6.tar.gz 951680
diff --git a/dev-python/numpy/numpy-0.9.6.ebuild b/dev-python/numpy/numpy-0.9.6.ebuild
new file mode 100644
index 000000000..f141ca9fe
--- /dev/null
+++ b/dev-python/numpy/numpy-0.9.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="Numpy contains a powerful N-dimensional array object for Python."
+SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz"
+HOMEPAGE="http://numeric.scipy.org/"
+DEPEND=">=dev-lang/python-2.3
+ lapack? ( virtual/blas )
+ lapack? ( virtual/lapack )"
+IUSE="lapack"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # note the default are fine to use with
+ # blas/lapack reference and mkl.
+ if use lapack; then
+ echo "[atlas]" > site.cfg
+ echo "atlas_libs = lapack, blas, cblas, atlas" >> site.cfg
+ else
+ echo "[DEFAULT]" > site.cfg
+ echo "library_dirs =" >> site.cfg
+ echo "include_dirs =" >> site.cfg
+ echo "src_dirs =" >> site.cfg
+ echo "[blas_opt] =" >> site.cfg
+ echo "[lapack_opt] =" >> site.cfg
+ fi
+}
+
+# he test only works after install
+# to be worked out.
+#src_test() {
+# python -c "import numpy; numpy.test()" || \
+# die "test failed!"
+#}
+
+src_install() {
+ distutils_src_install
+ dodoc numpy/doc/*
+}
+
+