aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/htcondor/Manifest3
-rw-r--r--sys-cluster/htcondor/htcondor-8.0.0.ebuild9
2 files changed, 8 insertions, 4 deletions
diff --git a/sys-cluster/htcondor/Manifest b/sys-cluster/htcondor/Manifest
index ada4ad124..fe70962d9 100644
--- a/sys-cluster/htcondor/Manifest
+++ b/sys-cluster/htcondor/Manifest
@@ -1,2 +1 @@
-DIST condor_src-7.5.2-all-all.tar.gz 21705891 RMD160 f9911e3a44b69bb22ef607964aec726b51ab9341 SHA1 7e85048545423b13f8173c6ba6d76d35b97f2dcc SHA256 1a4fc437541896aa9963f12ec9231495f6a5ab4cc5ca814b57755a38db407026
-DIST condor_src-7.5.4-all-all.tar.gz 21870900 RMD160 7118a7a7ee32d5d7d9378ed5b94ad7a058ac1fca SHA1 877f748b53dd5e796592f812ae65d75f7b907812 SHA256 a0429b2525047b2eaca988ff4546ff177a5b4e55511354c793e4b3f01b032c08
+DIST condor_src-8.0.0-all-all.tar.gz 18636227 SHA256 b1fe7cedcab17d713a64b57dbb2a5f0426979316b8f309f9492ff60f7b43d3a8 SHA512 a335d0cb200f1899711f6f87968a01a2f5dcd37fede2ef973f2863a3f628d6f04421abbaaa22a310711ea1367af3a4f68e31c5e91e8cee1149cc5957d6ac0119 WHIRLPOOL 4c755644cd2ba5f7414ac3c8374df141b98d3e830f07a0ea0e0cc46b575ac8b42c1e47135cb9a87342bd41309b03df1693de1836cd250ea7e6ace1c3445ebd25
diff --git a/sys-cluster/htcondor/htcondor-8.0.0.ebuild b/sys-cluster/htcondor/htcondor-8.0.0.ebuild
index cadcfdbd3..4550fc081 100644
--- a/sys-cluster/htcondor/htcondor-8.0.0.ebuild
+++ b/sys-cluster/htcondor/htcondor-8.0.0.ebuild
@@ -5,7 +5,7 @@
EAPI=5
PYTHON_COMPAT=( python{2_5,2_6,2_7} )
-inherit cmake-utils python-r1 python-single-r1
+inherit cmake-utils python-single-r1
DESCRIPTION="Workload management system for compute-intensive jobs"
HOMEPAGE="http://www.cs.wisc.edu/htcondor/"
@@ -42,6 +42,11 @@ RESTRICT=fetch
S="${WORKDIR}/condor-${PV}"
+pkg_setup() {
+ enewgroup condor
+ enewuser condor -1 "${ROOT}"bin/bash "${ROOT}var/lib/condor" condor
+}
+
src_configure() {
local mycmakeargs="
$(cmake-utils_use_have boinc backfill)
@@ -60,4 +65,4 @@ src_configure() {
$(cmake-utils_use_with ssl openssl)
$(cmake-utils_use_with xml libxml2)"
cmake-utils_src_configure
-} \ No newline at end of file
+}