aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-chemistry/coot/ChangeLog8
-rw-r--r--sci-chemistry/coot/coot-9999.ebuild5
-rw-r--r--sci-chemistry/coot/files/coot-9999-sandbox-icons.patch16
3 files changed, 28 insertions, 1 deletions
diff --git a/sci-chemistry/coot/ChangeLog b/sci-chemistry/coot/ChangeLog
index cee77b120..cd498bb5d 100644
--- a/sci-chemistry/coot/ChangeLog
+++ b/sci-chemistry/coot/ChangeLog
@@ -2,6 +2,14 @@
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 30 Jun 2014; Justin Lecher <jlec@gentoo.org> coot-9999.ebuild,
+ +files/coot-9999-sandbox-icons.patch:
+ Fix sandbox violation
+
+ 30 Jun 2014; Justin Lecher <jlec@gentoo.org> coot-9999.ebuild,
+ +files/coot-9999-sandbox-icons.patch:
+ Fix sandbox violation
+
08 Jun 2014; Justin Lecher <jlec@gentoo.org> coot-9999.ebuild:
Fix problem with shebang correction
diff --git a/sci-chemistry/coot/coot-9999.ebuild b/sci-chemistry/coot/coot-9999.ebuild
index f0fd7dcf1..79aed91e7 100644
--- a/sci-chemistry/coot/coot-9999.ebuild
+++ b/sci-chemistry/coot/coot-9999.ebuild
@@ -82,7 +82,10 @@ pkg_setup() {
python-single-r1_pkg_setup
}
-PATCHES=( "${FILESDIR}"/${PV}-pc.patch )
+PATCHES=(
+ "${FILESDIR}"/${PV}-pc.patch
+ "${FILESDIR}"/${P}-sandbox-icons.patch
+)
src_unpack() {
subversion_src_unpack
diff --git a/sci-chemistry/coot/files/coot-9999-sandbox-icons.patch b/sci-chemistry/coot/files/coot-9999-sandbox-icons.patch
new file mode 100644
index 000000000..2a9ff2d71
--- /dev/null
+++ b/sci-chemistry/coot/files/coot-9999-sandbox-icons.patch
@@ -0,0 +1,16 @@
+ pixmaps/icons/Makefile.am | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/pixmaps/icons/Makefile.am b/pixmaps/icons/Makefile.am
+index 0c183ae..dddc11a 100644
+--- a/pixmaps/icons/Makefile.am
++++ b/pixmaps/icons/Makefile.am
+@@ -11,6 +11,6 @@ install-data-local:
+ CONTEXT=` echo $$icon | cut -d_ -f2`; \
+ SIZE=` echo $$icon | cut -d_ -f3`; \
+ ICONFILE=`echo $$icon | cut -d_ -f4`; \
+- mkdir -p $(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT; \
+- $(INSTALL_DATA) $(srcdir)/$$icon $(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
++ mkdir -p $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT; \
++ $(INSTALL_DATA) $(srcdir)/$$icon $(DESTDIR)$(datadir)/icons/$$THEME/$$SIZE/$$CONTEXT/$$ICONFILE; \
+ done;