aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-misc/praat/Manifest1
-rw-r--r--sci-misc/praat/praat-6.1.40.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sci-misc/praat/Manifest b/sci-misc/praat/Manifest
index eb6c460d5..332a750cd 100644
--- a/sci-misc/praat/Manifest
+++ b/sci-misc/praat/Manifest
@@ -1 +1,2 @@
DIST praat-6.0.26.tar.gz 11631820 BLAKE2B c6cbd695e00954ea61084b43a43882f7e410127f500ff6a350e72b95ad7a27d8a64ff123d5d4d1a361b5da46f33ea4ef4d427a70f34a676fca609b1dc94446b0 SHA512 56a480ea6caf0226b048b1472eaa77761ad5e3f5cd4c65c5f11bd84e8655988e8c1f729f42af130d19fb6d6ee36814bde4c121d824292b35714beeb7ea666ed0
+DIST praat-6.1.40.tar.gz 33612192 BLAKE2B 0515acf011cd7b365bc02bbe373bc7131d67edfca18bae1f6d59d9ef40969dfb3e4d90a6905b02ded7bdef39d5d300b310c2540d5e8357a2dde3af26bf953086 SHA512 7e1e02fdc8dd800c5aadee1823581b27d96fc4fa3f255d5bc91e21b2e2756db41ffb2d44d6b3b0a4951f0b40ff0ec03300a4f271dc9969ce4c45c42bd3b09dff
diff --git a/sci-misc/praat/praat-6.1.40.ebuild b/sci-misc/praat/praat-6.1.40.ebuild
new file mode 100644
index 000000000..3e7f7d95c
--- /dev/null
+++ b/sci-misc/praat/praat-6.1.40.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Speech analysis and synthesis"
+HOMEPAGE="https://www.fon.hum.uva.nl/praat/ https://github.com/praat/praat"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="
+ x11-libs/gtk+:2
+ media-libs/alsa-lib
+ media-sound/pulseaudio"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ # TODO: following line should be updated for non-linux etc. builds
+ # (Flammie does not have testing equipment)
+ cp makefiles/makefile.defs.linux.pulse makefile.defs || die
+
+ cat <<-EOF >> makefile.defs
+ CFLAGS += ${CFLAGS}
+ CXXFLAGS += ${CXXFLAGS}
+ EOF
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/${PN}
+ doins -r test
+}