aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/cdfplayer/ChangeLog9
-rw-r--r--sci-mathematics/cdfplayer/Manifest2
-rw-r--r--sci-mathematics/cdfplayer/cdfplayer-9.0.0.ebuild (renamed from sci-mathematics/cdfplayer/cdfplayer-8.0.4.ebuild)16
-rw-r--r--sci-mathematics/cdfplayer/files/cdfplayer-9.0.0-installer.patch (renamed from sci-mathematics/cdfplayer/files/cdfplayer-8.0.4-installer.patch)4
4 files changed, 24 insertions, 7 deletions
diff --git a/sci-mathematics/cdfplayer/ChangeLog b/sci-mathematics/cdfplayer/ChangeLog
index e9ba9c3b9..8a7c794a6 100644
--- a/sci-mathematics/cdfplayer/ChangeLog
+++ b/sci-mathematics/cdfplayer/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for sci-mathematics/cdfplayer
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*cdfplayer-9.0.0 (05 Jan 2013)
+
+ 05 Jan 2013; Jauhien Piatlicki (jauhien) <piatlicki@gmail.com>
+ -cdfplayer-8.0.4.ebuild, -files/cdfplayer-8.0.4-installer.patch,
+ +cdfplayer-9.0.0.ebuild, +files/cdfplayer-9.0.0-installer.patch:
+ version bump
+
*cdfplayer-8.0.4 (23 Nov 2012)
23 Nov 2012; Jauhien Piatlicki (jauhien) <piatlicki@gmail.com>
diff --git a/sci-mathematics/cdfplayer/Manifest b/sci-mathematics/cdfplayer/Manifest
index cc6b32c4c..4e3d343d4 100644
--- a/sci-mathematics/cdfplayer/Manifest
+++ b/sci-mathematics/cdfplayer/Manifest
@@ -1 +1 @@
-DIST CDFPlayer_8.0.4_LINUX.sh 235344672 SHA256 e0d5c72e90ba96c959fb06b39bc50064c52ea1cd31556fa658307c0a0d56ea1b SHA512 31f7ee997366d286e4b2897165f0eac21d514b48fb2808940a8ec8fd51a5d87f86805413a109d07f46c117dc5aa1a2b9900d7c6c30d5b6f70e352229d18962b4 WHIRLPOOL 2c696e1040bc86b1d7eaac4658d196dbe11a06e4efecb39172e3b1315b2b88053296ac34031f5027a683db291ff6c398bf24b859bede0e657a3b78585c593140
+DIST CDFPlayer_9.0.0_LINUX.sh 606513951 SHA256 5e7f55313276ed516bf19f9b391603df0887eef68205ee5987e8db130cdd2f09 SHA512 5c3bca3b375babe7e649d3f33b2c335d0ad8ff47a02324e8da489019b71722b1c9f13591fb7830874a9e2cda74b2f8e935e17202bf1dbe1434805aeffce43b52 WHIRLPOOL 6b468b1ff0754de464d4061fc20f1af9ee61345f733dc98ab228f13145a900ac6a655104390ef614b8aa668178b82a94c34f765e33cee2d2f727f99c2c55190d
diff --git a/sci-mathematics/cdfplayer/cdfplayer-8.0.4.ebuild b/sci-mathematics/cdfplayer/cdfplayer-9.0.0.ebuild
index 2978e3e06..042436462 100644
--- a/sci-mathematics/cdfplayer/cdfplayer-8.0.4.ebuild
+++ b/sci-mathematics/cdfplayer/cdfplayer-9.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -7,6 +7,7 @@ EAPI=4
inherit eutils
MY_SCRIPT=CDFPlayer_${PV}_LINUX.sh
+MY_DESKTOPFILE=${ED}/opt/wolfram/SystemFiles/Installation/wolfram-cdf9.desktop
DESCRIPTION="Player for Wolfram CDF"
HOMEPAGE="http://www.wolfram.com/cdf-player/"
@@ -38,7 +39,16 @@ src_install() {
-targetdir="${ED}/opt/wolfram" -execdir="${ED}/usr/bin" || die
find "${ED}" -name '*.desktop' -exec \
sed -i "s%${ED}%/%g" {} \; || die
+ sed -i "s/WolframCDFPlayer %F/WolframCDFPlayer -graphicssystem native %F/g" \
+ "${MY_DESKTOPFILE}" \
+ || die
mkdir -p "${ED}/usr/share/applications" || die
- cp "${ED}/opt/wolfram/SystemFiles/Installation/wolfram-cdf8.desktop" \
- "${ED}/usr/share/applications" || die
+ domenu "${MY_DESKTOPFILE}"
+}
+
+pkg_postinst() {
+ elog "If you want to start CDFPlayer from command line"
+ elog "you will need to set your qtgraphicssystem to native"
+ elog "or start CDFPlayer with the '-graphicssystem native' option"
+ elog "see http://forums.gentoo.org/viewtopic-p-7202068.html for details."
}
diff --git a/sci-mathematics/cdfplayer/files/cdfplayer-8.0.4-installer.patch b/sci-mathematics/cdfplayer/files/cdfplayer-9.0.0-installer.patch
index 9deef53c5..65920ccab 100644
--- a/sci-mathematics/cdfplayer/files/cdfplayer-8.0.4-installer.patch
+++ b/sci-mathematics/cdfplayer/files/cdfplayer-9.0.0-installer.patch
@@ -1,5 +1,5 @@
---- CDFPlayer_8.0.4_LINUX.sh
-+++ CDFPlayer_8.0.4_LINUX.sh
+--- CDFPlayer_9.0.0_LINUX.sh
++++ CDFPlayer_9.0.0_LINUX.sh
@@ -261,11 +261,11 @@
fi
done