aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--virtual/lapack/lapack-3.6.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/virtual/lapack/lapack-3.6.ebuild b/virtual/lapack/lapack-3.6.ebuild
new file mode 100644
index 000000000..240fd0fa0
--- /dev/null
+++ b/virtual/lapack/lapack-3.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Linear Algebra Package FORTRAN 77 implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc int64"
+
+RDEPEND="
+ !app-eselect/eselect-lapack
+ || (
+ >=sci-libs/lapack-reference-${PV}[int64?,${MULTILIB_USEDEP}]
+ sci-libs/mkl[int64?,${MULTILIB_USEDEP}]
+ abi_x86_64? ( !abi_x86_32? ( >=sci-libs/atlas-3.9.34[lapack] ) )
+ )
+ int64? (
+ >=sci-libs/lapack-reference-${PV}[int64,${MULTILIB_USEDEP}]
+ sci-libs/mkl[int64,${MULTILIB_USEDEP}]
+ )
+ doc? ( >=app-doc/lapack-docs-3.3 )"
+DEPEND=""
+
+pkg_pretend() {
+ if [[ -e "${EROOT%/}"/usr/$(get_libdir)/lib${PN}.so ]]; then
+ ewarn "You have still the old ${PN} library symlink present"
+ ewarn "Please delete"
+ ewarn "${EROOT%/}/usr/$(get_libdir)/lib${PN}.so"
+ ewarn "to avoid problems with new ${PN} structure"
+ fi
+}