aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-cluster/condor/ChangeLog7
-rw-r--r--sys-cluster/condor/Manifest4
-rw-r--r--sys-cluster/condor/condor-7.5.4.ebuild160
3 files changed, 169 insertions, 2 deletions
diff --git a/sys-cluster/condor/ChangeLog b/sys-cluster/condor/ChangeLog
index c553548c0..484d64224 100644
--- a/sys-cluster/condor/ChangeLog
+++ b/sys-cluster/condor/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sys-cluster/condor
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*condor-7.5.4 (08 Jan 2011)
+
+ 08 Jan 2011; Sébastien Fabbro <bicatali@gentoo.org> +condor-7.5.4.ebuild:
+ Version bump
+
22 Jun 2010; Sébastien Fabbro <bicatali@gentoo.org> condor-7.5.2.ebuild,
files/condor.initd:
More initd fixes, now local config will reside in /var/lib
diff --git a/sys-cluster/condor/Manifest b/sys-cluster/condor/Manifest
index 57fa9004d..795698cbb 100644
--- a/sys-cluster/condor/Manifest
+++ b/sys-cluster/condor/Manifest
@@ -2,6 +2,8 @@ AUX condor.confd 75 RMD160 a58d37af4bbbcf1df486dd1397209832114cb614 SHA1 fcc784f
AUX condor.initd 1783 RMD160 0af1b75734da761674693a768ef9a00fd3f1849c SHA1 2fa56c701351e15966754245893257e26defc642 SHA256 11d1ff517d1ca0ed53a69cdc444cf8020932b20970d1b73078c2b7223d57cf41
AUX condor_config.local 273 RMD160 5aa8e9b62d57059667aac9f2c583cf3f2490b603 SHA1 d53d14ce4fb79510ae267ad6070f0bf6e42e0db1 SHA256 849985bc53bb39c464c55e30a8ae5b7d33e90b2ccee8337452b17bf87edc0b1f
DIST condor_src-7.5.2-all-all.tar.gz 21705891 RMD160 f9911e3a44b69bb22ef607964aec726b51ab9341 SHA1 7e85048545423b13f8173c6ba6d76d35b97f2dcc SHA256 1a4fc437541896aa9963f12ec9231495f6a5ab4cc5ca814b57755a38db407026
+DIST condor_src-7.5.4-all-all.tar.gz 21870900 RMD160 7118a7a7ee32d5d7d9378ed5b94ad7a058ac1fca SHA1 877f748b53dd5e796592f812ae65d75f7b907812 SHA256 a0429b2525047b2eaca988ff4546ff177a5b4e55511354c793e4b3f01b032c08
EBUILD condor-7.5.2.ebuild 4345 RMD160 912cb92deabde325068da49048edf483fb6b9f34 SHA1 73778f44eab0ab48d9466310b75bce1a54de2338 SHA256 37c88bdba428fb366ef8a220c492cbec73e6b84f3e5517b108c7869ce0aac237
-MISC ChangeLog 1461 RMD160 ca2724f6861e01ee441de87906846e34e7b36b25 SHA1 3a0577bcdbf180b5f80e02067548c1be2cc709be SHA256 7c52b89de1c861e71b16f3f974bcb3d70baa8cebceee9b74f4cf33eae9d6e726
+EBUILD condor-7.5.4.ebuild 4345 RMD160 c43f5b08d8d77cf07ca9b0d21c87e33eaf636b4e SHA1 0d25cdcc0c58506a8e9bcdfbaae2355dd5ab5998 SHA256 d0809dd9ec219939bba4788748a919a5950ed554f1b02c4d30794dc32b4df7f2
+MISC ChangeLog 1583 RMD160 1d4525812580e576ad5b458172b791955f9040d3 SHA1 03a96168e04e92d8ed58dccd6b4a3ab023c9ec4d SHA256 90a334777278b4fdb6fdfca76bf3fa25f29c06541112c014caf4cabfe6673eb0
MISC metadata.xml 1247 RMD160 bcc91575dc0a5cc4ac255d5c0c415d0ade7c96c4 SHA1 a9a3ca65688dc4f32a01df1a5c329065fc7b37bf SHA256 87fdc2d2b126339048785a67fa126a184ffdf08a6bf6e6e29e78c62581ca1f0f
diff --git a/sys-cluster/condor/condor-7.5.4.ebuild b/sys-cluster/condor/condor-7.5.4.ebuild
new file mode 100644
index 000000000..daf9d0f73
--- /dev/null
+++ b/sys-cluster/condor/condor-7.5.4.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="Workload management system for compute-intensive jobs"
+HOMEPAGE="http://www.cs.wisc.edu/condor/"
+SRC_URI="${PN}_src-${PV}-all-all.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="classads drmaa examples gcb kbdd kerberos postgres soap ssl static-libs"
+
+CDEPEND="sys-libs/zlib
+ app-emulation/libvirt
+ dev-libs/libpcre
+ classads? ( sys-cluster/classads[pcre] )
+ gcb? ( net-firewall/gcb )
+ kerberos? ( app-crypt/mit-krb5 )
+ kbdd? ( x11-libs/libX11 )
+ postgres? ( dev-db/postgresql-base )
+ soap? ( net-libs/gsoap )
+ ssl? ( dev-libs/openssl )"
+
+RDEPEND="${CDEPEND}
+ mail-client/mailx"
+
+DEPEND="${CDEPEND}
+ x11-misc/imake"
+
+RESTRICT=fetch
+
+S="${WORKDIR}/${P}/src"
+
+pkg_setup() {
+ enewgroup condor
+ enewuser condor -1 "${ROOT}"bin/bash "${ROOT}var/lib/condor" condor
+}
+
+src_prepare() {
+ # these two eauto* are to replicate the build_init script
+ # not so sure they are really needed
+ eautoheader
+ eautoconf
+ # this patch is mostly to use standard fhs
+ cd condor_examples
+ epatch ./condor_config.generic.rpm.patch
+ # the base local file is in /etc, then the condor local file is updated and should reside in /var/lib
+ sed -i \
+ -e 's:\(LOCAL_CONFIG_FILE.*=\).*:\1 /var/lib/condor/condor_config.local:' \
+ condor_config.generic || die
+}
+
+src_configure() {
+ # condor seems to be buggy with -O2 and above with gcc
+ filter-flags "-O[s2-9]" "-O1"
+
+ # set USE_OLD_IMAKE to anything so condor_imake will use the system
+ # installed imake instead of building its own
+ export USE_OLD_IMAKE=YES
+ econf \
+ --with-buildid=Gentoo-${P} \
+ --enable-proper \
+ --disable-full-port \
+ --disable-gcc-version-check \
+ --disable-glibc-version-check \
+ --disable-rpm \
+ --without-zlib \
+ --with-libvirt \
+ $(use_enable kbdd) \
+ $(use_enable postgres quill) \
+ $(use_enable static-libs static) \
+ $(use_with classads) \
+ $(use_with drmaa) \
+ $(use_with gcb) \
+ $(use_with kerberos krb5) \
+ $(use_with postgres postgresql) \
+ $(use_with soap gsoap) \
+ $(use_with ssl openssl)
+}
+
+src_compile() {
+ # yet to find a way to parallelize compilation
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake release manpages || die "emake release failed"
+ if use static-libs; then
+ emake static || die "emake static failed"
+ fi
+
+ cd release_dir
+ ## remove a shitload of useless stuff to sync with the rpm package
+ ## comments are from the rpm fedora spec file
+ # used by old MPI universe, not packaged (it's rsh, it should die)
+ rm -rf libexec/rsh
+ # this is distributed as chirp_client.c/h and chirp_protocol.h
+ rm lib/libchirp_client.a include/chirp_client.h
+ # checkpoint, reschedule and vacate live in bin/, don't duplicate
+ rm sbin/condor_{checkpoint,reschedule,vacate}
+ # sbin/condor is a pointless hard links
+ rm sbin/condor
+
+ # binaries
+ dosbin sbin/* || die
+ dobin bin/* || die
+ # headers
+ insinto /usr
+ doins -r include || die
+ # libs
+ dolib.so lib/*so || die
+ use static-libs && dolib.a lib/*a
+ insinto /usr/libexec/condor
+ doins -r libexec/* || die
+
+ # data files
+ insinto /usr/share/${PN}
+ doins lib/*.jar lib/*.class lib/*.pm || die
+ use postgres && doins -r sql
+
+ # examples
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r etc/examples || die
+ fi
+
+ # config files
+ insinto /etc/condor
+ newins etc/examples/condor_config.generic condor_config || die
+ newins etc/examples/condor_config.local.generic condor_config.local || die
+ insinto /var/lib/condor/
+ newins etc/examples/condor_config.local.generic
+
+ dodir /var/log/condor
+ dodir /var/run/condor
+ dodir /var/lock/condor
+
+ fperms 750 /var/lib/condor /var/log/condor
+ fperms 755 /var/run/condor
+ fperms 0775 /var/lock/condor
+ fowners condor:condor /var/lib/condor /var/log/condor /var/run/condor /var/lib/condor/condor_config.local
+
+ newconfd "${FILESDIR}"/condor.confd condor || die
+ newinitd "${FILESDIR}"/condor.initd condor || die
+}
+
+pkg_postinst() {
+ elog "Default configuration files have been installed"
+ elog "You can customize it from there or provide your own"
+ elog "in ${ROOT}etc/${PN}/condor_config*"
+
+ elog "The condor ebuild is still under development."
+ elog "Help us improve the ebuild in participating in:"
+ elog "https://bugs.gentoo.org/show_bug.cgi?id=60281"
+}