aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/dealii/dealii-9999.ebuild10
-rw-r--r--sci-libs/dealii/metadata.xml2
2 files changed, 9 insertions, 3 deletions
diff --git a/sci-libs/dealii/dealii-9999.ebuild b/sci-libs/dealii/dealii-9999.ebuild
index a992a7691..3d45ca624 100644
--- a/sci-libs/dealii/dealii-9999.ebuild
+++ b/sci-libs/dealii/dealii-9999.ebuild
@@ -33,9 +33,9 @@ fi
LICENSE="LGPL-2.1+"
SLOT="0"
IUSE="
- arpack cpu_flags_x86_avx cpu_flags_x86_sse2 +debug doc +examples
- +gsl hdf5 +lapack metis mpi muparser opencascade netcdf p4est petsc
- slepc +sparse static-libs +tbb trilinos
+ adolc arpack cpu_flags_x86_avx cpu_flags_x86_sse2 +debug doc +examples
+ +gsl hdf5 +lapack metis mpi muparser nanoflann opencascade netcdf p4est
+ petsc slepc +sparse static-libs +tbb trilinos
"
# TODO: add slepc use flag once slepc is packaged for gentoo-science
@@ -47,6 +47,7 @@ REQUIRED_USE="
RDEPEND="dev-libs/boost
app-arch/bzip2
sys-libs/zlib
+ adolc? ( sci-libs/adolc )
arpack? ( sci-libs/arpack[mpi=] )
gsl? ( sci-libs/gsl )
hdf5? ( sci-libs/hdf5[mpi=] )
@@ -54,6 +55,7 @@ RDEPEND="dev-libs/boost
metis? ( >=sci-libs/parmetis-4 )
mpi? ( virtual/mpi )
muparser? ( dev-cpp/muParser )
+ nanoflann? ( sci-libs/nanoflann )
netcdf? ( sci-libs/netcdf-cxx:0 )
opencascade? ( sci-libs/opencascade:* )
p4est? ( sci-libs/p4est[mpi] )
@@ -86,6 +88,7 @@ src_configure() {
-DDEAL_II_SHARE_RELDIR="share/${PN}"
-DDEAL_II_WITH_BZIP2=ON
-DDEAL_II_WITH_ZLIB=ON
+ -DDEAL_II_WITH_ADOLC="$(usex adolc)"
-DDEAL_II_WITH_ARPACK="$(usex arpack)"
-DDEAL_II_HAVE_AVX="$(usex cpu_flags_x86_avx)"
-DDEAL_II_HAVE_SSE2="$(usex cpu_flags_x86_sse2)"
@@ -97,6 +100,7 @@ src_configure() {
-DDEAL_II_WITH_METIS="$(usex metis)"
-DDEAL_II_WITH_MPI="$(usex mpi)"
-DDEAL_II_WITH_MUPARSER="$(usex muparser)"
+ -DDEAL_II_WITH_NANOFLANN="$(usex nanoflann)"
-DDEAL_II_WITH_NETCDF="$(usex netcdf)"
-DOPENCASCADE_DIR="${CASROOT}"
-DDEAL_II_WITH_OPENCASCADE="$(usex opencascade)"
diff --git a/sci-libs/dealii/metadata.xml b/sci-libs/dealii/metadata.xml
index 9b9c83ecc..929d8544d 100644
--- a/sci-libs/dealii/metadata.xml
+++ b/sci-libs/dealii/metadata.xml
@@ -16,6 +16,7 @@ state-of-the-art programming techniques to offer you a modern interface
to the complex data structures and algorithms required.
</longdescription>
<use>
+ <flag name="adolc">Adds support for ADOL-C (<pkg>sci-libs/adolc</pkg>)</flag>
<flag name="arpack">Adds support for ARPACK (<pkg>sci-libs/arpack</pkg>)</flag>
<flag name="debug">
Build an additional debug library with extra debug codepaths, like asserts
@@ -26,6 +27,7 @@ and extra output. If you want to get meaningful backtraces see
<flag name="metis">Add support for metis (<pkg>sci-libs/metis</pkg>)</flag>
<flag name="mumps">Add support for mumps (<pkg>sci-libs/mumps</pkg>)</flag>
<flag name="muparser">Add support for muparser (<pkg>dev-cpp/muParser</pkg>)</flag>
+ <flag name="nanoflann">Adds support for nanoflann (<pkg>sci-libs/nanoflann</pkg>)</flag>
<flag name="opencascade">Add support for opencascade (<pkg>sci-libs/opencascade</pkg>)</flag>
<flag name="p4est">Add support for p4est (<pkg>sci-mathematics/p4est</pkg>)</flag>
<flag name="parameter_gui">Build and install the parameter_gui executable</flag>