aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-tex/pythontex/Manifest1
-rw-r--r--dev-tex/pythontex/pythontex-0.15.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-tex/pythontex/Manifest b/dev-tex/pythontex/Manifest
index f169302cd..e73dfec2c 100644
--- a/dev-tex/pythontex/Manifest
+++ b/dev-tex/pythontex/Manifest
@@ -1 +1,2 @@
DIST pythontex-0.14.tar.gz 9704671 SHA256 d26501386d313cc7a0375e4ea3bec61aed38abb059f09042c8e0e015e980bce4 SHA512 dc37e3ac112ace95d4ac253f51fe08074cf465537fa8e686637dd2342edb397e89a1e9ee1111fd6b93bcf4194b8bbbcb5cbcc5256d4c451809bf96bb28ae3db6 WHIRLPOOL 9a5106446b61f514b3575170abcba0b9cd6eb2c896c6a12174cd4ae1c01e442e7625cde2cab06b2828e3fc07f4fac9edca4388253c49e8952fb4ad7829355366
+DIST pythontex-0.15.tar.gz 1765050 SHA256 5020ca647239368d38e64787cd41b43922677a80338cc7f61ab3786fe20e2fa6 SHA512 cbca1dc9208028bfe1a8ab47f6c145ec2bd0af0ad2c733ef80e1f9ee77199670c8701d30e7634207064dd073e5456bb1d1853ce4e1729f64c44967a52111b0d8 WHIRLPOOL 1e912201d5644dedb8fbe093e85bb056c8f677ffbdcd1888deedcec346b9b8a9791a127ee2f60f825170d3d323586e12c0a8af902edeec0f97a1d96ae0217d80
diff --git a/dev-tex/pythontex/pythontex-0.15.ebuild b/dev-tex/pythontex/pythontex-0.15.ebuild
new file mode 100644
index 000000000..6526b9fc6
--- /dev/null
+++ b/dev-tex/pythontex/pythontex-0.15.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit latex-package python-r1
+
+DESCRIPTION="Fast Access to Python from within LaTeX"
+HOMEPAGE="https://github.com/gpoore/pythontex"
+SRC_URI="https://github.com/gpoore/pythontex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LPPL-1.3 BSD"
+KEYWORDS="~amd64"
+IUSE="highlighting"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-texlive/texlive-latex-2016"
+RDEPEND="${DEPEND}
+ >=dev-texlive/texlive-latex-2016
+ highlighting? ( dev-python/pygments[${PYTHON_USEDEP}] )"
+
+TEXMF=/usr/share/texmf-site
+
+src_compile() {
+ cd ${PN} || die
+ ebegin "Compiling ${PN}"
+ rm ${PN}.sty || die
+ VARTEXFONTS="${T}/fonts" latex ${PN}.ins extra || die
+ eend
+}
+
+src_install() {
+ dodoc ${PN}/README "${S}"/*rst ${PN}_quickstart/*
+
+ cd ${PN} || die
+
+ installation() {
+ if python_is_python3; then
+ python_domodule {de,}${PN}3.py
+ else
+ python_domodule {de,}${PN}2.py
+ fi
+ python_domodule ${PN}_{engines,utils}.py
+ python_doscript {de,}${PN}.py syncpdb.py
+ python_optimize
+ }
+ python_foreach_impl installation
+
+ latex-package_src_doinstall dtx ins sty
+}