aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/ntCard/Manifest1
-rw-r--r--sci-biology/ntCard/metadata.xml12
-rw-r--r--sci-biology/ntCard/ntCard-1.0.1.ebuild23
-rw-r--r--sci-biology/ntCard/ntCard-9999.ebuild23
4 files changed, 59 insertions, 0 deletions
diff --git a/sci-biology/ntCard/Manifest b/sci-biology/ntCard/Manifest
new file mode 100644
index 000000000..db34bc5a0
--- /dev/null
+++ b/sci-biology/ntCard/Manifest
@@ -0,0 +1 @@
+DIST ntCard-1.0.1.tar.gz 15676 BLAKE2B 1a4c4f0a9d632e2ccd8e3516cf07939d4423298247560b6dd4fc5df3a4c3b60c603a8dd11652e8571705452e8c80c84c01a2e9356d2294acb48abfc02683891a SHA512 dc1c2ea0cace3e8462a6f3777559f4db11800d8b8a89c1c1a0adaea25d950cb98aed5d5b613a51d5dde5dacf842ca363a2c5985ae5e391a7104efd489928a36c
diff --git a/sci-biology/ntCard/metadata.xml b/sci-biology/ntCard/metadata.xml
new file mode 100644
index 000000000..138cb7705
--- /dev/null
+++ b/sci-biology/ntCard/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-biology/ntCard/ntCard-1.0.1.ebuild b/sci-biology/ntCard/ntCard-1.0.1.ebuild
new file mode 100644
index 000000000..14470723a
--- /dev/null
+++ b/sci-biology/ntCard/ntCard-1.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="Estimate k-mer coverage histogram of genomics data"
+HOMEPAGE="https://github.com/bcgsc/ntCard"
+SRC_URI="https://github.com/bcgsc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ sh ./autogen.sh || die
+ default
+}
diff --git a/sci-biology/ntCard/ntCard-9999.ebuild b/sci-biology/ntCard/ntCard-9999.ebuild
new file mode 100644
index 000000000..15b29ff93
--- /dev/null
+++ b/sci-biology/ntCard/ntCard-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils git-r3
+
+DESCRIPTION="Estimate k-mer coverage histogram of genomics data"
+HOMEPAGE="https://github.com/bcgsc/ntCard"
+EGIT_REPO_URI="https://github.com/bcgsc/ntCard.git"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ sh ./autogen.sh || die
+ default
+}