aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/mouse-brain-atlases/Manifest2
-rw-r--r--sci-biology/mouse-brain-atlases/metadata.xml3
-rw-r--r--sci-biology/mouse-brain-atlases/mouse-brain-atlases-0.1.20180717.ebuild44
3 files changed, 49 insertions, 0 deletions
diff --git a/sci-biology/mouse-brain-atlases/Manifest b/sci-biology/mouse-brain-atlases/Manifest
index 92a0ea774..afe21dda6 100644
--- a/sci-biology/mouse-brain-atlases/Manifest
+++ b/sci-biology/mouse-brain-atlases/Manifest
@@ -1,2 +1,4 @@
DIST mouse-brain-atlases-0.1.20180623.zip 709080130 BLAKE2B 887aeb7ec4dca61776449a2853ba935c74330e7ee00ccffb422e5d45f3f3d975b766ad54cb95f8bf2c901fece0870b7283f500fab0431b50e76a6018c13a0ee3 SHA512 a39beb02b9b342a556728a6a4b92e948eff0d5f45daea578318ce81322197e579934475c049cf6c6361110d7901cb8b82d8254c906bb45986e3ed9290ac41ebc
DIST mouse-brain-atlases-0.1.20180704.zip 709083338 BLAKE2B d0236f5a2dbb60f0e27a4d75a2b6f8f30988380f462e7c0722f86e25160020227f9a0975f12b3389aeab143d6766e9073870fbf162fa74bd42ecaee9a66a90e1 SHA512 c7f56b15f40fcc87b42e0d5e5757ea15e95b730e6df6aa56856cdaaf5d04075b5686327b0ce66e966e7ef53a2da89541f2069f1a420d233322862b6602d329a5
+DIST mouse-brain-atlases-0.1.20180717.tar.xz 125126760 BLAKE2B e777a89bb98d1eda2fe5943dd8eb4c135ce42cd233ea0ac7d6d50a6c4fb0c521839a9f45e6627cc9b8c292ad2cc0a925edadd4c69556b8d455d17e4beceedb5a SHA512 a3b1e5abe66e2b22122b9436d178a6e9c9b5b5a236487331212cb6ecee8432c3bdbaa730e7131be58db7d82999778409afcfee419ff1d98b9e109e1d1cee233f
+DIST mouse-brain-atlasesHD-0.1.20180717.tar.xz 391527184 BLAKE2B 999c7da01786b90724ecf4c80cd0124163bd0a8c01b6589f4d8d2abb755c79f89f33d830c7c801534cb05241be43a57e7ea6a805ea164fd8f2fc379c32fb0087 SHA512 ac0a3ccdd32c56d0d7862cbfa1d75c7b36ab140503239feb315f8ccec7f07c6af6a123f871fe3a218008c7709762fa2b1349932112eb25d564ba69b7de151e70
diff --git a/sci-biology/mouse-brain-atlases/metadata.xml b/sci-biology/mouse-brain-atlases/metadata.xml
index 4562cfeb1..a8c20f15c 100644
--- a/sci-biology/mouse-brain-atlases/metadata.xml
+++ b/sci-biology/mouse-brain-atlases/metadata.xml
@@ -13,4 +13,7 @@
Digital mouse brain atlases in NIfTI format for use in magnetic
resonance mouse brain imaging.
</longdescription>
+ <use>
+ <flag name="hires">Also install high-resolution atlases.</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-biology/mouse-brain-atlases/mouse-brain-atlases-0.1.20180717.ebuild b/sci-biology/mouse-brain-atlases/mouse-brain-atlases-0.1.20180717.ebuild
new file mode 100644
index 000000000..48cfab4bb
--- /dev/null
+++ b/sci-biology/mouse-brain-atlases/mouse-brain-atlases-0.1.20180717.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit check-reqs
+
+DESCRIPTION="A collection of mouse brain atlases in NIfTI format"
+HOMEPAGE="http://imaging.org.au/AMBMC/Model"
+SRC_URI="
+ http://chymera.eu/distfiles/${P}.tar.xz
+ hires? ( http://chymera.eu/distfiles/${PN}HD-${PV}.tar.xz )
+ "
+
+LICENSE="fairuse"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="hires"
+
+RDEPEND=""
+DEPEND=""
+
+pkg_pretend() {
+ if use hires; then
+ CHECKREQS_DISK_BUILD="4G"
+ CHECKREQS_DISK_USR="4G"
+ CHECKREQS_DISK_VAR="8G"
+ else
+ CHECKREQS_DISK_BUILD="500M"
+ fi
+ check-reqs_pkg_pretend
+}
+
+# We disable this phase to not check requirements twice.
+pkg_setup() { :; }
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ doins *
+ if use hires; then
+ cd "../${PN}HD-${PV}"
+ doins *
+ fi
+}