aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/phusion/ChangeLog10
-rw-r--r--sci-biology/phusion/Manifest1
-rw-r--r--sci-biology/phusion/metadata.xml9
-rw-r--r--sci-biology/phusion/phusion-2.1c.ebuild42
4 files changed, 62 insertions, 0 deletions
diff --git a/sci-biology/phusion/ChangeLog b/sci-biology/phusion/ChangeLog
new file mode 100644
index 000000000..b82964513
--- /dev/null
+++ b/sci-biology/phusion/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-biology/phusion
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*phusion-2.1c (02 May 2015)
+
+ 02 May 2015; Martin Mokrejs <mmokrejs@fold.natur.cuni.cz> +metadata.xml,
+ +phusion-2.1c.ebuild:
+ sci-biology/phusion: clarified missing LICENSE, have asked upstream for
+ clarification
diff --git a/sci-biology/phusion/Manifest b/sci-biology/phusion/Manifest
new file mode 100644
index 000000000..ded1cc97c
--- /dev/null
+++ b/sci-biology/phusion/Manifest
@@ -0,0 +1 @@
+DIST phusion_pipeline_v2.1c.tar.gz 12029104 SHA256 d6cd98d9194faf91c3b497c569529f0b0af8b2fa7bf083d24a5c946fd2804457 SHA512 b5ed5b2b893fa3d4cdbb6ae96acf515894b1df65ba2536f3a47829f383eca1e157f1b7b117e0d1bf0f763328e8bc2ffddac9a570dbec757c057040c3fb66a765 WHIRLPOOL 76d21eb6ab558395ac7b18043b4e4e31d1b2a6f02779f09fcbc2e2591a304738af5ab9abe042d3a982f73fd04cf32c1125d8798f3e04ab6fb67fcaa7c2b6e642
diff --git a/sci-biology/phusion/metadata.xml b/sci-biology/phusion/metadata.xml
new file mode 100644
index 000000000..2bc893037
--- /dev/null
+++ b/sci-biology/phusion/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <maintainer>
+ <email>mmokrejs@fold.natur.cuni.cz</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-biology/phusion/phusion-2.1c.ebuild b/sci-biology/phusion/phusion-2.1c.ebuild
new file mode 100644
index 000000000..14fde04dc
--- /dev/null
+++ b/sci-biology/phusion/phusion-2.1c.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Whole genome shotgun assembler using phrap (for Sanger-based reads)"
+HOMEPAGE="http://www.sanger.ac.uk/resources/software/phusion/"
+SRC_URI="ftp://ftp.sanger.ac.uk/pub/resources/software/phusion/phusion_pipeline_v2.1c.tar.gz"
+
+LICENSE="all-rights-reserved" # temporarily placed value
+# from http://genome.cshlp.org/content/13/1/81.full
+# Availability
+# Phusion is undergoing a rewrite of the code to make this a portable package. It will be made available free of charge to academic sites, but requires licensing for commercial use. For more information please contact the authors.
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+DEPEND="app-shells/tcsh"
+RDEPEND="${DEPEND}
+ sci-biology/phrap
+ dev-lang/perl"
+
+# contains bundled ssaha
+# file collision with sci-biology/shrimp on /usr/bin/fasta2fastq
+
+S="${WORKDIR}"/"phusion_pipeline_v2.1c"
+
+src_prepare(){
+ cp -pf /usr/bin/phrap src/phrap/phrap.manylong || die
+}
+
+src_compile(){
+ tcsh install.csh || csh install.csh || die
+}
+
+src_install(){
+ dobin bin/*
+ dodoc README.1st releaseNote_v2.1c doc/*
+}