aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/cernbox-client/Manifest2
-rw-r--r--net-misc/cernbox-client/cernbox-client-2.2.3.ebuild119
-rw-r--r--net-misc/cernbox-client/files/shell-integration-dolphin.patch36
-rw-r--r--net-misc/cernbox-client/files/shell-integration-nautilus.patch13
-rw-r--r--net-misc/cernbox-client/metadata.xml27
5 files changed, 197 insertions, 0 deletions
diff --git a/net-misc/cernbox-client/Manifest b/net-misc/cernbox-client/Manifest
new file mode 100644
index 000000000..a95a3d3ce
--- /dev/null
+++ b/net-misc/cernbox-client/Manifest
@@ -0,0 +1,2 @@
+DIST cernbox-client-2.1.1-1.1.src.rpm 13110999 SHA256 955f660e95ae5290ab6a9b05af6c6a0012428b574921f8d0a80a349a1ec39ead SHA512 25a53d88d393406ce4076932a1757dc27b2bbbe1a38a2d5f084024352a6467eb2ca650e1f5b86d5551f0277d4e4d9011f967e3651d86ed9b58a7296a8abe0039 WHIRLPOOL a5f416a299e49118a73a591f1ca6b58eb41d64bb84454ba363f27ccfdb4e38e5a1ab29395c9a4b1fbdd36d5d400dfac9567cd11cc8d0fd32bf5145917835187f
+DIST owncloudclient-2.2.3.tar.xz 12215320 SHA256 f8c921e3eda543c6c860ea8e3024ed164df0db7c0e83d1778ab0adfd324f7d01 SHA512 71be325e5d6177a767dc61b043bd6126b5b7a492a2a777c0179c2dbb77bf6104e26fce92734a6d4bfcc7b9c451026e86a2f44d39869e9451f21b0e534c26e189 WHIRLPOOL 7099c62214f1170c6ec3dfe2adc1c692d8847a0643bd7f5d5a5028f65e395774a29eec3ee6ece72e9e85dd343b05c3c1184665db34e635b2b99c6e15a33ce54e
diff --git a/net-misc/cernbox-client/cernbox-client-2.2.3.ebuild b/net-misc/cernbox-client/cernbox-client-2.2.3.ebuild
new file mode 100644
index 000000000..5f5693ab6
--- /dev/null
+++ b/net-misc/cernbox-client/cernbox-client-2.2.3.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils rpm
+
+DESCRIPTION="Synchronize files from CERNbox EOS with your computer"
+
+# Origin is classic owncloud-client, branded for CERN during compilation.
+ORIGIN_P="owncloudclient"
+BRANDED_P="cernbox"
+BRANDED_PV="2.1.1"
+BRANDED_REL="1.1"
+
+HOMEPAGE="https://cernbox.cern.ch/"
+SRC_URI="http://download.owncloud.com/desktop/stable/${ORIGIN_P}-${PV}.tar.xz
+ https://cernbox.cern.ch/cernbox/doc/Linux/repo/CentOS_7/src/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm"
+
+LICENSE="CC-BY-3.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc dolphin nautilus samba +sftp test qt4 +qt5"
+
+REQUIRED_USE="^^ ( qt4 qt5 )
+ dolphin? ( qt5 )"
+
+RDEPEND=">=dev-db/sqlite-3.4:3
+ sys-fs/inotify-tools
+ virtual/libiconv
+ dolphin? (
+ >=kde-frameworks/kcoreaddons-5.16:5
+ >=kde-frameworks/kio-5.16:5 )
+ nautilus? ( dev-python/nautilus-python )
+ qt4? (
+ dev-libs/qtkeychain[qt4]
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4
+ dev-qt/qtwebkit:4
+ net-libs/neon[ssl]
+ )
+ qt5? (
+ dev-libs/qtkeychain[qt5]
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ >=dev-qt/qtnetwork-5.4:5
+ dev-qt/qtgui:5
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtsql:5
+ dev-qt/qtwebkit:5[printsupport]
+ )
+ samba? ( >=net-fs/samba-3.5 )
+ sftp? ( >=net-libs/libssh-0.5 )
+ !net-misc/ocsync
+ !net-misc/nextcloud-client"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ )
+ dolphin? ( >=kde-frameworks/extra-cmake-modules-5.22.0 )
+ qt5? ( dev-qt/linguist-tools:5 )
+ test? (
+ dev-util/cmocka
+ qt4? ( dev-qt/qttest:4 )
+ qt5? ( dev-qt/qttest:5 )
+ )"
+
+S=${WORKDIR}/owncloudclient-${PV}
+
+src_unpack() {
+ rpm_src_unpack ${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm
+ mv ${PN/-}-${BRANDED_PV}/cernbox "${S}" || die "failed to extract branding"
+}
+
+src_prepare() {
+ # Keep tests in ${T}
+ sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die "sed failed"
+
+ if ! use nautilus; then
+ pushd shell_integration > /dev/null || die
+ cmake_comment_add_subdirectory nautilus
+ popd > /dev/null || die
+ fi
+
+ eapply "${FILESDIR}"/shell-integration-nautilus.patch \
+ "${FILESDIR}"/shell-integration-dolphin.patch
+
+ default
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DWITH_ICONV=ON
+ -DWITH_DOC=$(usex doc)
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5=$(usex !dolphin)
+ -DBUILD_WITH_QT4=$(usex qt4)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libsmbclient=$(usex !samba)
+ -DCMAKE_DISABLE_FIND_PACKAGE_LibSSH=$(usex !sftp)
+ -DUNIT_TESTING=$(usex test)
+ -DOEM_THEME_DIR=${PWD}/${BRANDED_P}/mirall
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ if ! use doc ; then
+ elog "Documentation and man pages not installed"
+ elog "Enable doc USE-flag to generate them"
+ fi
+}
diff --git a/net-misc/cernbox-client/files/shell-integration-dolphin.patch b/net-misc/cernbox-client/files/shell-integration-dolphin.patch
new file mode 100644
index 000000000..69631b8d2
--- /dev/null
+++ b/net-misc/cernbox-client/files/shell-integration-dolphin.patch
@@ -0,0 +1,36 @@
+From acdcc9ee50db0e010dbda185356868d65a231070 Mon Sep 17 00:00:00 2001
+From: Klaas Freitag <freitag@owncloud.com>
+Date: Mon, 12 Sep 2016 13:50:41 +0200
+Subject: [PATCH] Dolphin Plugin: Use the Application name for the socket path
+
+do not hardcode.
+
+This should fix #5165
+---
+ shell_integration/dolphin/ownclouddolphinpluginhelper.cpp | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/shell_integration/dolphin/ownclouddolphinpluginhelper.cpp b/shell_integration/dolphin/ownclouddolphinpluginhelper.cpp
+index 027e0e6..68c2a9c 100644
+--- a/shell_integration/dolphin/ownclouddolphinpluginhelper.cpp
++++ b/shell_integration/dolphin/ownclouddolphinpluginhelper.cpp
+@@ -21,6 +21,7 @@
+ #include <qcoreevent.h>
+ #include <QFile>
+ #include "ownclouddolphinpluginhelper.h"
++#include "config.h"
+
+ OwncloudDolphinPluginHelper* OwncloudDolphinPluginHelper::instance()
+ {
+@@ -67,7 +68,10 @@ void OwncloudDolphinPluginHelper::tryConnect()
+ return;
+ }
+ QString runtimeDir = QFile::decodeName(qgetenv("XDG_RUNTIME_DIR"));
+- QString socketPath = runtimeDir + QLatin1String("/ownCloud/socket");
++ runtimeDir.append( QChar('/'));
++ runtimeDir.append( QLatin1String(APPLICATION_SHORTNAME) );
++
++ const QString socketPath = runtimeDir + QLatin1String("/socket");
+ _socket.connectToServer(socketPath);
+ }
+
diff --git a/net-misc/cernbox-client/files/shell-integration-nautilus.patch b/net-misc/cernbox-client/files/shell-integration-nautilus.patch
new file mode 100644
index 000000000..67aee0274
--- /dev/null
+++ b/net-misc/cernbox-client/files/shell-integration-nautilus.patch
@@ -0,0 +1,13 @@
+--- a/shell_integration/nautilus/CMakeLists.txt 2016-08-08 15:42:39.000000000 +0200
++++ b/shell_integration/nautilus/CMakeLists.txt 2016-09-10 18:01:22.387950249 +0200
+@@ -19,8 +19,8 @@
+ ERROR_VARIABLE errors OUTPUT_VARIABLE out)
+
+
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/syncstate.py DESTINATION ${DATADIR}/nautilus-python/extensions)
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/syncstate_nemo.py DESTINATION ${DATADIR}/nemo-python/extensions RENAME syncstate.py)
++ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/syncstate.py DESTINATION ${DATADIR}/nautilus-python/extensions RENAME syncstate-${APPLICATION_SHORTNAME}.py)
++ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/syncstate_nemo.py DESTINATION ${DATADIR}/nemo-python/extensions RENAME syncstate-${APPLICATION_SHORTNAME}.py)
+
+
+
diff --git a/net-misc/cernbox-client/metadata.xml b/net-misc/cernbox-client/metadata.xml
new file mode 100644
index 000000000..1a378d6f4
--- /dev/null
+++ b/net-misc/cernbox-client/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ This service provides a cloud synchronisation service for all CERN users between personal devices (like a laptop) and a centrally-managed data storage.
+
+ Available to all CERN users. This service provides synchronisation capabilities:
+ everyone having a CERN computing account can use box to synchronise data (files and directories) across a series of (mobile) devices (smartphones, tablet, laptop, desktop).
+ Major software distributions are supported (notably recent Mac, Linux and Windows).
+
+ The service provides off-line eventually synchronised access to data and it is also meant for data sharing across collaborators (for example to share presentations or text documents).
+
+ The service is not suitable for critical-path activities like data acquisition, world-wide data distribution and massive batch processing.
+ </longdescription>
+ <use>
+ <flag name="dolphin">Install the <pkg>kde-apps/dolphin</pkg> extension</flag>
+ <flag name="nautilus">Install the <pkg>gnome-base/nautilus</pkg> extension</flag>
+ <flag name="sftp">Enable sftp transfer support via <pkg>net-libs/libssh</pkg></flag>
+ </use>
+ <upstream>
+ <doc>http://cernbox.web.cern.ch/cernbox/00_getting_started/index.html</doc>
+ </upstream>
+</pkgmetadata>