aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-mathematics/mdp/ChangeLog3
-rw-r--r--sci-mathematics/mdp/Manifest2
-rw-r--r--sci-mathematics/mdp/mdp-2.4.ebuild27
3 files changed, 32 insertions, 0 deletions
diff --git a/sci-mathematics/mdp/ChangeLog b/sci-mathematics/mdp/ChangeLog
index b7c1524a5..52e369d0f 100644
--- a/sci-mathematics/mdp/ChangeLog
+++ b/sci-mathematics/mdp/ChangeLog
@@ -2,6 +2,9 @@
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 23 Oct 2008; Tim Cera <timcera@earthlink.net> +mdp-2.4.ebuild:
+ Bumped to version 2.4, updated DEPEND.
+
16 Jul 2008; Tim Cera <timcera@earthlink.net> mdp-2.3.ebuild:
Added ~x86 per http://bugs.gentoo.org/show_bug.cgi?id=146976
diff --git a/sci-mathematics/mdp/Manifest b/sci-mathematics/mdp/Manifest
index 39db64511..a72b5396e 100644
--- a/sci-mathematics/mdp/Manifest
+++ b/sci-mathematics/mdp/Manifest
@@ -1,4 +1,6 @@
DIST MDP-2.3.tar.gz 133071 RMD160 b807dca615c8e249a4484aa316a1b545bc89ff7c SHA1 68cbb5ba97398a3471f26aaae84ec17227bfe6a2 SHA256 e5e78670d211e1ca8ad48305fd17af141df60e830e3816a4fa00d4d5ce5318fa
+DIST MDP-2.4.tar.gz 162171 RMD160 33381ef9fc2f62c3b51da037a181da7cff0925fe SHA1 90c7213a20f570742a1753c32dffa70ce6ffdb99 SHA256 85d1a51ee56f4ed5021d56616646dd393c41a32a7390b49a7f19f9f02961ddff
EBUILD mdp-2.3.ebuild 622 RMD160 aa479535fa37bee1c97dcbeec441cfbfe1661d76 SHA1 bc4ea5b3a44da23f729ac57981d64ace17561dbd SHA256 0d16b4660c627a0b5395d16e9191b6c2ab2c4783cc4edb3d57519db97e6f24e7
+EBUILD mdp-2.4.ebuild 654 RMD160 cd0d6a55e9cbc243427f8c882a85d0bebc323339 SHA1 65741040f6bc19f631a2cae8167c073b1ec0e024 SHA256 778369dd65b024e67e688ecfef2888816e8a648bc251dc5a0f469b4adf68455d
MISC ChangeLog 349 RMD160 a77b349a9f87d2384e245dbdd37cad1c8dd6e6e4 SHA1 b11ab006c5c555e7751cec834fbed455f730d81a SHA256 3202ba570e2868d7fcd86f3cf8e765ff2d0629e8fe65eebbc897cc744e647874
MISC metadata.xml 690 RMD160 ed4cf64e00309f9392595cfff9c5fae9034f252d SHA1 9db6ee0717246d2e588733dc9e5c339164c39ec2 SHA256 1dc442202528ffd5c0d9d256ad33868ad935664f30c3b143401866634af5a2d9
diff --git a/sci-mathematics/mdp/mdp-2.4.ebuild b/sci-mathematics/mdp/mdp-2.4.ebuild
new file mode 100644
index 000000000..db15330be
--- /dev/null
+++ b/sci-mathematics/mdp/mdp-2.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit distutils
+
+DESCRIPTION="A Python data processing framework."
+HOMEPAGE="http://mdp-toolkit.sourceforge.net/index.html"
+
+MY_P="${P/mdp/MDP}"
+MY_P="${MY_P/_rc/RC}"
+S="${WORKDIR}/${MY_P}"
+
+SRC_URI="mirror://sourceforge/mdp-toolkit/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="virtual/python
+ >=dev-lang/python-2.4
+ ( >=dev-python/numpy-1.1 ) || ( >=sci-libs/scipy-0.5.2 )"
+RDEPEND="${DEPEND}"
+
+src_test() {
+ PYTHONPATH="${S}/src" "${python}" -c "import mdp;mdp.test()" || die "tests failed"
+}
+