aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-cpp/growler-arch/ChangeLog6
-rw-r--r--dev-cpp/growler-arch/Manifest1
-rw-r--r--dev-cpp/growler-arch/growler-arch-0.3.7.1.ebuild32
-rw-r--r--dev-cpp/growler-arch/growler-arch-0.3.7.ebuild35
-rw-r--r--dev-cpp/growler-arch/metadata.xml10
5 files changed, 24 insertions, 60 deletions
diff --git a/dev-cpp/growler-arch/ChangeLog b/dev-cpp/growler-arch/ChangeLog
index abc7f3a00..b84f714bb 100644
--- a/dev-cpp/growler-arch/ChangeLog
+++ b/dev-cpp/growler-arch/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-cpp/growler-arch
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 01 Nov 2014; Justin Lecher <jlec@gentoo.org> -growler-arch-0.3.7.ebuild,
+ growler-arch-0.3.7.1.ebuild, metadata.xml:
+ Bump to EAPI=5
+
23 Jun 2010; Andreas K. Huettel (dilfridge) <mail@akhuettel.de>
growler-arch-0.3.7.ebuild, growler-arch-0.3.7.1.ebuild:
QA fixes
diff --git a/dev-cpp/growler-arch/Manifest b/dev-cpp/growler-arch/Manifest
index 1fc37cebf..01a0ed225 100644
--- a/dev-cpp/growler-arch/Manifest
+++ b/dev-cpp/growler-arch/Manifest
@@ -1,2 +1 @@
DIST growler-arch-0.3.7.1.tar.gz 500709 SHA256 36b53a1ac6eb4602c4a20b430c9f81db3e6ed442d7df1ea35f636367eb29f634
-DIST growler-arch-0.3.7.tar.gz 504380 SHA256 2b6804b32b32c7cd73b68fcd399139faf58522e68ed11cf91340f4a4152537e4
diff --git a/dev-cpp/growler-arch/growler-arch-0.3.7.1.ebuild b/dev-cpp/growler-arch/growler-arch-0.3.7.1.ebuild
index abd62f28a..2cedc63ff 100644
--- a/dev-cpp/growler-arch/growler-arch-0.3.7.1.ebuild
+++ b/dev-cpp/growler-arch/growler-arch-0.3.7.1.ebuild
@@ -2,34 +2,30 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-SLOT="0"
-LICENSE="NOSA"
+EAPI=5
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Growler-Arch are growler libraries and utilities."
+DESCRIPTION="Growler libraries and utilities"
HOMEPAGE="http://www.nas.nasa.gov/~bgreen/growler/"
SRC_URI="${HOMEPAGE}/downloads/growler-arch-${PV}.tar.gz"
+SLOT="0"
+LICENSE="NOSA"
+KEYWORDS="~amd64 ~x86"
IUSE="doc static"
-RDEPEND=">=dev-cpp/growler-link-0.3.7
- >=dev-cpp/growler-thread-0.3.4
- >=dev-cpp/growler-core-0.3.7"
+RDEPEND="
+ >=dev-cpp/growler-link-0.3.7
+ >=dev-cpp/growler-thread-0.3.4
+ >=dev-cpp/growler-core-0.3.7"
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen dev-libs/libxslt )"
+ doc? ( app-doc/doxygen dev-libs/libxslt )"
+
+DOCS=( README NEWS AUTHORS NOSA ChangeLog )
-src_compile() {
+src_configure() {
econf \
$(use_enable doc) \
$(use_enable static) \
- --enable-fast-install \
- || die "could not configure"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc README NEWS AUTHORS NOSA ChangeLog
+ --enable-fast-install
}
diff --git a/dev-cpp/growler-arch/growler-arch-0.3.7.ebuild b/dev-cpp/growler-arch/growler-arch-0.3.7.ebuild
deleted file mode 100644
index 581f40df0..000000000
--- a/dev-cpp/growler-arch/growler-arch-0.3.7.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-SLOT="0"
-LICENSE="NOSA"
-
-KEYWORDS="~amd64 ~x86"
-
-DESCRIPTION="Growler-Arch is growler libraries and utilities."
-HOMEPAGE="http://www.nas.nasa.gov/~bgreen/growler/"
-SRC_URI="${HOMEPAGE}/downloads/growler-arch-${PV}.tar.gz"
-
-IUSE="doc static"
-
-RDEPEND=">=dev-cpp/growler-link-0.3.7
- >=dev-cpp/growler-thread-0.3.4
- >=dev-cpp/growler-core-0.3.7"
-
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen dev-libs/libxslt )"
-
-src_compile() {
- econf \
- $(use_enable doc) \
- $(use_enable static) \
- --enable-fast-install \
- || die "could not configure"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc README NEWS AUTHORS NOSA ChangeLog
-}
diff --git a/dev-cpp/growler-arch/metadata.xml b/dev-cpp/growler-arch/metadata.xml
index 598ac7265..d212cf746 100644
--- a/dev-cpp/growler-arch/metadata.xml
+++ b/dev-cpp/growler-arch/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>bryan.d.green@nasa.gov</email>
- <name>Bryan Green</name>
- </maintainer>
- <longdescription>Growler-Arch is the set growler libraries and utilities that provide a distributed object architecture and environment.</longdescription>
+ <maintainer>
+ <email>bryan.d.green@nasa.gov</email>
+ <name>Bryan Green</name>
+ </maintainer>
+ <longdescription>Growler-Arch is the set growler libraries and utilities that provide a distributed object architecture and environment.</longdescription>
</pkgmetadata>