aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/pybids/Manifest1
-rw-r--r--sci-libs/pybids/pybids-0.10.2.ebuild (renamed from sci-libs/pybids/pybids-9999.ebuild)26
2 files changed, 15 insertions, 12 deletions
diff --git a/sci-libs/pybids/Manifest b/sci-libs/pybids/Manifest
index def9e08d0..80c5fc58b 100644
--- a/sci-libs/pybids/Manifest
+++ b/sci-libs/pybids/Manifest
@@ -1,2 +1,3 @@
+DIST pybids-0.10.2.tar.gz 3013780 BLAKE2B 6c61b3e1750f056c1007e2ee1769b86ffac606dc4df6bf09edc249cec24749738bd9474edc997941407133c65728f453d25b0afa54170fce5dd78c4ed90bdaf9 SHA512 a09005410fdc0d8d17b3bfbd5d0ee60f029575bc4499866be2bb29a04d23c1e85359d63ed19abe14615617a9e05714a40103e27d1a1e3f724232d1e1f2c3b874
DIST pybids-0.5.0.tar.gz 2814050 BLAKE2B b4bd548989d09e6f49d94c9262fb225a25a37bd5797fe33d2296943808a8dbebeaf17b81e4ea0513c620bcf4c4b4cbae394123fabe7244363205c73328f00e8b SHA512 7d39198fa321535a2f1761348069c18e7ba113174b8d034dd20e5ea3ac11013840da89b5b7bbe6d9b0458c46a5bc07200a97c5efa1a6ff716c524390bd0a3a65
DIST pybids-0.6.5.tar.gz 2915557 BLAKE2B d7765b872917bbffcd2706488d7c789976be5bbb1eb5d112cb0b7bcedb483236643f8bf7c177f4a64a44a4d50787a4df1d39fbec8e826bfffd2e2e6f891b3ef3 SHA512 9eef42f00440dddf0147d91f90e07db81f9f95a650f0e47c04304771173ca8691cdb366bd0df1d752c0444f102a4aa010c2343ba75df96528cceb9a98f9d8a0e
diff --git a/sci-libs/pybids/pybids-9999.ebuild b/sci-libs/pybids/pybids-0.10.2.ebuild
index 5d2e6eff9..8b30eeb0d 100644
--- a/sci-libs/pybids/pybids-9999.ebuild
+++ b/sci-libs/pybids/pybids-0.10.2.ebuild
@@ -3,35 +3,37 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+PYTHON_COMPAT=( python3_{6,7} )
-inherit distutils-r1 git-r3
+inherit distutils-r1
DESCRIPTION="Python package to access BIDS datasets"
HOMEPAGE="https://github.com/INCF/pybids"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/INCF/pybids"
+SRC_URI="https://github.com/INCF/pybids/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
+KEYWORDS="~amd64"
IUSE="test"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
- "
+DEPEND=""
RDEPEND="
- dev-python/grabbit[${PYTHON_USEDEP}]
dev-python/num2words[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
dev-python/patsy[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ sci-libs/bids-validator[${PYTHON_USEDEP}]
sci-libs/nibabel[${PYTHON_USEDEP}]
sci-libs/scipy[${PYTHON_USEDEP}]
"
+#RESTRICT="test"
+# Fails because fixtures are called directly
+# https://github.com/bids-standard/pybids/issues/289#issuecomment-476853673
+
python_test() {
- py.test -v || die
+ #rm bids/tests/test_config.py || die
+ distutils_install_for_testing
+ pytest -vv || die
}