aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-astronomy/swarp/Manifest1
-rw-r--r--sci-astronomy/swarp/swarp-2.38.0.ebuild41
-rw-r--r--sci-astronomy/swarp/swarp-9999.ebuild34
3 files changed, 15 insertions, 61 deletions
diff --git a/sci-astronomy/swarp/Manifest b/sci-astronomy/swarp/Manifest
deleted file mode 100644
index 48df37c5e..000000000
--- a/sci-astronomy/swarp/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST swarp-2.38.0.tar.gz 2063462 SHA256 f54a637f6c17ef2d94f767da641afea9bec726c31501cb828d9b948b1507c7c4 SHA512 80f4ade59738df3d4c9b47bda04148b53c6ba995d523fa8d1e02fb5d952b6078a53cc7d273849a033505de127a4f318b95adf2bf5a2dc38e8cc9bdaf5658487a WHIRLPOOL e328be5011ac0a89858ce7420d57715f2a178012b81f649953f63bbac6ae5a75c86905c01f58c4bc0a2149b41291e3092e40dbfd302667a1fcb7b2aa9688ac40
diff --git a/sci-astronomy/swarp/swarp-2.38.0.ebuild b/sci-astronomy/swarp/swarp-2.38.0.ebuild
deleted file mode 100644
index 71c254dee..000000000
--- a/sci-astronomy/swarp/swarp-2.38.0.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-if [[ ${PV} == "9999" ]] ; then
- inherit subversion
- ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
- SRC_URI=""
- KEYWORDS=""
- AUTOTOOLS_AUTORECONF=1
-else
- SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-inherit autotools-utils
-
-DESCRIPTION="Resample and coadd astronomical FITS images"
-HOMEPAGE="http://astromatic.iap.fr/software/swarp"
-
-LICENSE="GPL-3"
-SLOT="0"
-
-IUSE="doc threads"
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
-src_configure() {
- local myeconfargs=( $(use_enable threads) )
- autotools-utils_src_configure
-}
-
-src_install () {
- autotools-utils_src_install
- use doc && dodoc doc/*
-}
diff --git a/sci-astronomy/swarp/swarp-9999.ebuild b/sci-astronomy/swarp/swarp-9999.ebuild
index 71c254dee..0ba8a64bd 100644
--- a/sci-astronomy/swarp/swarp-9999.ebuild
+++ b/sci-astronomy/swarp/swarp-9999.ebuild
@@ -1,26 +1,18 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-if [[ ${PV} == "9999" ]] ; then
- inherit subversion
- ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
- SRC_URI=""
- KEYWORDS=""
- AUTOTOOLS_AUTORECONF=1
-else
- SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
+inherit subversion
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
-inherit autotools-utils
+ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ESVN_OPTIONS="--trust-server-cert-failures=unknown-ca"
+SRC_URI=""
+KEYWORDS=""
DESCRIPTION="Resample and coadd astronomical FITS images"
-HOMEPAGE="http://astromatic.iap.fr/software/swarp"
+HOMEPAGE="http://www.astromatic.net/software/swarp"
LICENSE="GPL-3"
SLOT="0"
@@ -30,12 +22,16 @@ IUSE="doc threads"
RDEPEND=""
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+ subversion_src_prepare
+}
+
src_configure() {
- local myeconfargs=( $(use_enable threads) )
- autotools-utils_src_configure
+ econf $(use_enable threads)
}
src_install () {
- autotools-utils_src_install
+ default
use doc && dodoc doc/*
}