aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/zarith/Manifest1
-rw-r--r--dev-ml/zarith/metadata.xml18
-rw-r--r--dev-ml/zarith/zarith-1.2.1.ebuild54
3 files changed, 0 insertions, 73 deletions
diff --git a/dev-ml/zarith/Manifest b/dev-ml/zarith/Manifest
deleted file mode 100644
index d7156cb11..000000000
--- a/dev-ml/zarith/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST zarith-1.2.1.tgz 68654 SHA256 916801cc39599d3fca07384fbfeec4bfaa5ffcb497d68ef89320af40ba5e4144 SHA512 5c053e259469bf6a2d4aaa3e653da42d18015e815a0b922a4e317db091a54c560e7ed32f5cb1faae7df1e8a6d81ba3913d71e5b500ace1bd45d69e69858467a1 WHIRLPOOL e31770c23e7f77bff8f084eeb3e0a9cab7c1413f2da64926c403720df2351bb84598953ad1bae0436d9b3ba6e66c1543aee0dbd9151a3708d793abe5506f1e00
diff --git a/dev-ml/zarith/metadata.xml b/dev-ml/zarith/metadata.xml
deleted file mode 100644
index e8c58a4aa..000000000
--- a/dev-ml/zarith/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-mathematics@gentoo.org</email>
- <name>Gentoo Mathematics Project</name>
- </maintainer>
- <longdescription>
- The Zarith library implements arithmetic and logical operations over
- arbitrary-precision integers. It uses GMP to efficiently implement
- arithmetic over big integers. Small integers are represented as Caml
- unboxed integers, for speed and space economy.
-</longdescription>
- <use>
- <flag name="mpir">Use <pkg>sci-libs/mpir</pkg> for arbitrary
- precision integer arithmetic</flag>
- </use>
-</pkgmetadata>
diff --git a/dev-ml/zarith/zarith-1.2.1.ebuild b/dev-ml/zarith/zarith-1.2.1.ebuild
deleted file mode 100644
index cd0fa27ec..000000000
--- a/dev-ml/zarith/zarith-1.2.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit eutils findlib multilib
-
-DESCRIPTION="Arithmetic and logical operations over arbitrary-precision integers"
-HOMEPAGE="http://forge.ocamlcore.org/projects/zarith"
-SRC_URI="http://forge.ocamlcore.org/frs/download.php/1199/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+ocamlopt doc mpir"
-
-DEPEND="
- >=dev-lang/ocaml-3.12.1[ocamlopt?]
- !mpir? ( dev-libs/gmp:0 )
- mpir? ( sci-libs/mpir:0 )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- OCAMLDIR=$(ocamlc -where)
-}
-
-src_prepare(){
- default
- sed \
- -e 's:(OCAMLFIND) install:(OCAMLFIND) install -ldconf $(INSTALLDIR)/ld.conf:g' \
- -i "${S}"/project.mak || die
-}
-
-src_configure(){
- MY_OPTS="-ocamllibdir /usr/$(get_libdir) -installdir ${D}/${OCAMLDIR}"
- use mpir && MY_OPTS="${MY_OPTS} -mpir"
- ./configure ${MY_OPTS} || die "configure failed"
-}
-
-src_compile(){
- default
- use doc && emake doc
-}
-
-src_install(){
- findlib_src_preinst
- cp "${OCAMLDIR}"/ld.conf "${D}/${OCAMLDIR}"/ld.conf || die
- default
- rm -f "${D}/${OCAMLDIR}"/ld.conf || die
- DOCS=( Changes README )
- use doc && HTML_DOCS=( html/. )
- einstalldocs
-}