aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-astronomy/skymaker/ChangeLog8
-rw-r--r--sci-astronomy/skymaker/Manifest2
-rw-r--r--sci-astronomy/skymaker/metadata.xml10
-rw-r--r--sci-astronomy/skymaker/skymaker-3.3.3.ebuild11
-rw-r--r--sci-astronomy/skymaker/skymaker-9999.ebuild36
5 files changed, 52 insertions, 15 deletions
diff --git a/sci-astronomy/skymaker/ChangeLog b/sci-astronomy/skymaker/ChangeLog
index 9ffd58d4e..54eb51c1c 100644
--- a/sci-astronomy/skymaker/ChangeLog
+++ b/sci-astronomy/skymaker/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for sci-astronomy/skymaker
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+*skymaker-9999 (04 Jul 2012)
+
+ 04 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> skymaker-3.3.3.ebuild,
+ +skymaker-9999.ebuild, metadata.xml:
+ Live version. Prefix love
+
04 Aug 2011; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml:
Switched herd to sci-astronomy
diff --git a/sci-astronomy/skymaker/Manifest b/sci-astronomy/skymaker/Manifest
index 8815cd30f..48564d6a5 100644
--- a/sci-astronomy/skymaker/Manifest
+++ b/sci-astronomy/skymaker/Manifest
@@ -1 +1 @@
-DIST skymaker-3.3.3.tar.gz 415740 RMD160 8f9809a1fcf6659a6d76b6d8f6cc1a9154306262 SHA1 781e4e1955a04bfadb74904243ddfd8f507839d5 SHA256 75ddcfcc577591b3ad430171fa867cc7a573bb93f541fd82ef6ebe873c1816f4
+DIST skymaker-3.3.3.tar.gz 415740 RMD160 8f9809a1fcf6659a6d76b6d8f6cc1a9154306262 SHA1 781e4e1955a04bfadb74904243ddfd8f507839d5 SHA256 75ddcfcc577591b3ad430171fa867cc7a573bb93f541fd82ef6ebe873c1816f4 SHA512 3980275af2ecf1c35057e61f6368b4bb3ee1428fa7fca366bb8bb373efd70351c4b3caac0e930a3f43aad61440844963e2d684f0f31d9d6517842ba0d61bf93b WHIRLPOOL 4496b40ab6ea19da5e3647cf8f985fa9e443795d20e1a5e0361ab95be1b6b484e88a65e93c47457de39edbab866e72bdba2c4fc919597072741ec0475444a7d7
diff --git a/sci-astronomy/skymaker/metadata.xml b/sci-astronomy/skymaker/metadata.xml
index 6b3fd39d2..914ff5770 100644
--- a/sci-astronomy/skymaker/metadata.xml
+++ b/sci-astronomy/skymaker/metadata.xml
@@ -3,10 +3,10 @@
<pkgmetadata>
<herd>sci-astronomy</herd>
<longdescription lang="en">
-SkyMaker is a program that simulates astronomical images. It accepts
-object lists in ASCII generated by the Stuff program to produce
-realistic astronomical fields. There are various options for the user:
-build a realistic Point Spread Function, generate a list of stars and
-galaxies. Galaxies are modeled analytically.
+ SkyMaker is a program that simulates astronomical images. It accepts
+ object lists in ASCII generated by the Stuff program to produce
+ realistic astronomical fields. There are various options for the user:
+ build a realistic Point Spread Function, generate a list of stars and
+ galaxies. Galaxies are modeled analytically.
</longdescription>
</pkgmetadata>
diff --git a/sci-astronomy/skymaker/skymaker-3.3.3.ebuild b/sci-astronomy/skymaker/skymaker-3.3.3.ebuild
index 99dd48b0d..a45e0c617 100644
--- a/sci-astronomy/skymaker/skymaker-3.3.3.ebuild
+++ b/sci-astronomy/skymaker/skymaker-3.3.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-EAPI=2
+EAPI=4
inherit autotools eutils
DESCRIPTION="Program that simulates astronomical images"
@@ -11,7 +11,7 @@ SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="threads"
DEPEND=">=sci-libs/fftw-3"
@@ -25,8 +25,3 @@ src_prepare() {
src_configure() {
econf $(use_enable threads)
}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog HISTORY README THANKS BUGS
-}
diff --git a/sci-astronomy/skymaker/skymaker-9999.ebuild b/sci-astronomy/skymaker/skymaker-9999.ebuild
new file mode 100644
index 000000000..d4a14b093
--- /dev/null
+++ b/sci-astronomy/skymaker/skymaker-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+if [[ ${PV} == "9999" ]] ; then
+ _SVN=subversion
+ ESVN_REPO_URI="https://astromatic.net/pubsvn/software/${PN}/trunk"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+inherit ${_SVN} autotools
+
+DESCRIPTION="Program that simulates astronomical images"
+HOMEPAGE="http://www.astromatic.net/software/skymaker"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc threads plplot"
+
+RDEPEND="sci-libs/fftw:3.0"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable threads)
+}