aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/abyss/Manifest1
-rw-r--r--sci-biology/abyss/abyss-2.1.1.ebuild54
-rw-r--r--sci-biology/abyss/metadata.xml18
3 files changed, 73 insertions, 0 deletions
diff --git a/sci-biology/abyss/Manifest b/sci-biology/abyss/Manifest
new file mode 100644
index 000000000..36e00a689
--- /dev/null
+++ b/sci-biology/abyss/Manifest
@@ -0,0 +1 @@
+DIST abyss-2.1.1.tar.gz 1055710 BLAKE2B 05f339b27624c0f537f129d72105ffe9bb420762a05270221055d77c34cdaa73bc99ecf29dd7d2c7a775c91ba4a5bbd8ca7a91c2ba4dedcc51957bf1b44951a3 SHA512 0bd58889123e3e016b127cd7c0b60e268195d368acd0ad816ce28d3cf888d4322b3cd95f3978746cca79206dd4cf6d8208eb99fab2ac0d3a248e3c7c91d4c020
diff --git a/sci-biology/abyss/abyss-2.1.1.ebuild b/sci-biology/abyss/abyss-2.1.1.ebuild
new file mode 100644
index 000000000..ccce937c7
--- /dev/null
+++ b/sci-biology/abyss/abyss-2.1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
+HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
+SRC_URI="https://github.com/bcgsc/abyss/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="abyss"
+SLOT="0"
+IUSE="+mpi openmp misc-haskell"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-cpp/sparsehash
+ dev-libs/boost:=
+ misc-haskell? (
+ dev-libs/gmp:0=
+ virtual/libffi:0=
+ )
+ mpi? ( sys-cluster/openmpi )"
+DEPEND="${RDEPEND}
+ misc-haskell? (
+ dev-lang/ghc
+ )"
+
+# todo: --enable-maxk=N configure option
+# todo: fix automagic mpi toggling
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/-Werror//" configure.ac || die #365195
+ sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ # disable building haskell tool Misc/samtobreak
+ # unless request by user: bug #534412
+ use misc-haskell || export ac_cv_prog_ac_ct_GHC=
+
+ econf $(use_enable openmp)
+}
diff --git a/sci-biology/abyss/metadata.xml b/sci-biology/abyss/metadata.xml
new file mode 100644
index 000000000..47116e507
--- /dev/null
+++ b/sci-biology/abyss/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci-biology@gentoo.org</email>
+ <name>Gentoo Biology Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="misc-haskell">build abyss-samtobreak tool, pull in haskell toolchain</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">bcgsc/abyss</remote-id>
+ </upstream>
+</pkgmetadata>