aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/fslpy/files/fslpy-2.7.0-coverage.patch16
-rw-r--r--dev-python/fslpy/fslpy-2.7.0.ebuild7
2 files changed, 20 insertions, 3 deletions
diff --git a/dev-python/fslpy/files/fslpy-2.7.0-coverage.patch b/dev-python/fslpy/files/fslpy-2.7.0-coverage.patch
new file mode 100644
index 000000000..3de6d92f1
--- /dev/null
+++ b/dev-python/fslpy/files/fslpy-2.7.0-coverage.patch
@@ -0,0 +1,16 @@
+diff --git a/setup.cfg b/setup.cfg
+index 9ea1ddb..00eb59b 100644
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -18,8 +18,8 @@ markers =
+
+
+ testpaths = tests
+-addopts = -v --niters=50 --cov=fsl -m "not longtest"
++addopts = -v --niters=50 -m "not longtest"
+
+
+ [flake8]
+-ignore = E127,E201,E203,E221,E222,E241,E271,E272,E301,E302,E303,E701,W504
+\ No newline at end of file
++ignore = E127,E201,E203,E221,E222,E241,E271,E272,E301,E302,E303,E701,W504
diff --git a/dev-python/fslpy/fslpy-2.7.0.ebuild b/dev-python/fslpy/fslpy-2.7.0.ebuild
index 211ae6087..bb7a5032b 100644
--- a/dev-python/fslpy/fslpy-2.7.0.ebuild
+++ b/dev-python/fslpy/fslpy-2.7.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1 virtualx
@@ -19,7 +19,6 @@ IUSE="test"
DEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
)
dev-python/setuptools[${PYTHON_USEDEP}]
"
@@ -36,6 +35,8 @@ RDEPEND="
sci-libs/scipy[${PYTHON_USEDEP}]
"
+PATCHES=( "${FILESDIR}/fslpy-2.7.0-coverage.patch" )
+
python_test() {
virtx pytest -m "not (dicomtest or fsltest)" --verbose || die
}