aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-misc/salome-component/ChangeLog4
-rw-r--r--sci-misc/salome-component/Manifest14
-rw-r--r--sci-misc/salome-component/salome-component-5.1.3.ebuild7
3 files changed, 20 insertions, 5 deletions
diff --git a/sci-misc/salome-component/ChangeLog b/sci-misc/salome-component/ChangeLog
index e105d6c40..7874875db 100644
--- a/sci-misc/salome-component/ChangeLog
+++ b/sci-misc/salome-component/ChangeLog
@@ -1,6 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 29 Jun 2010; Justin Lecher <jlec@gentoo.org>
+ salome-component-5.1.3.ebuild:
+ Python ABI fixes
+
04 Apr 2010; Etienne Lorriaux <etienne.lorriaux@gmail.com>
salome-component-5.1.3.ebuild:
changed fetch URL + cleaning
diff --git a/sci-misc/salome-component/Manifest b/sci-misc/salome-component/Manifest
index 503b5e9fb..b37d81adb 100644
--- a/sci-misc/salome-component/Manifest
+++ b/sci-misc/salome-component/Manifest
@@ -1,5 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
AUX salome-component-5.1.3-mpi.patch 718 RMD160 4cfed4cf318686774a49fb037c31dc1ff24be94c SHA1 bd2d3ce92ccb57a81033f8639e8624874b529614 SHA256 9b9b85eaf19409927055fa31899aedd765ea1da05bfe5e8d58a8c8fde792345a
DIST src5.1.3.tar.gz 106470135 RMD160 f46ac847ab57c76df524ddf358b887662fc862cf SHA1 643c775f90277314983747e002918ee5b826db90 SHA256 78ce2acc9cfa474e030723674f4420c420fd2de926b1939455c3716f1fd48a2b
-EBUILD salome-component-5.1.3.ebuild 2991 RMD160 ca1756c309312d4dbca0b1f7a15c731032b151d3 SHA1 a5c6313d4e97bc2749d377ae1028bede7354f483 SHA256 16f22b182a4b7a9ab12162c3f7f1d92bf5ec609c589d07ffeb547454999bae8c
-MISC ChangeLog 1578 RMD160 f8f1d7199da6997c379b2bcaa32b8c9c31b7f932 SHA1 9a7ffbf5f1727510110e12ec7f834173030075ab SHA256 e331022430b2b449271d6662ebb654318c9df4aa91441883113a57abca747a5d
+EBUILD salome-component-5.1.3.ebuild 3011 RMD160 a5cd0a3f79608b6a9f1a0f0a34f1d31f87c8bc71 SHA1 5be8ebc5ef91d4a4d0601258e480cded6f93af83 SHA256 cfeb2db3f77c4cf2b29e0df0f768983e65e06bee8f9268f666d23a33b7147575
+MISC ChangeLog 1678 RMD160 bb1ab204919036ddb58f0417384ac993cbd7e782 SHA1 d08ed3b2462d4cbd71593906dccaed6102d38f02 SHA256 04ef47f9cc950ac0a424dd5347cb128362097211c95d28c1a90bcee260a3fd63
MISC metadata.xml 157 RMD160 ed43b99e7bf8bbf62cf4e46152138ab42d3a88c5 SHA1 2182a6de0b10959aad51af2990f1a6c69e34dd97 SHA256 750cb9e46ac2b77e1adf73de43c186a8c2d2234a9c6a89d9358d0969dc5cf8ac
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.15 (GNU/Linux)
+
+iEYEARECAAYFAkwqWEYACgkQgAnW8HDreRYlngCeIl0azEUQkcn7QcLRpXklufrO
+hUsAn0eBNZEJSlgeL/9gcm0bXOBneliD
+=HZkA
+-----END PGP SIGNATURE-----
diff --git a/sci-misc/salome-component/salome-component-5.1.3.ebuild b/sci-misc/salome-component/salome-component-5.1.3.ebuild
index a9f3d4ae2..af4f224aa 100644
--- a/sci-misc/salome-component/salome-component-5.1.3.ebuild
+++ b/sci-misc/salome-component/salome-component-5.1.3.ebuild
@@ -3,6 +3,7 @@
# $Header: $
EAPI=2
+
PYTHON_DEPEND="2:2.4"
inherit eutils flag-o-matic python
@@ -16,8 +17,8 @@ KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="debug doc mpi"
-RDEPEND="mpi? ( || ( sys-cluster/openmpi[cxx]
- sys-cluster/mpich2[cxx] ) )
+RDEPEND="mpi? || ( sys-cluster/openmpi[cxx]
+ sys-cluster/mpich2[cxx] )
debug? ( dev-util/cppunit )
>=sci-misc/salome-kernel-${PV}
>=sci-misc/salome-gui-${PV}
@@ -28,7 +29,6 @@ RDEPEND="mpi? ( || ( sys-cluster/openmpi[cxx]
>=x11-libs/qwt-5.2
>=dev-python/PyQt4-4.4.3
>=sci-libs/opencascade-6.3"
-
DEPEND="${RDEPEND}
>=app-doc/doxygen-1.5.6
media-gfx/graphviz
@@ -45,6 +45,7 @@ COMPONENT_ROOT_DIR="/opt/salome-${PV}/${MODULE_NAME}"
pkg_setup() {
[[ $(python_get_version) > 2.4 ]] && \
ewarn "Python 2.4 is highly recommended for Salome..."
+ python_set_active_version 2
}
src_prepare() {