aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-benchmarks/numbench/ChangeLog3
-rw-r--r--app-benchmarks/numbench/numbench-9999.ebuild10
-rw-r--r--sci-libs/trilinos/trilinos-10.10.1.ebuild53
3 files changed, 40 insertions, 26 deletions
diff --git a/app-benchmarks/numbench/ChangeLog b/app-benchmarks/numbench/ChangeLog
index becf4a404..d4ecf81da 100644
--- a/app-benchmarks/numbench/ChangeLog
+++ b/app-benchmarks/numbench/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-benchmarks/numbench
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+
+ 7 Aug 2012; Andrea Arteaga <andyspiros@gmail.com> numbench-9999.ebuild
+ Updated live ebuild.
*numbench-0.2_beta3
diff --git a/app-benchmarks/numbench/numbench-9999.ebuild b/app-benchmarks/numbench/numbench-9999.ebuild
index 1e8517418..ac8095f32 100644
--- a/app-benchmarks/numbench/numbench-9999.ebuild
+++ b/app-benchmarks/numbench/numbench-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -8,7 +8,8 @@ inherit eutils git-2 distutils
DESCRIPTION="Automated benchmarks suite"
HOMEPAGE="http://soc.dev.gentoo.org/~spiros"
-EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/auto-numerical-bench.git"
+#EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/auto-numerical-bench.git"
+EGIT_REPO_URI="git://github.com/andyspiros/numbench.git"
LICENSE="GPL-2"
SLOT="0"
@@ -20,8 +21,7 @@ RDEPEND="!app-admin/eselect-blas
!app-admin/eselect-cblas
!app-admin/eselect-lapack
>=dev-python/matplotlib-1.0.0
- =app-admin/eselect-1.3.1-r1
- app-benchmarks/btl"
+ =app-admin/eselect-1.3.1-r1"
src_install() {
distutils_src_install
@@ -30,7 +30,7 @@ src_install() {
newbin exec.py numbench
insinto /usr/share/numbench/samples
- doins *.in
+ doins samples/*xml
doman doc/numbench.1
}
diff --git a/sci-libs/trilinos/trilinos-10.10.1.ebuild b/sci-libs/trilinos/trilinos-10.10.1.ebuild
index 7b964e432..b2bf5bbc5 100644
--- a/sci-libs/trilinos/trilinos-10.10.1.ebuild
+++ b/sci-libs/trilinos/trilinos-10.10.1.ebuild
@@ -16,7 +16,7 @@ RESTRICT="fetch"
LICENSE="BSD LGPL-2.1"
SLOT="0"
-IUSE="arprec boost cuda hdf5 netcdf qd qt taucs tbb umfpack zlib"
+IUSE="arprec boost cuda hdf5 hwloc netcdf qd qt scotch taucs tbb umfpack zlib"
RDEPEND="virtual/blas
virtual/lapack
@@ -26,9 +26,11 @@ RDEPEND="virtual/blas
boost? ( dev-libs/boost )
cuda? ( >=dev-util/nvidia-cuda-toolkit-3.2 )
hdf5? ( sci-libs/hdf5[mpi] )
+ hwloc? ( sys-apps/hwloc )
netcdf? ( sci-libs/netcdf )
qd? ( sci-libs/qd )
qt? ( >=x11-libs/qt-gui-4.5 )
+ scotch? ( sys-libs/scotch[mpi] )
taucs? ( sci-libs/taucs )
tbb? ( dev-cpp/tbb )
umfpack? ( sci-libs/umfpack )"
@@ -44,21 +46,21 @@ pkg_nofetch() {
}
function trilinos_alternatives {
- alt_dirs=""
- for d in $(pkg-config --libs-only-L $1); do
- alt_dirs="${alt_dirs};${d:2}"
- done
- arg="-D${2}_LIBRARY_DIRS=${alt_dirs:1}"
- mycmakeargs+=(
+ alt_dirs=""
+ for d in $(pkg-config --libs-only-L $1); do
+ alt_dirs="${alt_dirs};${d:2}"
+ done
+ arg="-D${2}_LIBRARY_DIRS=${alt_dirs:1}"
+ mycmakeargs+=(
$arg
)
-
+
alt_libs=""
- for d in $(pkg-config --libs-only-l $1); do
- alt_libs="${alt_libs};${d:2}"
- done
- arg="-D${2}_LIBRARY_NAMES=${alt_libs:1}"
- mycmakeargs+=(
+ for d in $(pkg-config --libs-only-l $1); do
+ alt_libs="${alt_libs};${d:2}"
+ done
+ arg="-D${2}_LIBRARY_NAMES=${alt_libs:1}"
+ mycmakeargs+=(
$arg
)
}
@@ -68,7 +70,7 @@ src_configure() {
mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
-DTrilinos_ENABLE_ALL_PACKAGES=ON
-
+
# Directories (workaround for generating correct Makefiles and CMakefiles)
-DCMAKE_INSTALL_PREFIX="/"
-DTrilinos_INSTALL_INCLUDE_DIR="/usr/include/trilinos"
@@ -78,6 +80,7 @@ src_configure() {
$(cmake-utils_use test Trilinos_ENABLE_TESTS)
# Mandatory dependencies
+ -DTPL_ENABLE_BinUtils=ON
-DTPL_ENABLE_MPI=ON
-DTPL_ENABLE_BLAS=ON
-DTPL_ENABLE_LAPACK=ON
@@ -88,24 +91,32 @@ src_configure() {
# Optional dependencies
$(cmake-utils_use arprec TPL_ENABLE_ARPREC)
$(cmake-utils_use boost TPL_ENABLE_Boost)
+ $(cmake-utils_use boost TPL_ENABLE_BoostLib)
$(cmake-utils_use cuda TPL_ENABLE_CUDA)
$(cmake-utils_use hdf5 TPL_ENABLE_HDF5)
+ $(cmake-utils_use hwloc TPL_ENABLE_HWLOC)
$(cmake-utils_use netcdf TPL_ENABLE_Netcdf)
$(cmake-utils_use qd TPL_ENABLE_QD)
$(cmake-utils_use qt TPL_ENABLE_QT)
+ $(cmake-utils_use scotch TPL_ENABLE_Scotch)
$(cmake-utils_use taucs TPL_ENABLE_TAUCS)
$(cmake-utils_use tbb TPL_ENABLE_TBB)
$(cmake-utils_use umfpack TPL_ENABLE_UMFPACK)
$(cmake-utils_use zlib TPL_ENABLE_Zlib)
)
- # Add BLAS libraries
- trilinos_alternatives blas BLAS
- trilinos_alternatives lapack LAPACK
- trilinos_alternatives scalapack SCALAPACK
- trilinos_alternatives scalapack BLACS
-
- mycmakeargs+=( -DBLACS_INCLUDE_DIRS="/usr/include/blacs" )
+ # Scotch libraries
+ if use scotch; then
+ mycmakeargs+=( -DScotch_INCLUDE_DIRS="/usr/include/scotch" )
+ fi
+
+ # Add BLAS libraries
+ trilinos_alternatives blas BLAS
+ trilinos_alternatives lapack LAPACK
+ trilinos_alternatives scalapack SCALAPACK
+ trilinos_alternatives scalapack BLACS
+
+ mycmakeargs+=( -DBLACS_INCLUDE_DIRS="/usr/include/blacs" )
cmake-utils_src_configure
}