aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-physics/elk/Manifest2
-rw-r--r--sci-physics/elk/elk-1.4.22.ebuild110
-rw-r--r--sci-physics/elk/elk-2.1.25.ebuild136
-rw-r--r--sci-physics/elk/metadata.xml25
4 files changed, 0 insertions, 273 deletions
diff --git a/sci-physics/elk/Manifest b/sci-physics/elk/Manifest
deleted file mode 100644
index adb5a0410..000000000
--- a/sci-physics/elk/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST elk-1.4.22.tgz 1866287 BLAKE2B 34e11f23823a274154732f11cb8b2891f68b1ac15cc2179e4e6d471983382ac1a3fbf5e3b891be8eba26031302957ef276dc90fb213ad04e320613373e4e2b86 SHA512 7c512ac6738d883fe1c76964c8bd44ef34269f58f4c8d97ee63949949391ef1040dc41cf0c2626492f6c94649b696d7b67eef8292011dc75c312a3c4b3c21da6
-DIST elk-2.1.25.tgz 1932025 BLAKE2B 8fb20518eba4b64be7bd4a71e1e9d45eb9cf8d990016ccf7b9c18d72da89bd646f0e16f8e4b904d096883c7e509d528bf7b59998073b84080fd1afd8d15928d0 SHA512 ef121946f992a6de2d05681a08a94a50eeab72d0dc6cc81de82ccd3460020eccd266f5f584e7e52c8c79eb8ad1d29ed8a0decc9fa0ecf9ae07fb54c3235b389c
diff --git a/sci-physics/elk/elk-1.4.22.ebuild b/sci-physics/elk/elk-1.4.22.ebuild
deleted file mode 100644
index daa3d4f53..000000000
--- a/sci-physics/elk/elk-1.4.22.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils flag-o-matic fortran-2 multilib toolchain-funcs
-
-DESCRIPTION="All-electron full-potential linearised augmented-plane wave (FP-LAPW)"
-HOMEPAGE="http://elk.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="-debug lapack libxc mpi openmp perl test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- lapack? (
- virtual/blas
- virtual/lapack )
- libxc? ( >=sci-libs/libxc-1.2.0-r1[fortran] )
- mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- perl? ( dev-lang/perl )
- virtual/pkgconfig"
-
-DOCS=( README )
-
-FORTRAN_STANDARD=90
-
-pkg_setup() {
- # fortran-2.eclass does not handle mpi wrappers
- if use mpi; then
- export FC="mpif90"
- export F77="mpif77"
- export CC="mpicc"
- export CXX="mpic++"
- else
- tc-export FC F77 CC CXX
- fi
-
- use openmp && FORTRAN_NEED_OPENMP=1
-
- fortran-2_pkg_setup
-
- use openmp && append-flags -fopenmp
-}
-
-src_prepare() {
- rm -rf src/{BLAS,LAPACK} || die
- if use libxc; then
- sed -i -e's/^\(SRC_libxc =\)/#\1/' "${S}/src/Makefile" || die
- fi
- if use mpi; then
- sed -i -e's/^\(SRC_mpi =\)/#\1/' "${S}/src/Makefile" || die
- fi
-
- sed \
- -e "s: -o : ${LDFLAGS} -o :g" \
- -i src/{,eos,spacegroup}/Makefile || die
-}
-
-src_configure() {
- append-fflags -I/usr/include -I/usr/$(get_libdir)/finclude
-
- cat > make.inc <<- EOF
- MAKE = make
- F90 = $(tc-getFC)
- F90_OPTS = ${FCFLAGS}
- F77 = $(tc-getF77)
- F77_OPTS = ${FFLAGS}
- CC = $(tc-getCC)
- CXX = $(tc-getCXX)
- CFLAGS = ${CFLAGS}
- CXXFLAGS = ${CXXFLAGS}
- LD = $(tc-getLD)
- AR = $(tc-getAR)
- LIB_SYS =
- LIB_LPK = $($(tc-getPKG_CONFIG) --libs lapack)
- LIB_FFT = fftlib.a
- EOF
-
- if use libxc; then
- echo "LIB_XC = -L/usr/$(get_libdir) -lxc" >> make.inc
- echo "SRC_libxc = libxc_funcs.f90 libxc.f90 libxcifc.f90" >>make.inc
- fi
-}
-
-MAKEOPTS+=" -j1"
-
-src_compile() {
- emake -C src fft
- emake -C src elk
- emake -C src/eos
- emake -C src/spacegroup
-}
-
-src_install() {
- dobin src/elk src/protex src/eos/eos src/spacegroup/spacegroup
- dobin utilities/elk-bands
- use perl && dobin utilities/xps_exc.pl utilities/se.pl
- dodoc README
- for doc in docs/*; do
- dodoc $doc
- done
- insinto /usr/share/${P}
- doins -r species utilities examples tests
-}
diff --git a/sci-physics/elk/elk-2.1.25.ebuild b/sci-physics/elk/elk-2.1.25.ebuild
deleted file mode 100644
index cef46a976..000000000
--- a/sci-physics/elk/elk-2.1.25.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils flag-o-matic fortran-2 multilib toolchain-funcs python-single-r1
-
-DESCRIPTION="All-electron full-potential linearised augmented-plane wave (FP-LAPW)"
-HOMEPAGE="http://elk.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="-debug lapack libxc mpi openmp perl python test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- lapack? (
- virtual/blas
- virtual/lapack )
- libxc? ( >=sci-libs/libxc-1.2.0-r1[fortran] )
- perl? ( dev-lang/perl )
- python? ( ${PYTHON_DEPS} )
- mpi? ( virtual/mpi )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-DOCS=( README )
-
-FORTRAN_STANDARD=90
-
-pkg_setup() {
- # fortran-2.eclass does not handle mpi wrappers
- if use mpi; then
- export FC="mpif90"
- export F77="mpif77"
- export CC="mpicc"
- export CXX="mpic++"
- else
- tc-export FC F77 CC CXX
- fi
-
- use openmp && FORTRAN_NEED_OPENMP=1
-
- fortran-2_pkg_setup
-
- if use openmp; then
- # based on _fortran-has-openmp() of fortran-2.eclass
- local openmp=""
- local fcode=ebuild-openmp-flags.f
- local _fc=$(tc-getFC)
-
- pushd "${T}"
- cat <<- EOF > "${fcode}"
- 1 call omp_get_num_threads
- 2 end
- EOF
-
- for openmp in -fopenmp -xopenmp -openmp -mp -omp -qsmp=omp; do
- "${_fc}" "${openmp}" "${fcode}" -o "${fcode}.x" && break
- done
-
- rm -f "${fcode}.*"
- popd
-
- append-flags "${openmp}"
- fi
-}
-
-src_prepare() {
- rm -rf src/{BLAS,LAPACK} || die
- if use libxc; then
- sed -i -e's/^\(SRC_libxc =\)/#\1/' "${S}/src/Makefile" || die
- fi
- if use mpi; then
- sed -i -e's/^\(SRC_mpi =\)/#\1/' "${S}/src/Makefile" || die
- fi
-
- sed \
- -e "s: -o : ${LDFLAGS} -o :g" \
- -i src/{,eos,spacegroup}/Makefile || die
-}
-
-src_configure() {
- append-fflags -I/usr/include
-
- cat > make.inc <<- EOF
- MAKE = make
- F90 = $(tc-getFC)
- F90_OPTS = ${FCFLAGS}
- F77 = $(tc-getF77)
- F77_OPTS = ${FFLAGS}
- CC = $(tc-getCC)
- CXX = $(tc-getCXX)
- CFLAGS = ${CFLAGS}
- CXXFLAGS = ${CXXFLAGS}
- LD = $(tc-getLD)
- AR = $(tc-getAR)
- LIB_SYS =
- LIB_LPK = $($(tc-getPKG_CONFIG) --libs lapack)
- LIB_FFT = fftlib.a
- EOF
-
- if use libxc; then
- echo "LIB_XC = -L/usr/$(get_libdir) -lxc" >> make.inc
- echo "SRC_libxc = libxc_funcs.f90 libxc.f90 libxcifc.f90" >>make.inc
- fi
-}
-
-MAKEOPTS+=" -j1"
-
-src_compile() {
- emake -C src fft
- emake -C src elk
- emake -C src/eos
- emake -C src/spacegroup
-}
-
-src_install() {
- dobin src/elk src/protex src/eos/eos src/spacegroup/spacegroup
- dobin utilities/elk-bands/elk-bands
- use perl && dobin utilities/xps/xps_exc.pl utilities/wien2k-elk/se.pl
- use python && dobin utilities/blocks2columns/blocks2columns.py
- dodoc README
- for doc in docs/*; do
- dodoc $doc
- done
- insinto /usr/share/${P}
- doins -r species utilities examples tests
-}
diff --git a/sci-physics/elk/metadata.xml b/sci-physics/elk/metadata.xml
deleted file mode 100644
index d00045595..000000000
--- a/sci-physics/elk/metadata.xml
+++ /dev/null
@@ -1,25 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>sci-physics@gentoo.org</email>
- <name>Gentoo Physics Project</name>
- </maintainer>
- <longdescription lang="en">
-Elk is an all-electron full-potential linearised augmented-plane wave (FP-LAPW) code with many advanced features. Written originally at Karl-Franzens-Universität Graz as a milestone of the EXCITING EU Research and Training Network, the code is designed to be as simple as possible so that new developments in the field of density functional theory (DFT) can be added quickly and reliably. The code is freely available under the GNU General Public License.
-</longdescription>
- <use>
- <flag name="libxc">
-Use sci-libs/libxc library of exchange-correlation functionals by ETSF.
-</flag>
- <flag name="perl">
-Install perl scripts.
-</flag>
- <flag name="python">
-Install python scripts.
-</flag>
- </use>
- <upstream>
- <remote-id type="sourceforge">elk</remote-id>
- </upstream>
-</pkgmetadata>