aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/blas-reference/Manifest2
-rw-r--r--sci-libs/blas-reference/blas-reference-20131116-r100.ebuild106
-rw-r--r--sci-libs/blas-reference/blas-reference-20151113-r100.ebuild112
-rw-r--r--sci-libs/blas-reference/blas-reference-99999999.ebuild6
4 files changed, 3 insertions, 223 deletions
diff --git a/sci-libs/blas-reference/Manifest b/sci-libs/blas-reference/Manifest
index 7bb499833..23289c10f 100644
--- a/sci-libs/blas-reference/Manifest
+++ b/sci-libs/blas-reference/Manifest
@@ -1,3 +1 @@
-DIST lapack-3.5.0.tgz 6313139 BLAKE2B c23a35f107cfc5c887491fd148c1c76851a4580c98ad86aff9c391ac3d393c31ba67427ed445fe821c7666418e9fcf19523a3a668f8009337508994cf1a68c04 SHA512 b948a0a0db032bda455ec4f519d4e89e4c29e29cecb5b6258ca61f68faaeeac9fdf4ece5c39ffcd0154c5505facbc392c7d09c8348b1d60bdd2685153ab2543f
-DIST lapack-3.6.0.tgz 6792324 BLAKE2B 438f3376b63b38ef0fe70f6becac847816f3a11c01f5ab237dc0d941792ceb54dbd2f8dc22d56286f5dab3499289ed94e67521ea951a98973c9640abc294ad6c SHA512 bc50441d415ef8896dd7626d77c6104184b996e758704366288089f03d4c99d068e33153b0d13305310886017e5d2e716130f812a95cfcad36ef37fe20417ab8
DIST lapack-3.7.0.tgz 7359812 BLAKE2B 20aa42e22d8c920d1360afe41ceec7b36f6cd5fbe43ca9d7848ef7cc45a64a0314cb1321941c1a7c03654f41e28ec805445882ded0ca0ea07674e70b66cba6b5 SHA512 e4f4c7d0ba8a096eeb813160c6dbcdd535647df6b2ad5beac9181908158956b31d1a9554ec9b9836fd44fe7404c1f377b297cbb20d744f20d70e357fd246c91b
diff --git a/sci-libs/blas-reference/blas-reference-20131116-r100.ebuild b/sci-libs/blas-reference/blas-reference-20131116-r100.ebuild
deleted file mode 100644
index 7927c9503..000000000
--- a/sci-libs/blas-reference/blas-reference-20131116-r100.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-NUMERIC_MODULE_NAME="refblas"
-
-inherit alternatives-2 cmake-utils fortran-2 numeric-int64-multibuild python-any-r1 toolchain-funcs
-
-LPN=lapack
-LPV=3.5.0
-
-DESCRIPTION="Reference implementation of BLAS"
-HOMEPAGE="http://www.netlib.org/lapack/"
-SRC_URI="http://www.netlib.org/${LPN}/${LPN}-${LPV}.tgz"
-
-LICENSE="BSD"
-SLOT="0/${LPV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs test"
-
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- test? ( ${PYTHON_DEPS} )
- virtual/pkgconfig"
-
-S="${WORKDIR}/${LPN}-${LPV}"
-
-src_prepare() {
- # rename library to avoid collision with other blas implementations
- # ${LIBNAME} and ${PROFNAME} are not defined here, they are in single
- # quotes in the following seds. They are later set by defining cmake
- # variables with -DPROFNAME etc in src_configure
- sed -i \
- -e 's:\([^xc]\)blas:\1${LIBNAME}:g' \
- CMakeLists.txt \
- BLAS/SRC/CMakeLists.txt || die
- sed -i \
- -e '/Name: /s:blas:${PROFNAME}:' \
- -e 's:-lblas:-l${LIBNAME}:g' \
- BLAS/blas.pc.in || die
- sed -i \
- -e 's:blas):${LIBNAME}):' \
- BLAS/TESTING/CMakeLists.txt || die
- sed -i \
- -e 's:BINARY_DIR}/blas:BINARY_DIR}/${PROFNAME}:' \
- BLAS/CMakeLists.txt || die
-}
-
-src_configure() {
- blas_configure() {
- local FCFLAGS="${FCFLAGS}"
- append-fflags $($(tc-getPKG_CONFIG) --cflags ${blas_profname})
- append-fflags $(get_abi_CFLAGS)
- append-fflags $(numeric-int64_get_fortran_int64_abi_fflags)
-
- local profname=$(numeric-int64_get_module_name)
- local libname="${profname//-/_}"
-
- local mycmakeargs=(
- -Wno-dev
- -DPROFNAME="${profname}"
- -DLIBNAME="${libname}"
- -DUSE_OPTIMIZED_BLAS=OFF
- -DCMAKE_Fortran_FLAGS="${FCFLAGS}"
- -DLAPACK_PKGCONFIG_FFLAGS="$(numeric-int64_get_fortran_int64_abi_fflags)"
- $(cmake-utils_use_build test TESTING)
- )
- if $(numeric-int64_is_static_build); then
- mycmakeargs+=(
- -DBUILD_SHARED_LIBS=OFF
- -DBUILD_STATIC_LIBS=ON
- )
- else
- mycmakeargs+=(
- -DBUILD_SHARED_LIBS=ON
- -DBUILD_STATIC_LIBS=OFF
- )
- fi
- cmake-utils_src_configure
- }
- numeric-int64-multibuild_foreach_all_abi_variants blas_configure
-}
-
-src_compile() {
- local each target_dirs=( BLAS )
- use test && target_dirs+=( TESTING )
- for each in ${target_dirs[@]}; do
- numeric-int64-multibuild_foreach_all_abi_variants \
- cmake-utils_src_compile -C ${each}
- done
-
-}
-
-src_test() {
- numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_test
-}
-
-src_install() {
- numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_install -C BLAS
- numeric-int64-multibuild_install_alternative blas reference
-}
diff --git a/sci-libs/blas-reference/blas-reference-20151113-r100.ebuild b/sci-libs/blas-reference/blas-reference-20151113-r100.ebuild
deleted file mode 100644
index de7d0e668..000000000
--- a/sci-libs/blas-reference/blas-reference-20151113-r100.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-NUMERIC_MODULE_NAME="refblas"
-
-inherit alternatives-2 cmake-utils eutils fortran-2 numeric-int64-multibuild python-any-r1 toolchain-funcs
-
-LPN=lapack
-LPV=3.6.0
-
-DESCRIPTION="Reference implementation of BLAS"
-HOMEPAGE="http://www.netlib.org/lapack/"
-SRC_URI="http://www.netlib.org/${LPN}/${LPN}-${LPV}.tgz"
-
-LICENSE="BSD"
-SLOT="0/${LPV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs test"
-
-REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- test? ( ${PYTHON_DEPS} )
- virtual/pkgconfig"
-
-S="${WORKDIR}/${LPN}-${LPV}"
-PATCHES=( "${FILESDIR}/lapack-fix-build-system.patch" )
-
-src_prepare() {
- # the lapack(e)/(c)blas build system is somewhat broken
- # with respect to its pkg-config files.
- epatch "${PATCHES[@]}"
-
- # rename library to avoid collision with other blas implementations
- # ${LIBNAME} and ${PROFNAME} are not defined here, they are in single
- # quotes in the following seds. They are later set by defining cmake
- # variables with -DPROFNAME etc in src_configure
- sed -i \
- -e 's:\([^xc]\)blas:\1${LIBNAME}:g' \
- -e '/PROPERTIES/s:blas:${LIBNAME}:g' \
- CMakeLists.txt \
- BLAS/SRC/CMakeLists.txt || die
- sed -i \
- -e '/Name: /s:blas:@PROFNAME@:' \
- -e 's:-lblas:-l@LIBNAME@:g' \
- BLAS/blas.pc.in || die
- sed -i \
- -e 's:blas):${LIBNAME}):' \
- BLAS/TESTING/CMakeLists.txt || die
- sed -i \
- -e 's:BINARY_DIR}/blas:BINARY_DIR}/${PROFNAME}:' \
- BLAS/CMakeLists.txt || die
-}
-
-src_configure() {
- blas_configure() {
- local FCFLAGS="${FCFLAGS}"
- append-fflags $($(tc-getPKG_CONFIG) --cflags ${blas_profname})
- append-fflags $(get_abi_CFLAGS)
- append-fflags $(numeric-int64_get_fortran_int64_abi_fflags)
-
- local profname=$(numeric-int64_get_module_name)
- local libname="${profname//-/_}"
-
- local mycmakeargs=(
- -Wno-dev
- -DPROFNAME="${profname}"
- -DLIBNAME="${libname}"
- -DUSE_OPTIMIZED_BLAS=OFF
- -DCMAKE_Fortran_FLAGS="${FCFLAGS}"
- -DLAPACK_PKGCONFIG_FFLAGS="$(numeric-int64_get_fortran_int64_abi_fflags)"
- $(cmake-utils_use_build test TESTING)
- )
- if $(numeric-int64_is_static_build); then
- mycmakeargs+=(
- -DBUILD_SHARED_LIBS=OFF
- -DBUILD_STATIC_LIBS=ON
- )
- else
- mycmakeargs+=(
- -DBUILD_SHARED_LIBS=ON
- -DBUILD_STATIC_LIBS=OFF
- )
- fi
- cmake-utils_src_configure
- }
- numeric-int64-multibuild_foreach_all_abi_variants blas_configure
-}
-
-src_compile() {
- local each target_dirs=( BLAS )
- use test && target_dirs+=( TESTING )
- for each in ${target_dirs[@]}; do
- numeric-int64-multibuild_foreach_all_abi_variants \
- cmake-utils_src_compile -C ${each}
- done
-
-}
-
-src_test() {
- numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_test
-}
-
-src_install() {
- numeric-int64-multibuild_foreach_all_abi_variants cmake-utils_src_install -C BLAS
- numeric-int64-multibuild_install_alternative blas reference
-}
diff --git a/sci-libs/blas-reference/blas-reference-99999999.ebuild b/sci-libs/blas-reference/blas-reference-99999999.ebuild
index 7ce81635b..12e50de88 100644
--- a/sci-libs/blas-reference/blas-reference-99999999.ebuild
+++ b/sci-libs/blas-reference/blas-reference-99999999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
@@ -10,7 +10,7 @@ NUMERIC_MODULE_NAME="refblas"
inherit alternatives-2 cmake-utils fortran-2 numeric-int64-multibuild python-any-r1 toolchain-funcs subversion
LPN=lapack
-LPV=3.6.0
+LPV=3.8.0
DESCRIPTION="Reference implementation of BLAS"
HOMEPAGE="http://www.netlib.org/lapack/"