aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/psychopy/psychopy-1.75.01.ebuild10
-rw-r--r--sci-biology/psychopy/psychopy-1.77.02.ebuild10
-rw-r--r--sci-biology/psychopy/psychopy-1.78.00.ebuild10
-rw-r--r--sci-biology/psychopy/psychopy-9999.ebuild8
4 files changed, 23 insertions, 15 deletions
diff --git a/sci-biology/psychopy/psychopy-1.75.01.ebuild b/sci-biology/psychopy/psychopy-1.75.01.ebuild
index ceeac91ce..db7ffd360 100644
--- a/sci-biology/psychopy/psychopy-1.75.01.ebuild
+++ b/sci-biology/psychopy/psychopy-1.75.01.ebuild
@@ -28,13 +28,15 @@ RDEPEND="
dev-python/wxpython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
- app-admin/eselect
dev-python/pyglet[${PYTHON_USEDEP}]
- dev-python/pygame[${PYTHON_USEDEP}]"
+ dev-python/pygame[${PYTHON_USEDEP}]
+ "
-DEPEND="app-arch/unzip
+DEPEND="app-admin/eselect
+ app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
+ test? ( ${RDEPEND} )
+ "
RESTRICT="test" # interactive, opens lots of windows
diff --git a/sci-biology/psychopy/psychopy-1.77.02.ebuild b/sci-biology/psychopy/psychopy-1.77.02.ebuild
index ceeac91ce..db7ffd360 100644
--- a/sci-biology/psychopy/psychopy-1.77.02.ebuild
+++ b/sci-biology/psychopy/psychopy-1.77.02.ebuild
@@ -28,13 +28,15 @@ RDEPEND="
dev-python/wxpython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
- app-admin/eselect
dev-python/pyglet[${PYTHON_USEDEP}]
- dev-python/pygame[${PYTHON_USEDEP}]"
+ dev-python/pygame[${PYTHON_USEDEP}]
+ "
-DEPEND="app-arch/unzip
+DEPEND="app-admin/eselect
+ app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
+ test? ( ${RDEPEND} )
+ "
RESTRICT="test" # interactive, opens lots of windows
diff --git a/sci-biology/psychopy/psychopy-1.78.00.ebuild b/sci-biology/psychopy/psychopy-1.78.00.ebuild
index 32e175167..584a533a9 100644
--- a/sci-biology/psychopy/psychopy-1.78.00.ebuild
+++ b/sci-biology/psychopy/psychopy-1.78.00.ebuild
@@ -28,13 +28,15 @@ RDEPEND="
dev-python/wxpython[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
- app-admin/eselect
dev-python/pyglet[${PYTHON_USEDEP}]
- dev-python/pygame[${PYTHON_USEDEP}]"
+ dev-python/pygame[${PYTHON_USEDEP}]
+ "
-DEPEND="app-arch/unzip
+DEPEND="app-admin/eselect
+ app-arch/unzip
dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
+ test? ( ${RDEPEND} )
+ "
RESTRICT="test" # interactive, opens lots of windows
diff --git a/sci-biology/psychopy/psychopy-9999.ebuild b/sci-biology/psychopy/psychopy-9999.ebuild
index 3cb8e831a..512d34757 100644
--- a/sci-biology/psychopy/psychopy-9999.ebuild
+++ b/sci-biology/psychopy/psychopy-9999.ebuild
@@ -16,10 +16,11 @@ LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-admin/eselect
+ "
RDEPEND="${DEPEND}
- app-admin/eselect
virtual/python-imaging[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
@@ -28,7 +29,8 @@ RDEPEND="${DEPEND}
dev-python/pyglet[${PYTHON_USEDEP}]
dev-python/pyopengl[${PYTHON_USEDEP}]
dev-python/wxpython[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]"
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ "
python_install_all() {
distutils-r1_python_install_all