aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-astronomy/ds9/ChangeLog9
-rw-r--r--sci-astronomy/ds9/Manifest5
-rw-r--r--sci-astronomy/ds9/ds9-4.0_beta7.ebuild52
-rw-r--r--sci-astronomy/ds9/files/digest-ds9-4.0_beta71
-rw-r--r--sci-astronomy/ds9/files/ds9-Makefile.patch59
-rw-r--r--sci-astronomy/ds9/metadata.xml12
6 files changed, 138 insertions, 0 deletions
diff --git a/sci-astronomy/ds9/ChangeLog b/sci-astronomy/ds9/ChangeLog
new file mode 100644
index 000000000..acf693d7c
--- /dev/null
+++ b/sci-astronomy/ds9/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sci-astronomy/ds9
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+* ds9-4.0_beta7 (02 Dec 2005)
+
+ O2 Dec 2005; Sebastien Fabbro <seb@ist.utl.pt> +ds9-4.0_beta7.ebuild:
+ Initial import. Close bug #65657 and #78364
+
diff --git a/sci-astronomy/ds9/Manifest b/sci-astronomy/ds9/Manifest
new file mode 100644
index 000000000..468c51515
--- /dev/null
+++ b/sci-astronomy/ds9/Manifest
@@ -0,0 +1,5 @@
+MD5 6c7b03bbb9d402e7ad92d8a1b71e0601 ds9-4.0_beta7.ebuild 1589
+MD5 1a9e880154be5521b9aacc906b1f407a metadata.xml 370
+MD5 4785ef89cd9307e1c7c6489336e9026a ChangeLog 271
+MD5 a8d8c98fa3633546413bd278f3af9ca8 files/digest-ds9-4.0_beta7 63
+MD5 1368902cfd7fbe8a1c52bf34c2829765 files/ds9-Makefile.patch 2040
diff --git a/sci-astronomy/ds9/ds9-4.0_beta7.ebuild b/sci-astronomy/ds9/ds9-4.0_beta7.ebuild
new file mode 100644
index 000000000..9521bbda1
--- /dev/null
+++ b/sci-astronomy/ds9/ds9-4.0_beta7.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit flag-o-matic eutils
+
+MY_PV="4.0b7"
+DESCRIPTION="Astronomical imaging and data visualization application for FITS images"
+HOMEPAGE="http://hea-www.harvard.edu/RD/ds9"
+SRC_URI="http://hea-www.harvard.edu/saord/download/${PN}/source/${PN}.${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc xpa"
+DEPEND=">=sys-devel/gcc-3.4
+ virtual/x11"
+RDEPEND="virtual/x11"
+
+S=${WORKDIR}/sao${PN}
+
+# This is a long and fragile compilation
+# which recompiles tcl/tk, blt, funtools, and who knows what else
+# The make install in src_compile only install and strip the ds9 exec
+# One day scientists will use tools like autotools, cmake, scons
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # The patch is to speed up the compilation
+ # (avoid generating tcl man files for ex.)
+ # and avoid local install bugs with symbolic linking.
+ epatch ${FILESDIR}/${PN}-Makefile.patch
+}
+
+src_compile() {
+ ! is-flag -fPIC && append-flags -fPIC
+ sed -i -e '1i #!/bin/sh' funtools-*/filter/inc.sed
+ use x86 && ln -s make.linux make.include
+ use amd64 && ln -s make.linux64 make.include
+ emake -j1 || die "emake failed"
+ make install || die "make install (local) failed"
+}
+
+src_install () {
+ dobin bin/ds9 || die "dobin ds9 failed"
+ if use xpa; then
+ dobin bin/xpa* || die "dobin xpa failed"
+ doman man/man?/xpa* || die "doman xpa failed"
+ fi
+ dodoc README acknowledgement copyright || die "dodoc failed"
+ use doc && dohtml ds9/doc/* || die "dohtml failed"
+}
diff --git a/sci-astronomy/ds9/files/digest-ds9-4.0_beta7 b/sci-astronomy/ds9/files/digest-ds9-4.0_beta7
new file mode 100644
index 000000000..6202529fa
--- /dev/null
+++ b/sci-astronomy/ds9/files/digest-ds9-4.0_beta7
@@ -0,0 +1 @@
+MD5 86bde2f24ef70cd57c2fd856ccf9dcc1 ds9.4.0b7.tar.gz 22237375
diff --git a/sci-astronomy/ds9/files/ds9-Makefile.patch b/sci-astronomy/ds9/files/ds9-Makefile.patch
new file mode 100644
index 000000000..c5be804bc
--- /dev/null
+++ b/sci-astronomy/ds9/files/ds9-Makefile.patch
@@ -0,0 +1,59 @@
+--- Makefile.old 2005-12-01 23:31:19.000000000 +0000
++++ Makefile 2005-12-01 19:52:04.000000000 +0000
+@@ -141,22 +141,22 @@
+ tclsh : FORCE
+ @echo "Installing Tcl shared..."
+ cd $(TCLDIRDIR); CC=$(CCc) ./configure $(TCLFLAGS) --enable-shared
+- cd $(TCLDIRDIR); $(MAKE) install
++ cd $(TCLDIRDIR); $(MAKE) install-binaries install-libraries
+
+ tcl : FORCE
+ @echo "Installing Tcl noshared..."
+ cd $(TCLDIRDIR); CC=$(CCc) ./configure $(TCLFLAGS) --disable-shared
+- cd $(TCLDIRDIR); $(MAKE) install
++ cd $(TCLDIRDIR); $(MAKE) install-binaries install-libraries
+
+ tksh : FORCE
+ @echo "Installing Tk shared..."
+ cd $(TKDIRDIR); CC=$(CCc) ./configure $(TCLFLAGS) --enable-shared
+- cd $(TKDIRDIR); $(MAKE) install
++ cd $(TKDIRDIR); $(MAKE) install-binaries install-libraries
+
+ tk : FORCE
+ @echo "Installing Tk noshared..."
+ cd $(TKDIRDIR); CC=$(CCc) ./configure $(TCLFLAGS) --disable-shared
+- cd $(TKDIRDIR); $(MAKE) install
++ cd $(TKDIRDIR); $(MAKE) install-binaries install-libraries
+
+ tclxsh : FORCE
+ @echo "Installing TCLX shared..."
+@@ -171,17 +171,17 @@
+ tktablesh : FORCE
+ @echo "Installing TkTable..."
+ cd $(TKTABLEDIR); CC=$(CCc) ./configure $(TCLFLAGS) --enable-shared
+- cd $(TKTABLEDIR); $(MAKE); $(MAKE) install
++ cd $(TKTABLEDIR); $(MAKE); $(MAKE) install-binaries install-libraries
+
+ tktable : FORCE
+ @echo "Installing TkTable..."
+ cd $(TKTABLEDIR); CC=$(CCc) ./configure $(TCLFLAGS) --disable-shared
+- cd $(TKTABLEDIR); $(MAKE); $(MAKE) install
++ cd $(TKTABLEDIR); $(MAKE); $(MAKE) install-binaries install-libraries
+
+ tcllib : FORCE
+ @echo "Installing TCLLIB..."
+ cd $(TCLLIBDIR); ./configure $(TCLLIBFLAGS)
+- cd $(TCLLIBDIR); $(MAKE) install
++ cd $(TCLLIBDIR); $(MAKE) install-libraries
+
+ tkindex : FORCE
+ @echo "Installing Tk mkIndex..."
+@@ -190,7 +190,7 @@
+ blt : FORCE
+ @echo "Installing BLT..."
+ cd $(BLTDIR); ./configure $(BLTFLAGS)
+- cd $(BLTDIR); $(MAKE); $(MAKE) install
++ cd $(BLTDIR); $(MAKE); $(MAKE) -C src install; $(MAKE) -C library install
+
+ mktclapp: FORCE
+ @echo "Installing MKTCLAPP..."
diff --git a/sci-astronomy/ds9/metadata.xml b/sci-astronomy/ds9/metadata.xml
new file mode 100644
index 000000000..58c7d934e
--- /dev/null
+++ b/sci-astronomy/ds9/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>seb@ist.utl.pt</email>
+ <name> Sebastien Fabbro</name>
+</maintainer>
+ <longdescription lang="en">
+ DS9 is a a package to visualize multiple astronomical FITS images.
+ </longdescription>
+</pkgmetadata>