aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/picard/Manifest1
-rw-r--r--sci-biology/picard/picard-1.141.ebuild2
-rw-r--r--sci-biology/picard/picard-2.2.2.ebuild2
-rw-r--r--sci-biology/picard/picard-2.8.1.ebuild59
4 files changed, 62 insertions, 2 deletions
diff --git a/sci-biology/picard/Manifest b/sci-biology/picard/Manifest
index 91a5492dd..0b6c7208b 100644
--- a/sci-biology/picard/Manifest
+++ b/sci-biology/picard/Manifest
@@ -1,2 +1,3 @@
DIST picard-1.141.tar.gz 5692255 SHA256 128e761b4dbedda9a89cceb4d1648be213ec823ff105a35db9c9526955a42320 SHA512 5fed8ff0076ec5f096a5138b95ae07805f8f4d68db33b65f2e21325f49493c50f235519768823c2db981b2e543fbf05f55be7939d75cbd5d257ac84e633b9bf4 WHIRLPOOL 5716cc51da6e94b338aceb5a3d01da5ae048f011e3d3eee72a96144d4b6f80dddf898ea902fae08b127f93c771f521437bd299bdeaf005af6f24c76f9844b63d
DIST picard-2.2.2.tar.gz 6565857 SHA256 1d858fde23aa9938a87cd96e6c2fbbfcdea669c9f30d524c107af26bce3798de SHA512 4ee97443397b45236a2481fa64c80edbd7761d6562cc134d65f1d95fa101ccc82402bbf21ed6b186e15324f2c189737790066e18cd0143bb50768c20ee4b156b WHIRLPOOL 69df60c171a5e531b78ad670b260d717a749012d05028e1afba2484eb3a84a71e61ade13c7298b0e9bc6ff526367ca886d9440b996882d3f19455f8f46e3bd4f
+DIST picard-2.8.1.tar.gz 3851366 SHA256 780d43230f769e312ccc00b0a5bde4f0d8a2020e98e7447887f581550f4cb975 SHA512 897ec512b3bf66c25dd4f1cbb70306cdfd951c9a257f745ae23f7b8bf7125563460f90128b053977c13fa4fb509b5fa4ec6a11d410487fa0c8927b6ab1bd909a WHIRLPOOL 71b1a7c56f465c7afbdc9b8e0143ab2cb0f661edbaa425d07efe264c37cd58adf1f9f7d388e81fbc3a78efe06af5c1c2611feaeaea7bd64bb748709bf515dc43
diff --git a/sci-biology/picard/picard-1.141.ebuild b/sci-biology/picard/picard-1.141.ebuild
index ab65edb40..b84d91dbb 100644
--- a/sci-biology/picard/picard-1.141.ebuild
+++ b/sci-biology/picard/picard-1.141.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/sci-biology/picard/picard-2.2.2.ebuild b/sci-biology/picard/picard-2.2.2.ebuild
index c43b52cac..f0cc489c6 100644
--- a/sci-biology/picard/picard-2.2.2.ebuild
+++ b/sci-biology/picard/picard-2.2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
diff --git a/sci-biology/picard/picard-2.8.1.ebuild b/sci-biology/picard/picard-2.8.1.ebuild
new file mode 100644
index 000000000..4d09e8d48
--- /dev/null
+++ b/sci-biology/picard/picard-2.8.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java-based command-line utilities that manipulate SAM/BAM/CRAM/VCF files"
+HOMEPAGE="http://picard.sourceforge.net
+ http://broadinstitute.github.io/picard"
+SRC_URI="https://github.com/broadinstitute/picard/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS=""
+
+CDEPEND="dev-java/snappy:1.1
+ dev-java/cofoja:0
+ dev-java/commons-jexl:2
+ dev-java/ant-core:0
+ dev-java/htsjdk:0"
+
+DEPEND=">=virtual/jdk-1.8
+ ${CDEPEND}"
+
+RDEPEND=">=virtual/jre-1.8
+ ${CDEPEND}"
+
+EANT_BUILD_TARGET="all"
+EANT_NEEDS_TOOLS="true"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="snappy-1.1,cofoja,commons-jexl-2,ant-core,htsjdk"
+
+java_prepare() {
+ default
+ rm -r src/java/picard/util/TestNGUtil.java src/tests/java/* || die
+ epatch "${FILESDIR}"/${PV}-build.xml.patch
+}
+
+src_compile(){
+ # work around gradle writing $HOME/.gradle and requiring $HOME/.git
+ # https://github.com/samtools/htsjdk/issues/660#issuecomment-232155965
+ GRADLE_USER_HOME="${WORKDIR}" ./gradlew build || die
+}
+
+#src_install() {
+# cd dist || die
+# java-pkg_dojar ${PN}.jar
+# java-pkg_dojar ${PN}-lib.jar
+#
+# java-pkg_dolauncher ${PN} --main picard.cmdline.PicardCommandLine
+#
+# use source && java-pkg_dosrc "${S}"/src/java/*
+# use doc && java-pkg_dojavadoc "${S}"/javadoc
+#}