aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/cernbox-client/Manifest4
-rw-r--r--net-misc/cernbox-client/cernbox-client-2.6.3.14058.ebuild (renamed from net-misc/cernbox-client/cernbox-client-2.3.2.ebuild)75
-rw-r--r--net-misc/cernbox-client/files/owncloud-client-2.6.3.14058-qt515.patch11
-rw-r--r--net-misc/cernbox-client/metadata.xml21
4 files changed, 61 insertions, 50 deletions
diff --git a/net-misc/cernbox-client/Manifest b/net-misc/cernbox-client/Manifest
index 9cc363d55..9ebdb08d0 100644
--- a/net-misc/cernbox-client/Manifest
+++ b/net-misc/cernbox-client/Manifest
@@ -1,2 +1,2 @@
-DIST cernbox-client-2.2.4-1.1.src.rpm 14208412 SHA256 1835b660026026a1fd30ef45c2f0d76fbf8efb2970399c24467c9e1611745838 SHA512 24b2a56eb7cc520271ea5f4900f86852cf34ff500b5339b63984b74a40288e30fe785fc9815937637211e7c3d8d7fde7f509f0319d676522641e04ef8192db1e WHIRLPOOL af3c11d30b77d6722c67bb561d1d6e3ab125824d3a25265d25227dfc0ef4f2198d0dfe733b0ca5a3098f59b6da08fbcdb2fac81d02b025ca3215196bf2a4e337
-DIST owncloudclient-2.3.2.tar.xz 12266008 BLAKE2B 53d08aec4971ae309b4fd07cea4e6ed9643411d4f6921c82213d55ec757abcd61ee64abc81e359ea0808b54d8447e3742fdec5394ed55b2e09805616f5430a75 SHA512 8abe071c28b365c100eb30ed91610640a25a7385f4347f5527289f4664788bda375e9618396ffa3e441c7e473da55bdaf7a5cdd99c8fd5801de78cb945fabb9c
+DIST cernbox-client-2.5.4-2719.1.src.rpm 14672426 BLAKE2B 905db6f82f135a6f1012c7e1139313f546ca1556fbde48f803a1d67df0dc24f8841407c4a7e8b39bdc51dd5a264bc464e667b0404000699b7892bb8b9c8b4f56 SHA512 9c2ff9ed01e024ec70809e159fbba952b3cc00159228f9ef15ce78160c3133c86f96b6d6281ed76bc0dbb4e00587533cbae036864b79191f4e614c9b4daaa8c7
+DIST owncloudclient-2.6.3.14058.tar.xz 21246672 BLAKE2B 15b75c2162d22c22827a057242d783e739837f618c2f65be3edce6b2678aaa13505fd14c4e4088374c240537a999d9aff7758ccb93993e0cbdebb886f735311c SHA512 e2159dc5668f263449e7a9a20ef10c6bb140ea5bd1128a6d3438abce03bc4913bb4eecbacc5160c8018398b6fa75ccfb2a9ab9ad637965e41caebc83994b80b3
diff --git a/net-misc/cernbox-client/cernbox-client-2.3.2.ebuild b/net-misc/cernbox-client/cernbox-client-2.6.3.14058.ebuild
index 9513b064b..5cb28eec0 100644
--- a/net-misc/cernbox-client/cernbox-client-2.3.2.ebuild
+++ b/net-misc/cernbox-client/cernbox-client-2.6.3.14058.ebuild
@@ -1,55 +1,50 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils rpm
+inherit cmake rpm xdg
+
+DESCRIPTION="Synchronize files from CERNBox EOS with your computer"
# Origin is classic owncloud-client, branded for CERN during compilation.
-ORIGIN_P="owncloudclient"
+ORIGIN_P="owncloud-client"
BRANDED_P="cernbox"
-BRANDED_PV="2.2.4"
-BRANDED_REL="1.1"
-
-DESCRIPTION="Synchronize files from CERNbox EOS with your computer"
+BRANDED_PV="2.5.4"
+BRANDED_REL="2719.1"
+BRANDED_TS="202002062027"
HOMEPAGE="https://cernbox.cern.ch/"
-SRC_URI="
- http://download.owncloud.com/desktop/stable/${ORIGIN_P}-${PV}.tar.xz
+SRC_URI="http://download.owncloud.com/desktop/stable/${ORIGIN_P/-}-${PV}.tar.xz
https://cernbox.cern.ch/cernbox/doc/Linux/repo/CentOS_7/src/${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm"
LICENSE="CC-BY-3.0 GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc dolphin nautilus samba +sftp test"
+IUSE="doc dolphin gnome-keyring nautilus test"
-COMMON_DEPEND="
- >=dev-db/sqlite-3.4:3
- dev-libs/qtkeychain
+COMMON_DEPEND=">=dev-db/sqlite-3.4:3
+ dev-libs/qtkeychain[gnome-keyring?,qt5(+)]
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
- dev-qt/qtnetwork:5
+ dev-qt/qtnetwork:5[ssl]
dev-qt/qtsql:5
- dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
sys-fs/inotify-tools
- virtual/libiconv
dolphin? (
kde-frameworks/kcoreaddons:5
kde-frameworks/kio:5
)
- nautilus? ( dev-python/nautilus-python )
- samba? ( >=net-fs/samba-3.5 )
- sftp? ( >=net-libs/libssh-0.5 )
-"
-RDEPEND="${COMMON_DEPEND}
- !net-misc/ocsync
- !net-misc/nextcloud-client
-"
+ nautilus? ( dev-python/nautilus-python )"
+
+RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}
dev-qt/linguist-tools:5
doc? (
dev-python/sphinx
+ dev-tex/latexmk
dev-texlive/texlive-latexextra
virtual/latex-base
)
@@ -57,43 +52,44 @@ DEPEND="${COMMON_DEPEND}
test? (
dev-util/cmocka
dev-qt/qttest:5
- )
-"
+ )"
+
+RESTRICT="!test? ( test )"
S=${WORKDIR}/owncloudclient-${PV}
+PATCHES=( "${FILESDIR}"/${ORIGIN_P}-${PV}-qt515.patch )
+
src_unpack() {
- rpm_src_unpack ${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm
- mv ${PN/-}-${BRANDED_PV}/cernbox "${S}" || die "failed to extract branding"
+ rpm_src_unpack ${PN}-${BRANDED_PV}-${BRANDED_REL}.src.rpm || die "failed to extract branding RPM"
+ mv ${PN/-}-${BRANDED_PV}.${BRANDED_TS}/cernbox "${S}" || die "failed to extract branding"
+ rm -rf "${S}/theme" || die "failed to remove vanilla theme"
+ mv ${PN/-}-${BRANDED_PV}.${BRANDED_TS}/theme "${S}" || die "failed to extract branding"
}
src_prepare() {
# Keep tests in ${T}
- sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die "sed failed"
+ sed -i -e "s#\"/tmp#\"${T}#g" test/test*.cpp || die
if ! use nautilus; then
pushd shell_integration > /dev/null || die
cmake_comment_add_subdirectory nautilus
popd > /dev/null || die
fi
- default
+ cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
-DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
- -DWITH_ICONV=ON
- -DWITH_DOC=$(usex doc)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Sphinx=$(usex !doc)
-DCMAKE_DISABLE_FIND_PACKAGE_KF5=$(usex !dolphin)
- -DBUILD_WITH_QT4=OFF
- -DCMAKE_DISABLE_FIND_PACKAGE_Libsmbclient=$(usex !samba)
- -DCMAKE_DISABLE_FIND_PACKAGE_LibSSH=$(usex !sftp)
- -DUNIT_TESTING=$(usex test)
- -DOEM_THEME_DIR=${PWD}/${BRANDED_P}/mirall
+ -DBUILD_TESTING=$(usex test)
+ -DOEM_THEME_DIR=${PWD}/${BRANDED_P}/syncclient
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {
@@ -101,4 +97,5 @@ pkg_postinst() {
elog "Documentation and man pages not installed"
elog "Enable doc USE-flag to generate them"
fi
+ xdg_pkg_postinst
}
diff --git a/net-misc/cernbox-client/files/owncloud-client-2.6.3.14058-qt515.patch b/net-misc/cernbox-client/files/owncloud-client-2.6.3.14058-qt515.patch
new file mode 100644
index 000000000..57dd20938
--- /dev/null
+++ b/net-misc/cernbox-client/files/owncloud-client-2.6.3.14058-qt515.patch
@@ -0,0 +1,11 @@
+diff -Naur owncloudclient-2.6.3.14058.orig/src/libsync/networkjobs.cpp owncloudclient-2.6.3.14058/src/libsync/networkjobs.cpp
+--- owncloudclient-2.6.3.14058.orig/src/libsync/networkjobs.cpp 2020-06-12 14:35:04.000000000 +0200
++++ owncloudclient-2.6.3.14058/src/libsync/networkjobs.cpp 2020-06-13 11:18:28.822842347 +0200
+@@ -31,6 +31,7 @@
+ #include <QJsonObject>
+ #ifndef TOKEN_AUTH_ONLY
+ #include <QPainter>
++#include <QPainterPath>
+ #endif
+
+ #include "networkjobs.h"
diff --git a/net-misc/cernbox-client/metadata.xml b/net-misc/cernbox-client/metadata.xml
index ac0a4fc58..c67ea7b66 100644
--- a/net-misc/cernbox-client/metadata.xml
+++ b/net-misc/cernbox-client/metadata.xml
@@ -1,27 +1,30 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>o.freyermuth@googlemail.com</email>
+ <name>Oliver Freyermuth</name>
+ </maintainer>
<maintainer type="project">
<email>sci-physics@gentoo.org</email>
<name>Gentoo Physics Project</name>
</maintainer>
<longdescription lang="en">
-This service provides a cloud synchronisation service for all CERN users between personal devices (like a laptop) and a centrally-managed data storage.
+ This service provides a cloud synchronisation service for all CERN users between personal devices (like a laptop) and a centrally-managed data storage.
-Available to all CERN users. This service provides synchronisation capabilities:
-everyone having a CERN computing account can use box to synchronise data (files and directories) across a series of (mobile) devices (smartphones, tablet, laptop, desktop).
-Major software distributions are supported (notably recent Mac, Linux and Windows).
+ Available to all CERN users. This service provides synchronisation capabilities:
+ everyone having a CERN computing account can use box to synchronise data (files and directories) across a series of (mobile) devices (smartphones, tablet, laptop, desktop).
+ Major software distributions are supported (notably recent Mac, Linux and Windows).
-The service provides off-line eventually synchronised access to data and it is also meant for data sharing across collaborators (for example to share presentations or text documents).
+ The service provides off-line eventually synchronised access to data and it is also meant for data sharing across collaborators (for example to share presentations or text documents).
-The service is not suitable for critical-path activities like data acquisition, world-wide data distribution and massive batch processing.
-</longdescription>
+ The service is not suitable for critical-path activities like data acquisition, world-wide data distribution and massive batch processing.
+ </longdescription>
<use>
<flag name="dolphin">Install the <pkg>kde-apps/dolphin</pkg> extension</flag>
<flag name="nautilus">Install the <pkg>gnome-base/nautilus</pkg> extension</flag>
- <flag name="sftp">Enable sftp transfer support via <pkg>net-libs/libssh</pkg></flag>
</use>
<upstream>
- <doc>http://cernbox.web.cern.ch/cernbox/00_getting_started/index.html</doc>
+ <doc>https://cernbox.web.cern.ch/cernbox/</doc>
</upstream>
</pkgmetadata>