aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/root-docs/Manifest1
-rw-r--r--app-doc/root-docs/root-docs-5.34.00.ebuild96
2 files changed, 0 insertions, 97 deletions
diff --git a/app-doc/root-docs/Manifest b/app-doc/root-docs/Manifest
index a6785d8c6..c73051d39 100644
--- a/app-doc/root-docs/Manifest
+++ b/app-doc/root-docs/Manifest
@@ -3,7 +3,6 @@ AUX root-docs-5.34-makehtml.patch 1389 RMD160 ab7affbe7b525bdfa7822784e6aa861960
DIST root_v5.32.03.source.tar.gz 55529362 RMD160 90ee828638f322c169875135b51231810dada383 SHA1 cc1125660073918d0f47e209a069be2b9e849dc3 SHA256 575057c429625df69f0fa5c303287acefff185cda8cf8d1e9a6b2d21097d5ae6
DIST root_v5.34.00.source.tar.gz 56214534 RMD160 6089493c70f94a1c4edd87ebe79adb9f3570f903 SHA1 e7c8352d92be8510b36001efb020f3eb0bf22ed1 SHA256 808e04876dbc9cfbfea54ee11ba35e90382e8ff4219dbdbe2d2236a9dadf7df1
EBUILD root-docs-5.32.03.ebuild 2680 RMD160 7afaac5cc162f05c2172438d8740ce1a1c5ad4c7 SHA1 a0ca1ee250512870547aa4d4a0421d5c803c2ed0 SHA256 b4ee9fc8e465171bafd90ef6aa6fe333a669b029d6695f299c28ed4191ea1614
-EBUILD root-docs-5.34.00.ebuild 2680 RMD160 49fa4a3adf1c2a54ed349e43acdee84cbac5e6c8 SHA1 c14c03e379c99fc99b74e8351d57441c120036aa SHA256 8b2ccf034b1bfa42ba4ed96e0931245582e62849599362eab933df36710600e5
EBUILD root-docs-9999.ebuild 2680 RMD160 49fa4a3adf1c2a54ed349e43acdee84cbac5e6c8 SHA1 c14c03e379c99fc99b74e8351d57441c120036aa SHA256 8b2ccf034b1bfa42ba4ed96e0931245582e62849599362eab933df36710600e5
MISC ChangeLog 1334 RMD160 82a11846c16c1e6d796b9edbc1d8668a1a9f0927 SHA1 982e2da4714fe70292f6c14a29c7af4e284a44e9 SHA256 04935384ea3738bc649adc33b1472bf18c2da5000f886846c0fc05c8bb6d25af
MISC metadata.xml 445 RMD160 7c03cc156077e890bc7051bb37a7bda72c4425b0 SHA1 85cd2df4d36e312634491d536aefc51d629d64a8 SHA256 00cd4d82a3a02cc4a2ac6dc347b57713f3772635f9be6987d05bb024ad9f3b72
diff --git a/app-doc/root-docs/root-docs-5.34.00.ebuild b/app-doc/root-docs/root-docs-5.34.00.ebuild
deleted file mode 100644
index ca2754851..000000000
--- a/app-doc/root-docs/root-docs-5.34.00.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/root-docs/root-docs-5.34.00.ebuild,v 1.2 2012/06/27 17:31:12 bicatali Exp $
-
-EAPI=4
-
-ROOT_PN="root"
-PATCH_PV="5.34"
-
-if [[ ${PV} == "9999" ]] ; then
- _SVN_DEP="dev-vcs/subversion"
- SRC_URI=""
- KEYWORDS=""
-else
- SRC_URI="ftp://root.cern.ch/${ROOT_PN}/${ROOT_PN}_v${PV}.source.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-inherit eutils multilib toolchain-funcs virtualx
-
-DESCRIPTION="API documentation for ROOT (An Object-Oriented Data Analysis Framework)"
-HOMEPAGE="http://root.cern.ch/"
-
-SLOT="0"
-LICENSE="LGPL-2.1"
-IUSE=""
-
-S="${WORKDIR}/${ROOT_PN}"
-VIRTUALX_REQUIRED="always"
-
-DEPEND="
- ~sci-physics/root-${PV}[X,doc,graphviz,htmldoc,opengl]
- virtual/pkgconfig
- ${_SVN_DEP}"
-RDEPEND=""
-
-pkg_setup() {
- # sandboxed user can't access video hardware, so xorg-x11 implementation
- # should be used
- GL_IMPLEM=$(eselect opengl show)
- eselect opengl set xorg-x11
-}
-
-src_unpack() {
- # can't use subversion eclass functions,
- # we need to svn export the same root tree:
- # 1) svn revisions for root and root-docs must be the same;
- # 2) no need to abuse server twice.
- if [[ ${PV} == "9999" ]] ; then
- addpredict "${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}/svn-src/${ROOT_PN}/trunk/.svn"
- svn export "${PORTAGE_ACTUAL_DISTDIR:-${DISTDIR}}/svn-src/${ROOT_PN}/trunk" \
- "${S}" || die "svn export failed"
- else
- default
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-makehtml.patch
-}
-
-src_configure() {
- # we need only to setup paths here, html docs doesn't depend on USE flags
- ./configure \
- --prefix="${EPREFIX}"/usr \
- --etcdir="${EPREFIX}"/etc/root \
- --libdir="${EPREFIX}"/usr/$(get_libdir)/${PN} \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --tutdir="${EPREFIX}"/usr/share/doc/${PF}/examples/tutorials \
- --testdir="${EPREFIX}"/usr/share/doc/${PF}/examples/tests \
- --with-cc=$(tc-getCC) \
- --with-cxx=$(tc-getCXX) \
- --with-f77=$(tc-getFC) \
- --with-ld=$(tc-getCXX) \
- --with-afs-shared=yes \
- --with-llvm-config="${EPREFIX}"/usr/bin/llvm-config \
- --with-sys-iconpath="${EPREFIX}"/usr/share/pixmaps
-}
-
-src_compile() {
- ROOTSYS="${S}" Xemake html
- # if root.exe crashes, return code will be 0 due to gdb attach,
- # so we need to check if last html file was generated;
- # this check is volatile and can't catch crash on the last file.
- [[ -f htmldoc/timespec.html ]] || die "looks like html doc generation crashed"
-}
-
-src_install() {
- dodir /usr/share/doc/${PF}
- # too large data to copy
- mv htmldoc/* "${ED}usr/share/doc/${PF}/"
-}
-
-pkg_postinst() {
- eselect opengl set ${GL_IMPLEM}
-}