aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/neovim-9999.ebuild')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
new file mode 100644
index 000000000..2f77478eb
--- /dev/null
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit cmake-utils
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="git://github.com/neovim/neovim.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Vim's rebirth for the 21st century"
+HOMEPAGE="https://github.com/neovim/neovim"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="app-admin/eselect-vi
+ sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ >=dev-libs/libuv-0.11.19"