aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/imaxima/imaxima-0.95.ebuild')
-rw-r--r--app-emacs/imaxima/imaxima-0.95.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/imaxima/imaxima-0.95.ebuild b/app-emacs/imaxima/imaxima-0.95.ebuild
new file mode 100644
index 000000000..e0fb5c645
--- /dev/null
+++ b/app-emacs/imaxima/imaxima-0.95.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils elisp
+
+MY_P="${PN}-imath-${PV}"
+DESCRIPTION="Enables graphical output in Maxima sessions with emacs"
+HOMEPAGE="http://members3.jcom.home.ne.jp/imaxima/Site/Welcome.html"
+SRC_URI="http://members3.jcom.home.ne.jp/imaxima/Site/Download%20and%20Install_files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc"
+IUSE=""
+
+DEPEND="virtual/emacs
+ virtual/tetex
+ virtual/ghostscript
+ || (>=dev-tex/breqn-0.94 app-text/texlive)
+ >=sci-mathematics/maxima-5.10"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-imaxima.el.patch
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ elisp-site-file-install ${FILESDIR}/50imaxima-gentoo.el
+ dodoc ChangeLog NEWS README
+ docinto imath-example
+ dodoc imath-example/*.txt
+}