aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/vine/files')
-rw-r--r--app-forensics/vine/files/vine-1.0-binutils.patch16
-rw-r--r--app-forensics/vine/files/vine-1.0-gcc46.patch37
-rw-r--r--app-forensics/vine/files/vine-1.0-install.patch89
-rw-r--r--app-forensics/vine/files/vine-1.0-ocamlgraph182.patch68
4 files changed, 0 insertions, 210 deletions
diff --git a/app-forensics/vine/files/vine-1.0-binutils.patch b/app-forensics/vine/files/vine-1.0-binutils.patch
deleted file mode 100644
index 737f10ce2..000000000
--- a/app-forensics/vine/files/vine-1.0-binutils.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-https://groups.google.com/d/msg/bitblaze-users/Zpg7Ddzngns/o7LNnR0qqxwJ
-
-Index: libasmir/src/disasm/asm_program.cpp
-===================================================================
---- a/libasmir/src/disasm/asm_program.cpp (older version)
-+++ b/libasmir/src/disasm/asm_program.cpp (fixed version)
-@@ -7,6 +7,11 @@
- #include "debug.h"
- #include "asm_program.h"
- #include "objdump.h"
-+/* Some versions of glibc and the binutils libiberty library give
-+ conflicting prototypes for basename(). We don't use that function
-+ anyway, but to work around the problem, make libliberty.h think
-+ that it has already been declared. */
-+#define HAVE_DECL_BASENAME 1
- #include "libiberty.h"
diff --git a/app-forensics/vine/files/vine-1.0-gcc46.patch b/app-forensics/vine/files/vine-1.0-gcc46.patch
deleted file mode 100644
index 41dc0ae40..000000000
--- a/app-forensics/vine/files/vine-1.0-gcc46.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-https://groups.google.com/d/msg/bitblaze-users/sTTPlFEzWo0/0ZjPL0QYC8IJ
-
-Index: libasmir/src/vex/irtoir-i386.cpp
-===================================================================
---- a/libasmir/src/vex/irtoir-i386.cpp (old revision)
-+++ b/libasmir/src/vex/irtoir-i386.cpp (new revision)
-@@ -9,6 +9,13 @@
- web site at: http://bitblaze.cs.berkeley.edu/
- */
-
-+/* Because we use offsetof() for values that go in switch statement
-+ cases, we need a definition in terms of __builtin_offsetof so that
-+ GCC >= 4.6 can accept the results of offsetof() as a constant
-+ expression. They've stopped supporting the traditional definition
-+ as a macro &((type*)0)->memb, which appears in VEX's headers. */
-+#include <stddef.h>
-+
- #include <string>
- #include <vector>
- #include <iostream>
-Index: libasmir/src/vex/irtoir-arm.cpp
-===================================================================
---- a/libasmir/src/vex/irtoir-arm.cpp (old revision)
-+++ b/libasmir/src/vex/irtoir-arm.cpp (new revision)
-@@ -9,6 +9,12 @@
- web site at: http://bitblaze.cs.berkeley.edu/
- */
-
-+/* Because we use offsetof() for values that go in switch statement
-+ cases, we need a definition in terms of __builtin_offsetof so that
-+ GCC >= 4.6 can accept the results of offsetof() as a constant
-+ expression. They've stopped supporting the traditional definition
-+ as a macro &((type*)0)->memb, which appears in VEX's headers. */
-+#include <stddef.h>
-
- #include "irtoir-internal.h"
- #include "libvex_guest_arm.h"
diff --git a/app-forensics/vine/files/vine-1.0-install.patch b/app-forensics/vine/files/vine-1.0-install.patch
deleted file mode 100644
index 166bd1c4e..000000000
--- a/app-forensics/vine/files/vine-1.0-install.patch
+++ /dev/null
@@ -1,89 +0,0 @@
---- a/stp/ocaml/Makefile 2009-09-24 15:45:57.000000000 -0600
-+++ b/stp/ocaml/Makefile 2013-03-14 20:22:49.993194747 -0600
-@@ -14,3 +14,6 @@
- Makefile
-
- include $(OCAMLMAKEFILE)
-+
-+install: rawinstall
-+
---- a/stp/ocaml/OCamlMakefile 2009-09-24 15:45:57.000000000 -0600
-+++ b/stp/ocaml/OCamlMakefile 2013-03-14 20:20:23.012069386 -0600
-@@ -1126,10 +1126,10 @@
- .PHONY: rawinstall
- rawinstall: all
- $(QUIET)printf "\nInstalling library to: $(OCAML_LIB_INSTALL)\n"
-- -install -d $(OCAML_LIB_INSTALL)
-+ -install -d $(DESTDIR)$(OCAML_LIB_INSTALL)
- for i in $(LIBINSTALL_FILES); do \
- if [ -f $$i ]; then \
-- install -c -m 0644 $$i $(OCAML_LIB_INSTALL); \
-+ install -c -m 0644 $$i $(DESTDIR)$(OCAML_LIB_INSTALL); \
- fi; \
- done
- $(QUIET)printf "\nInstallation successful.\n"
-
---- a/ocaml/Makefile 2009-09-24 15:45:57.000000000 -0600
-+++ b/ocaml/Makefile 2013-03-14 20:22:49.993194747 -0600
-@@ -14,3 +14,6 @@
-
-
- include $(OCAMLMAKEFILE)
-+
-+install: rawinstall
-+
---- a/ocaml/OCamlMakefile 2009-09-24 15:45:57.000000000 -0600
-+++ b/ocaml/OCamlMakefile 2013-03-14 20:20:23.012069386 -0600
-@@ -1126,10 +1126,10 @@
- .PHONY: rawinstall
- rawinstall: all
- $(QUIET)printf "\nInstalling library to: $(OCAML_LIB_INSTALL)\n"
-- -install -d $(OCAML_LIB_INSTALL)
-+ -install -d $(DESTDIR)$(OCAML_LIB_INSTALL)
- for i in $(LIBINSTALL_FILES); do \
- if [ -f $$i ]; then \
-- install -c -m 0644 $$i $(OCAML_LIB_INSTALL); \
-+ install -c -m 0644 $$i $(DESTDIR)$(OCAML_LIB_INSTALL); \
- fi; \
- done
- $(QUIET)printf "\nInstallation successful.\n"
---- a/trace/Makefile 2009-09-24 15:45:57.000000000 -0600
-+++ b/trace/Makefile 2013-03-14 20:22:49.993194747 -0600
-@@ -14,3 +14,6 @@
-
-
- include $(OCAMLMAKEFILE)
-+
-+install: rawinstall
-+
---- a/trace_utils/Makefile 2009-09-24 15:45:57.000000000 -0600
-+++ b/trace_utils/Makefile 2013-03-16 14:31:46.375690732 -0600
-@@ -88,6 +88,8 @@
- # * subprjs
-
-
-+install:
-+
-
- %:
- make -f $(OCAMLMAKEFILE) subprojs SUBTARGET=$@
---- a/utils/Makefile 2009-09-24 15:45:57.000000000 -0600
-+++ b/utils/Makefile 2013-03-16 14:31:46.375690732 -0600
-@@ -88,6 +88,8 @@
- # * subprjs
-
-
-+install:
-+
-
- %:
- make -f $(OCAMLMAKEFILE) subprojs SUBTARGET=$@
---- a/doc/Makefile 2009-09-24 15:45:57.000000000 -0600
-+++ b/doc/Makefile 2013-03-16 14:41:59.182926821 -0600
-@@ -17,3 +17,6 @@
-
- clean:
- (cd howto && $(MAKE) clean)
-+
-+install:
-+
diff --git a/app-forensics/vine/files/vine-1.0-ocamlgraph182.patch b/app-forensics/vine/files/vine-1.0-ocamlgraph182.patch
deleted file mode 100644
index e9a2f5d6a..000000000
--- a/app-forensics/vine/files/vine-1.0-ocamlgraph182.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-Index: ocaml/vine_cfg.mli
-===================================================================
---- a/ocaml/vine_cfg.mli (old version)
-+++ b/ocaml/vine_cfg.mli (new version)
-@@ -86,6 +86,11 @@
- (** [cfg#iter_edges f] calls [f a b] forall [(a,b)] where there is an edge
- vine-1.0-from [a] to [b] in the CFG. *)
-
-+ method fold_edges : 'b. ('a bb -> 'a bb -> 'b -> 'b) -> 'b -> 'b
-+ (** [cfg#fold_edges f init] computes [f uN uN (... (f u1 v1
-+init)...)] where [(u1, v1) ... (uN, vN)] is an enumeration of all
-+the edges in the graph, in an unspecified order. *)
-+
- method get_info : 'a bb -> 'a
- (** Returns the info associated with the given bb. *)
-
-@@ -225,6 +230,7 @@
- val iter_vertex : (bbid -> unit) -> t -> unit
- val fold_vertex : (vertex -> 'a -> 'a) -> t -> 'a -> 'a
- val iter_edges_e : (E.t -> unit) -> t -> unit
-+ val fold_edges_e : (E.t -> 'a -> 'a) -> t -> 'a -> 'a
- val iter_succ : (vertex -> unit) -> t -> vertex -> unit
- val iter_pred : (vertex -> unit) -> t -> vertex -> unit
- val in_degree : t -> vertex -> int
-Index: ocaml/vine_cfg.ml
-===================================================================
---- a/ocaml/vine_cfg.ml (old version)
-+++ b/ocaml/vine_cfg.ml (new version)
-@@ -115,6 +115,7 @@
- method iter_bb : ('a bb -> unit) -> unit
- method fold_bb : 'b. ('a bb -> 'b -> 'b) -> 'b -> 'b
- method iter_edges : ('a bb -> 'a bb -> unit) -> unit
-+ method fold_edges : 'b. ('a bb -> 'a bb -> 'b -> 'b) -> 'b -> 'b
- method get_info : 'a bb -> 'a
- method set_info : 'a bb -> 'a -> unit
- method get_id : 'a bb -> bbid
-@@ -306,6 +307,14 @@
- self#iter_bb (fun b -> List.iter (f b) (self#succ b));
- self#check_graph;
-
-+ method fold_edges f a =
-+ self#check_graph;
-+ let res = self#fold_bb
-+ (fun b a2 -> List.fold_left (fun a3 b2 -> f b b2 a3) a2 (self#succ b)) a
-+ in
-+ self#check_graph;
-+ res
-+
- method length = Hashtbl.length blktbl
-
- method get_info b =
-@@ -1122,6 +1131,7 @@
- val iter_vertex : (bbid -> unit) -> t -> unit
- val fold_vertex : (bbid -> 'a -> 'a) -> t -> 'a -> 'a
- val iter_edges_e : (E.t -> unit) -> t -> unit
-+ val fold_edges_e : (E.t -> 'a -> 'a) -> t -> 'a -> 'a
- val iter_succ : (vertex -> unit) -> t -> vertex -> unit
- val iter_pred : (vertex -> unit) -> t -> vertex -> unit
- val in_degree : t -> vertex -> int
-@@ -1170,6 +1180,8 @@
- let fold_vertex f (g:t) a = g#fold_bb (fun b -> f b.id) a
- let iter_edges_e f (g:t) =
- g#iter_edges (fun x y -> f (g#get_id x, g#get_id y))
-+ let fold_edges_e f (g:t) a =
-+ g#fold_edges (fun x y a -> f (g#get_id x, g#get_id y) a) a
- let iter_succ f g v = List.iter f (bb_succ g v)
- let iter_pred f g v = List.iter f (bb_pred g v)
- let in_degree g v = List.length (bb_pred g v)