aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/growler-math/growler-math-0.3.4.1.ebuild')
-rw-r--r--dev-cpp/growler-math/growler-math-0.3.4.1.ebuild24
1 files changed, 9 insertions, 15 deletions
diff --git a/dev-cpp/growler-math/growler-math-0.3.4.1.ebuild b/dev-cpp/growler-math/growler-math-0.3.4.1.ebuild
index e68a5c7ee..7b53ecb73 100644
--- a/dev-cpp/growler-math/growler-math-0.3.4.1.ebuild
+++ b/dev-cpp/growler-math/growler-math-0.3.4.1.ebuild
@@ -2,30 +2,24 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-SLOT="0"
-LICENSE="NOSA"
-
-KEYWORDS="~amd64 ~x86"
+EAPI=5
-DESCRIPTION="Growler-Math provides a set of math-related classes and functionality"
+DESCRIPTION="Math-related classes and functionality"
HOMEPAGE="http://www.nas.nasa.gov/~bgreen/growler/"
SRC_URI="${HOMEPAGE}/downloads/growler-math-${PV}.tar.gz"
+SLOT="0"
+LICENSE="NOSA"
+KEYWORDS="~amd64 ~x86"
IUSE="static"
RDEPEND=">=dev-cpp/growler-core-0.3.7"
-
DEPEND="${RDEPEND}"
-src_compile() {
+DOCS=( README NEWS AUTHORS NOSA ChangeLog )
+
+src_configure() {
econf \
$(use_enable static) \
- --enable-fast-install \
- || die "could not configure"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc README NEWS AUTHORS NOSA ChangeLog
+ --enable-fast-install
}