aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jrosetta/files/engine-build.xml2
-rw-r--r--dev-java/jrosetta/jrosetta-1.0.4.ebuild12
2 files changed, 5 insertions, 9 deletions
diff --git a/dev-java/jrosetta/files/engine-build.xml b/dev-java/jrosetta/files/engine-build.xml
index 6bbcef0f4..9ee8429f4 100644
--- a/dev-java/jrosetta/files/engine-build.xml
+++ b/dev-java/jrosetta/files/engine-build.xml
@@ -44,7 +44,7 @@
<!-- ====================================================================== -->
<path id="build.classpath">
- <pathelement location="${maven.repo.local}/com/artenum/jrosetta/jrosetta-api/1.0.4/jrosetta-api-1.0.4.jar"/>
+ <pathelement location="../jrosetta-api/target/classes"/>
</path>
<path id="build.test.classpath">
<pathelement location="${maven.repo.local}/com/artenum/jrosetta/jrosetta-api/1.0.4/jrosetta-api-1.0.4.jar"/>
diff --git a/dev-java/jrosetta/jrosetta-1.0.4.ebuild b/dev-java/jrosetta/jrosetta-1.0.4.ebuild
index 015bc8404..5fc23155c 100644
--- a/dev-java/jrosetta/jrosetta-1.0.4.ebuild
+++ b/dev-java/jrosetta/jrosetta-1.0.4.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=4
-JAVA_PKG_IUSE=""
-
inherit java-pkg-2 java-ant-2
DESCRIPTION="Provides a common base for graphical component to build a graphical console."
@@ -15,14 +13,12 @@ SRC_URI="http://maven.artenum.com/content/groups/public/com/artenum/${PN}/${PV}/
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64"
-IUSE="source"
+IUSE=""
DEPEND=">=virtual/jdk-1.5
- app-arch/unzip
- ${COMMON_DEPEND}"
+ app-arch/unzip"
-RDEPEND=">=virtual/jre-1.5
- ${COMMON_DEPEND}"
+RDEPEND=">=virtual/jre-1.5"
EANT_BUILD_TARGET="compile package"
JAVA_ANT_BSFIX_EXTRA_ARGS="--maven-cleaning"