aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/fits/Manifest2
-rw-r--r--dev-java/fits/files/01-Use-getResource-to-access-CompressTest-data-for-unit.patch137
-rw-r--r--dev-java/fits/files/02-Update-ArrayFuncsTest.java-to-JUnit-4.patch223
-rw-r--r--dev-java/fits/files/README.Gentoo44
-rw-r--r--dev-java/fits/files/build.xml84
-rw-r--r--dev-java/fits/fits-1.11.0-r1.ebuild68
-rw-r--r--dev-java/fits/fits-1.15.1.ebuild27
7 files changed, 28 insertions, 557 deletions
diff --git a/dev-java/fits/Manifest b/dev-java/fits/Manifest
index ecf89b161..dc9abd6bb 100644
--- a/dev-java/fits/Manifest
+++ b/dev-java/fits/Manifest
@@ -1 +1 @@
-DIST fits-1.11.0-src.jar 247303 BLAKE2B 2d836b943229b9d7eda1f144cf3e37a3d94f634a2aff2a177120654aef3fc6cce1bb5ba1c4d45624da5c9f08167d69a67da50cd7a110a5e7d41b47ea5a179ccf SHA512 e4ecebe139dfcd9f475c9e588c4d625472a6b147b67b9ce2eb3f08e5e43b278e9df03d86d597881c9f9a7fffbc3a4dbede75b3a76543742ceb705f136d8a9b27
+DIST fits-1.15.1.jar 531531 BLAKE2B e490d4159ee9ef5bed5359cb3c0972a4a16db9f37c0b52f454c169dfbfd1c51bcf47b941c255b1eb968a22ed3d4bd78c973209a38ab32a621d6eeaf0a7842e30 SHA512 4835bf5ac2766c9c13f3817e2fd48fc8c7304f1cc7c912dc3d5d56dfba9c705d73fcd3093a8b58afb95fb58edd799c7197e7705f189cec7853f2387bafe4fcc5
diff --git a/dev-java/fits/files/01-Use-getResource-to-access-CompressTest-data-for-unit.patch b/dev-java/fits/files/01-Use-getResource-to-access-CompressTest-data-for-unit.patch
deleted file mode 100644
index 389c233d1..000000000
--- a/dev-java/fits/files/01-Use-getResource-to-access-CompressTest-data-for-unit.patch
+++ /dev/null
@@ -1,137 +0,0 @@
-diff --git a/src/nom/tam/fits/test/CompressTest.java b/src/nom/tam/fits/test/CompressTest.java
-index dd3aad0..c6d953e 100644
---- a/src/nom/tam/fits/test/CompressTest.java
-+++ b/src/nom/tam/fits/test/CompressTest.java
-@@ -54,58 +54,57 @@ public class CompressTest {
-
- @Test
- public void testStream() throws Exception {
-- InputStream is;
-+ String is;
-
-- is = new FileInputStream("test.fits");
-+ is = "test.fits";
- assertEquals("Stream1", 300, streamRead(is, false, false));
-
-- is = new FileInputStream("test.fits.Z");
-+ is = "test.fits.Z";
- assertEquals("Stream2", 300, streamRead(is, false, false));
-
-- is = new FileInputStream("test.fits.gz");
-+ is = "test.fits.gz";
- assertEquals("Stream3", 300, streamRead(is, false, false));
-
-- is = new FileInputStream("test.fits");
-+ is = "test.fits";
- assertEquals("Stream4", 300, streamRead(is, false, true));
-
-- is = new FileInputStream("test.fits.Z");
-+ is = "test.fits.Z";
- assertEquals("Stream5", 300, streamRead(is, false, true));
-
-- is = new FileInputStream("test.fits.gz");
-+ is = "test.fits.gz";
- assertEquals("Stream6", 300, streamRead(is, false, true));
-
--
-- is = new FileInputStream("test.fits.Z");
-+ is = "test.fits.Z";
- assertEquals("Stream7", 300, streamRead(is, true, true));
-
-- is = new FileInputStream("test.fits.gz");
-+ is = "test.fits.gz";
- assertEquals("Stream8", 300, streamRead(is, true, true));
-
-- is = new FileInputStream("test.fits.bz2");
-+ is = "test.fits.bz2";
- assertEquals("Stream9", 300, streamRead(is, true, true));
- }
-
- @Test
- public void testFile() throws Exception {
-- File is = new File("test.fits");
-+ String is = "test.fits";
- assertEquals("File1", 300, fileRead(is, false, false));
-
-- is = new File("test.fits.Z");
-+ is = "test.fits.Z";
- assertEquals("File2", 300, fileRead(is, false, false));
-
-- is = new File("test.fits.gz");
-+ is = "test.fits.gz";
- assertEquals("File3", 300, fileRead(is, false, false));
-
-- is = new File("test.fits");
-+ is = "test.fits";
- assertEquals("File4", 300, fileRead(is, false, true));
-
-- is = new File("test.fits.Z");
-+ is = "test.fits.Z";
- assertEquals("File7", 300, fileRead(is, true, true));
-
-- is = new File("test.fits.gz");
-+ is = "test.fits.gz";
- assertEquals("File8", 300, fileRead(is, true, true));
-
-- is = new File("test.fits.bz2");
-+ is = "test.fits.bz2";
- assertEquals("File9", 300, fileRead(is, true, true));
- }
-
-@@ -131,7 +130,6 @@ public class CompressTest {
-
- is = "test.fits.bz2";
- assertEquals("String8", 300, stringRead(is, true, true));
--
- }
-
- @Test
-@@ -158,13 +156,9 @@ public class CompressTest {
- assertEquals("String8", 300, urlRead(is, true, true));
- }
-
-- int urlRead(String is, boolean comp, boolean useComp)
-+ int urlRead(String filename, boolean comp, boolean useComp)
- throws Exception {
-- File fil = new File(is);
--
-- String path = fil.getCanonicalPath();
-- URL u = new URL("file://" + path);
--
-+ URL u = CompressTest.class.getResource(filename);
- Fits f;
- if (useComp) {
- f = new Fits(u, comp);
-@@ -176,8 +170,9 @@ public class CompressTest {
- return total(data);
- }
-
-- int streamRead(InputStream is, boolean comp, boolean useComp)
-+ int streamRead(String filename, boolean comp, boolean useComp)
- throws Exception {
-+ InputStream is = CompressTest.class.getResourceAsStream(filename);
- Fits f;
- if (useComp) {
- f = new Fits(is, comp);
-@@ -190,8 +185,9 @@ public class CompressTest {
- return total(data);
- }
-
-- int fileRead(File is, boolean comp, boolean useComp)
-+ int fileRead(String filename, boolean comp, boolean useComp)
- throws Exception {
-+ File is = new File(CompressTest.class.getResource(filename).getPath());
- Fits f;
- if (useComp) {
- f = new Fits(is, comp);
-@@ -203,8 +199,9 @@ public class CompressTest {
- return total(data);
- }
-
-- int stringRead(String is, boolean comp, boolean useComp)
-+ int stringRead(String filename, boolean comp, boolean useComp)
- throws Exception {
-+ String is = CompressTest.class.getResource(filename).getPath();
- Fits f;
- if (useComp) {
- f = new Fits(is, comp);
diff --git a/dev-java/fits/files/02-Update-ArrayFuncsTest.java-to-JUnit-4.patch b/dev-java/fits/files/02-Update-ArrayFuncsTest.java-to-JUnit-4.patch
deleted file mode 100644
index c9cd02d55..000000000
--- a/dev-java/fits/files/02-Update-ArrayFuncsTest.java-to-JUnit-4.patch
+++ /dev/null
@@ -1,223 +0,0 @@
-From b9edd6a86e66d354b0c1d010125246d8359cbb37 Mon Sep 17 00:00:00 2001
-From: W. Trevor King <wking@drexel.edu>
-Date: Fri, 7 Oct 2011 03:44:18 -0400
-Subject: [PATCH 7/8] Update ArrayFuncsTest.java to JUnit-4.
-
----
- src/nom/tam/util/test/ArrayFuncsTest.java | 44 +++++++++++++++++++---------
- 1 files changed, 30 insertions(+), 14 deletions(-)
-
-diff --git a/src/nom/tam/util/test/ArrayFuncsTest.java b/src/nom/tam/util/test/ArrayFuncsTest.java
-index df5efb0..7ad8e51 100644
---- a/src/nom/tam/util/test/ArrayFuncsTest.java
-+++ b/src/nom/tam/util/test/ArrayFuncsTest.java
-@@ -6,6 +6,12 @@
- */
- package nom.tam.util.test;
-
-+import org.junit.Test;
-+import static org.junit.Assert.assertEquals;
-+import static org.junit.Assert.assertTrue;
-+import static org.junit.Assert.assertFalse;
-+import static org.junit.Assert.assertSame;
-+import static org.junit.Assert.assertNotSame;
- import junit.framework.*;
- import java.lang.reflect.*;
- import java.util.Arrays;
-@@ -15,21 +21,12 @@ import nom.tam.util.ArrayFuncs;
- *
- * @author Thomas McGlynn
- */
--public class ArrayFuncsTest extends TestCase {
--
-- public ArrayFuncsTest(String testName) {
-- super(testName);
-- }
--
-- protected void setUp() throws Exception {
-- }
--
-- protected void tearDown() throws Exception {
-- }
-+public class ArrayFuncsTest {
-
- /**
- * Test of computeSize method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testComputeSize() {
- System.out.println("computeSize");
-
-@@ -58,6 +55,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of nElements method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testNElements() {
- System.out.println("nElements");
-
-@@ -72,6 +70,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of deepClone method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testDeepClone() {
- int[][] test = {{0, 1}, {2, 3}, {4, 5}};
- int[][] result = (int[][]) nom.tam.util.ArrayFuncs.deepClone(test);
-@@ -96,6 +95,7 @@ public class ArrayFuncsTest extends TestCase {
- }
-
- public boolean equals(Object x) {
-+ System.out.println("checking equality");
- return (x instanceof CloneTest)
- && (((CloneTest) x).value == this.value);
- }
-@@ -104,6 +104,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of genericClone method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testGenericClone() {
- System.out.println("genericClone");
-
-@@ -126,6 +127,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of copyArray method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testCopyArray() {
- System.out.println("copyArray");
-
-@@ -138,6 +140,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of getDimensions method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testGetDimensions() {
- System.out.println("getDimensions");
-
-@@ -157,6 +160,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of getBaseArray method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testGetBaseArray() {
-
- int[][][] test = new int[2][3][4];
-@@ -169,6 +173,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of getBaseClass method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testGetBaseClass() {
- System.out.println("getBaseClass");
-
-@@ -179,6 +184,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of getBaseLength method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testGetBaseLength() {
-
- assertEquals(ArrayFuncs.getBaseLength(new int[2][3]), 4);
-@@ -195,6 +201,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of generateArray method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testGenerateArray() {
- System.out.println("generateArray");
-
-@@ -213,6 +220,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of testPattern method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testTestPattern() {
- System.out.println("testPattern");
-
-@@ -229,6 +237,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of flatten method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testFlatten() {
- System.out.println("flatten");
-
-@@ -241,6 +250,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of curl method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testCurl() {
- System.out.println("curl");
-
-@@ -259,6 +269,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of mimicArray method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testMimicArray() {
- System.out.println("mimicArray");
-
-@@ -273,6 +284,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of convertArray method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testConvertArray() {
- System.out.println("convertArray");
-
-@@ -286,7 +298,7 @@ public class ArrayFuncsTest extends TestCase {
-
- newType = int.class;
- int[][] ires = (int[][]) ArrayFuncs.convertArray(array, newType, true);
-- assertEquals(array, ires);
-+ assertSame(array, ires);
-
- ires = (int[][]) ArrayFuncs.convertArray(array, newType, false);
- assertNotSame(array, ires);
-@@ -296,6 +308,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of copyInto method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testCopyInto() {
- System.out.println("copyInto");
-
-@@ -304,13 +317,14 @@ public class ArrayFuncsTest extends TestCase {
-
- ArrayFuncs.copyInto(x, y);
-
-- assertEquals((double) x[0][0], y[0][0]);
-- assertEquals((double) x[1][2], y[1][2]);
-+ assertEquals((double) x[0][0], y[0][0], 0.01);
-+ assertEquals((double) x[1][2], y[1][2], 0.01);
- }
-
- /**
- * Test of arrayEquals method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testArrayEquals() {
- System.out.println("arrayEquals");
-
-@@ -331,6 +345,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of doubleArrayEquals method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testDoubleArrayEquals() {
-
- double x[] = {1, 2, 3};
-@@ -349,6 +364,7 @@ public class ArrayFuncsTest extends TestCase {
- /**
- * Test of floatArrayEquals method, of class nom.tam.util.ArrayFuncs.
- */
-+ @Test
- public void testFloatArrayEquals() {
- float x[] = {1f, 2f, 3f};
- float y[] = {1f, 2f, 3f};
---
-1.7.3.1.104.gc752e
-
diff --git a/dev-java/fits/files/README.Gentoo b/dev-java/fits/files/README.Gentoo
deleted file mode 100644
index 62c238cdd..000000000
--- a/dev-java/fits/files/README.Gentoo
+++ /dev/null
@@ -1,44 +0,0 @@
-I have been unable to track down a source repository for fits, so this
-ebuild straps a build system onto source unpacked from a source JAR.
-Not the greatest solution, but it's the best I can come up with. I've
-also had trouble figuring out who holds copyright and what the
-licensing terms are. If you find more authoritative information, let
-me know!
-
-Authors (listed with the first release note to mention them):
- Tom McGlynn <thomas.a.mcglynn@nasa.gov> [1,12]
- Jens Knudstrup [2]
- Alan Brighton [2]
- R.J. Mathar [3]
- Jorgo Bakker [3]
- Laurent Michel [3]
- R. Mathar [4]
- Guillame Belanger [4]
- A. Kovacs [5]
- Javier Diaz [6]
- Juan Carlos Segovia [7]
- Thomas Granzer [7]
- L. Michel [8]
- Mark Taylor [9]
- Laurent Bourges [10]
- V. Forchi [11]
-
-From [11]:
-
-> [The] build procedure for FITS library has been changed. The library
-> is now stored as a NetBeans project and the standard NetBeans build
-> script has been modified to generate the fits.jar and fits_src.jar.
-
-
-[1]: http://heasarc.gsfc.nasa.gov/docs/heasarc/fits/java/v0.9/NOTES/NOTE.v091
-[2]: http://heasarc.gsfc.nasa.gov/docs/heasarc/fits/java/v0.9/NOTES/NOTE.v093
-[3]: http://heasarc.gsfc.nasa.gov/docs/heasarc/fits/java/v0.9/NOTES/NOTE.v099
-[4]: http://heasarc.gsfc.nasa.gov/docs/heasarc/fits/java/v0.9/NOTES/NOTE.v099.1
-[5]: http://heasarc.gsfc.nasa.gov/docs/heasarc/fits/java/v0.9/NOTES/NOTE.v099.5
-[6]: http://heasarc.gsfc.nasa.gov/docs/heasarc/fits/java/v1.0/NOTE.v100.1
-[7]: http://heasarc.gsfc.nasa.gov/docs/heasarc/fits/java/v1.0/NOTE.v101.0
-[8]: http://heasarc.gsfc.nasa.gov/docs/heasarc/fits/java/v1.0/NOTE.v102.0
-[9]: http://heasarc.gsfc.nasa.gov/docs/heasarc/fits/java/v1.0/NOTE.v104.0
-[10]: http://heasarc.gsfc.nasa.gov/docs/heasarc/fits/java/v1.0/NOTE.v105.0
-[11]: http://heasarc.gsfc.nasa.gov/docs/heasarc/fits/java/v1.0/NOTE.v105.1
-[12]: http://asd.gsfc.nasa.gov/Thomas.McGlynn/
diff --git a/dev-java/fits/files/build.xml b/dev-java/fits/files/build.xml
deleted file mode 100644
index d8aa41b85..000000000
--- a/dev-java/fits/files/build.xml
+++ /dev/null
@@ -1,84 +0,0 @@
-<?xml version="1.0"?>
-<project name="fits" default="all" basedir=".">
- <target name="init" description="Sets build properties">
- <!-- package configuration -->
- <property name="package.version" value="devel"/>
- <!-- directory locations -->
- <property name="src" value="${basedir}/src"/>
- <property name="build" value="${basedir}/build"/>
- <property name="doc" value="${basedir}/doc"/>
- <property name="doc.api" value="${doc}/api"/>
- <!-- external dependencies -->
- <property name="junit.jar" value="junit.jar"/>
- <!-- classpaths -->
- <path id="project.class.path">
- </path>
- <path id="build.class.path">
- <pathelement location="${junit.jar}"/>
- </path>
- <path id="test.class.path">
- <pathelement location="${build}"/>
- </path>
- </target>
- <target name="all" depends="jar,javadoc"
- description="Pseudo-target that builds JAR and Javadoc">
- </target>
- <target name="build" depends="init"
- description="Compiles the classes">
- <mkdir dir="${build}"/>
- <javac destdir="${build}" srcdir="${src}" debug="true"
- deprecation="true" includeantruntime="false">
- <classpath refid="project.class.path"/>
- <classpath refid="build.class.path"/>
- <!--compilerarg line="-Xlint:unchecked"/-->
- </javac>
- <copy todir="${build}">
- <mappedresources>
- <fileset dir="${src}" includes="**/test/test.fits*"/>
- <globmapper from="*" to="*"/>
- </mappedresources>
- </copy>
- </target>
- <target name="test" depends="build">
- <junit>
- <classpath refid="project.class.path" />
- <classpath refid="test.class.path"/>
- <formatter type="brief" usefile="false" />
- <batchtest>
- <fileset dir="${build}">
- <include name="**/test/*.class" />
- <exclude name="**/*$*.class" />
- </fileset>
- </batchtest>
- </junit>
- </target>
- <target name="javadoc" depends="init"
- description="Generates Javadoc API documentation">
- <mkdir dir="${doc.api}"/>
- <javadoc packagenames="*"
- sourcepath="${src}" destdir="${doc.api}"
- author="true" version="true"
- use="true" private="true">
- <classpath refid="project.class.path" />
- <classpath refid="build.class.path"/>
- </javadoc>
- </target>
- <target name="jar" depends="build"
- description="Builds a project JAR file">
- <jar basedir="${build}" jarfile="${build}/fits.jar">
- <manifest>
- <attribute name="Version" value="${package.version}"/>
- </manifest>
- </jar>
- </target>
- <target name="clean" depends="init"
- description="Erase all generated files and dirs">
- <delete dir="${build}" verbose="true"/>
- <delete dir="${doc}/api" verbose="true"/>
- <delete verbose="true">
- <fileset dir="${basedir}" includes="*.fits"/>
- <fileset dir="${basedir}" includes="*.fil"/>
- <fileset dir="${basedir}" includes="*.hdr"/>
- </delete>
- </target>
-</project>
diff --git a/dev-java/fits/fits-1.11.0-r1.ebuild b/dev-java/fits/fits-1.11.0-r1.ebuild
deleted file mode 100644
index 18daa2e84..000000000
--- a/dev-java/fits/fits-1.11.0-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Java library for FITS input/output"
-HOMEPAGE="http://fits.gsfc.nasa.gov/fits_libraries.html#java_tam"
-SRC_URI="http://heasarc.gsfc.nasa.gov/docs/heasarc/${PN}/java/v1.0/v${PV}/${PN}_src.jar -> ${P}-src.jar"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-CDEPEND="dev-java/junit:4"
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.5"
-DEPEND="${CDEPEND}
- >=virtual/jdk-1.5
- test? ( dev-java/ant-junit4:0 )"
-
-EANT_EXTRA_ARGS="-Dpackage.version=${PV}"
-JAVA_ANT_REWRITE_CLASSPATH="true"
-EANT_GENTOO_CLASSPATH="junit-4"
-
-src_unpack() {
- mkdir -p ${P}/src && cd ${P}/src || die
- unpack ${A}
-}
-
-java_prepare() {
- cd "${S}" || die
- cp "${FILESDIR}"/README.Gentoo "${FILESDIR}"/build.xml . || die
- epatch \
- "${FILESDIR}"/01-Use-getResource-to-access-CompressTest-data-for-unit.patch \
- "${FILESDIR}"/02-Update-ArrayFuncsTest.java-to-JUnit-4.patch
-
- if ! use test; then
- find "${S}" \( -name "*Test.java" -o -name "*Tester.java" \) -print -delete || die
- fi
-
- # from http://heasarc.gsfc.nasa.gov/docs/heasarc/fits/java/v1.0/NOTE.v111.0:
- # The source code JAR (fits_src.jar) includes a number of new classes for
- # which the corresponding class files are not included in fits.jar. These
- # classes are pre-alpha versions of support for tile compressed data that
- # is being developed. Interested Users may take a look at these, but they
- # definitely are not expected to work today.
- rm src/nom/tam/image/comp/Quantizer.java \
- src/nom/tam/image/comp/RealStats.java \
- src/nom/tam/image/comp/TiledImageHDU.java \
- src/nom/tam/image/QuantizeRandoms.java \
- src/nom/tam/image/TileDescriptor.java \
- src/nom/tam/image/TileLooper.java || die
-}
-
-src_test() {
- ANT_TASKS="ant-junit4" java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_dojar build/${PN}.jar
- use doc && java-pkg_dojavadoc doc/api
- use source && java-pkg_dosrc src/*
-}
diff --git a/dev-java/fits/fits-1.15.1.ebuild b/dev-java/fits/fits-1.15.1.ebuild
new file mode 100644
index 000000000..59a0801df
--- /dev/null
+++ b/dev-java/fits/fits-1.15.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit java-utils-2
+
+DESCRIPTION="Java library for FITS input/output"
+HOMEPAGE="http://fits.gsfc.nasa.gov/fits_libraries.html#java_tam"
+SRC_URI="http://heasarc.gsfc.nasa.gov/docs/heasarc/${PN}/java/v1.0/v${PV}/${PN}.jar -> ${P}.jar"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ # nothing to do here
+ return
+}
+
+src_install() {
+ java-pkg_newjar "${DISTDIR}/${P}.jar" "${PN}.jar"
+}